Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 17:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обыкновенное уравнение (в отчёте)  (Прочитано 431 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
Отчёт->макет->табличный документ насколько я понимаю...

К примеру, в ячейке r1c1 задано значение x1, в r1c2 значение x2, а в r1c3 должна получиться сумма x1 и x2. Как это записать на встроенном языке?

ТабДок.Область("R1C3").Текст = Число(ТабДок.Область("R1C1").Текст) + Число(ТабДок.Область("R1C2").Текст);

Так тоже ничего:

ТабДок.Область("r1c3").Значение = ТабДок.Область("r1c1").Значение + ТабДок.Область("r1c2").Значение;

P.S. Ячейки r1c1 и r1c2 в виде текста и параметра пробовал ставить

P.P.S. Посоветуйте литературу по теме


Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
 &НаКлиенте
Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)

ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);

КонецПроцедуры


&НаКлиенте
Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт

ПозицияКолонки = Найти(Область.Имя,"C");
Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
Колонка = Сред(Область.Имя, ПозицияКолонки);

Если Колонка = "C1" или Колонка = "C2" Тогда
Попытка
Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
Исключение
КонецПопытки;
КонецЕсли;

КонецФункции

Это сложение двух чисел, а как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 403
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1189
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 524
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7673
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1205
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
66 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 378
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal