Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 20:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Инициализация внешней обработки табличных частей  (Прочитано 4045 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите пожалуйста:  Есть процедура заполнения табличной части в модуле объекта, как перенести ее во внешнию  обработку табличных частей.
 * Я создал новую обработку,
 *добавил реквизит СсылкаНаОбъект со ссылкой на документ.
* В модуле объекта прописал


Процедура Инициализировать(СсылкаНаОбъект,ИмяТабличнойЧасти,Объект) Экспорт
   
   
   
   Дата = СсылкаНаОбъект.Дата;
   Склад = СсылкаНаОбъект.Склад;
   Организация =  СсылкаНаОбъект.Организация;
   Товары = СсылкаНаОбъект.Товары;
   
   Если Товары.Количество() > 0 Тогда
     
      ТекстВопроса = "Перед заполнением табличная часть будет очищена. Заполнить?";
      Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да, Метаданные().Синоним);
      Если Ответ <> КодВозвратаДиалога.Да Тогда
         Возврат;
      КонецЕсли;
     
      СсылкаНаОбъект.Товары.Очистить();
   КонецЕсли;
   
   
   ЗаполнитьОстаткамиНаМЦ4();

   Запрос = Новый Запрос;
КонецПроцедуры


Процедура ЗаполнитьОстаткамиНаМЦ4()Экспорт;
   
(здесь процедура которая заполняет таб часть Товары   )
   
   КонецПроцедуры



* В режиме предприятия добавил новую внешнию. В документе появился пункт на закладке Заполнить. Но при нажатии никакой реакции.
Преподаватель, программист...и просто хороший человек


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
А причем тут "Инициализация внешней обработки" в разделе "ПОЛЕЗНЫЕ ССЫЛКИ для скачивания"?  :^454^:
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6082
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3464
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 181
Последний ответ 24 Авг 2017, 10:43
от Golickoff
Пропадают начисления отпусков после обработки "Перерасчета зарплаты организации"

Автор bartolomewРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 651
Последний ответ 19 Июл 2016, 10:43
от bartolomew
Посоветуйте материалы для изучения объекта конфигурации "Обработки"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3218
Последний ответ 17 Фев 2011, 11:18
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal