Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Сен 2020, 19:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура Инициализации при создании внешней обработки таб. частей  (Прочитано 15592 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн crow1983

  • ****
  • Сообщений: 441
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите пожалуйста:  Есть процедура заполнения табличной части в модуле объекта, как перенести ее во внешнию  обработку табличных частей.
 * Я создал новую обработку,
 *добавил реквизит СсылкаНаОбъект со ссылкой на документ.
* В модуле объекта прописал


Процедура Инициализировать(СсылкаНаОбъект,ИмяТабличнойЧасти,Объект) Экспорт
   
   
   
   Дата = СсылкаНаОбъект.Дата;
   Склад = СсылкаНаОбъект.Склад;
   Организация =  СсылкаНаОбъект.Организация;
   Товары = СсылкаНаОбъект.Товары;
   
   Если Товары.Количество() > 0 Тогда
      
      ТекстВопроса = "Перед заполнением табличная часть будет очищена. Заполнить?";
      Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да, Метаданные().Синоним);
      Если Ответ <> КодВозвратаДиалога.Да Тогда
         Возврат;
      КонецЕсли;
      
      СсылкаНаОбъект.Товары.Очистить();
   КонецЕсли;
   
   
   ЗаполнитьОстаткамиНаМЦ4();

   Запрос = Новый Запрос;
КонецПроцедуры


Процедура ЗаполнитьОстаткамиНаМЦ4()Экспорт;
   
(здесь процедура которая заполняет таб часть Товары   )
   
   КонецПроцедуры



* В режиме предприятия добавил новую внешнию. В документе появился пункт на закладке Заполнить. Но при нажатии никакой реакции.



Преподаватель, программист...и просто хороший человек


Оффлайн crow1983

  • ****
  • Сообщений: 441
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Преподаватель, программист...и просто хороший человек

Оффлайн Limonka

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2010-07-29
  • Сайт: 
  • Профессия: Программист 1С
может поможет ссылка?

http://itprovince.blogspot.com/2009/11/blog-post_27.html

и еще... может вместо
ЗаполнитьОстаткамиНаМЦ4()Экспорт
нужно ЗаполнитьОстаткамиНаМЦ4(Форма)

и может вообще без нее обойтись? можно все заполнение в Инициализировать прописать

Оффлайн crow1983

  • ****
  • Сообщений: 441
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Все сделал.

Процедура Инициализировать(Объект, ИмяКнопки, РасшифровкаКнопки) Экспорт

    ДокументОбъект = Объект;
    СсылкаНаОбъект = Оюъект.Ссылка;

   Док = ДокументОбъект;
 
  Товары = Док.Товары;
  Дата = Док.Дата;
 ...........................
КонецПроцедуры
Преподаватель, программист...и просто хороший человек


Теги:
 

Печать этикеток из обработки "Печать этикеток" УПП 1.3

Автор EgorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1047
Последний ответ 23 Авг 2019, 05:56
от Egor
Изменение дополнительных реквизитов справочника при помощи обработки "Групповое изменение реквизито"

Автор arch_vectorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3379
Последний ответ 22 Дек 2018, 10:48
от alex0402
Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 8476
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4461
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 825
Последний ответ 24 Авг 2017, 10:43
от Golickoff

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
oooo800
33 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
23 Сообщений
DmitriyF DmitriyF
16 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 577
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal