Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обыкновенное уравнение (в отчёте)  (Прочитано 997 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
Отчёт->макет->табличный документ насколько я понимаю...

К примеру, в ячейке r1c1 задано значение x1, в r1c2 значение x2, а в r1c3 должна получиться сумма x1 и x2. Как это правильно записать на встроенном языке?

Процедура ПолеТабличногоДокументаПриИзмененииСодержимогоОбласти(Элемент, Область)
ТабДок.Область("R1C3").Текст = Число(ТабДок.Область("R1C1").Текст) + Число(ТабДок.Область("R1C2").Текст);
КонецПроцедуры

P.S. Посоветуйте литературу по теме


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
в подавляющем большинстве:
макет - ячейка - параметр
который потом в коде заполняется каким либо значением
табдок только ПОКАЗЫВАЕТ готовый результат

посему: складывать нужно значения которые заполняют параметры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
Вроде не робит или я что-то не так делаю...так тоже ничего...

ТабДок.Область("r1c3").Значение = ТабДок.Область("r1c1").Значение + ТабДок.Область("r1c2").Значение;

P.S. Ячейки r1c1 и r1c2 в виде текста и параметра пробовал ставить

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
весь мир 1С-ников (правильный) пишет так:

...
ОбластьМакета.Параметры.Параметр1 = Переменная1;
ОбластьМакета.Параметры.Параметр2 = Переменная2;
ОбластьМакета.Параметры.Сумма = Переменная1 + Переменная2; //!!!
...

ни разу не видел, что бы так извращались, как предлагаете вы
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
LexaK, мало значит видел еще в мире 1С =))
Добавлено: 07 Мар 2015, 01:54

LexaK, как ты реализуешь на ТабДоке расчет произвольного количества формул?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Ник8

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-03
  • Сайт: 
 &НаКлиенте
Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)

ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);

КонецПроцедуры


&НаКлиенте
Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт

ПозицияКолонки = Найти(Область.Имя,"C");
Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
Колонка = Сред(Область.Имя, ПозицияКолонки);

Если Колонка = "C1" или Колонка = "C2" Тогда
Попытка
Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
Исключение
КонецПопытки;
КонецЕсли;

КонецФункции

Это сложение двух чисел, а как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вы всегда можете самостоятельно разработать "MatCad". 1С именно для этого и разрабатывалась. 

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Это сложение двух чисел, а как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7

ИМХО не следует превращать обычный ТабДок в Эксель - не его это предназначение...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 359
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1127
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 467
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7325
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1165
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 292
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal