Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 11:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор именинников при запуске системы  (Прочитано 1231 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
    Здравствуйте. Недавно посмотрел урок Чистова по созданию списка именинников при запуске системы, но там было для всего справочника *Работники*.
А вот если есть в справочнике *Работники* еще и папка *Уволенные*, то как добавить содержимое этой папки в исключения, чтобы при запуске программы именинники из этой группы не находились.
Помогите пожалуйста.


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Если Сотр.Родитель.Наименвоание <> "Уволеные" Тогда

|И Сотр.Родитель.Наименование <> "Уволеные"

Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Если Сотр.Родитель.Наименвоание <> "Уволеные" Тогда

|И Сотр.Родитель.Наименование <> "Уволеные"
Я конечно извиняюсь, но я чтото не понимаю. Копирую я Ваш код, дописываю его, получается:

если Сотр.Родитель.Наименование <> "Уволеные" Тогда
         продолжить
      иначе отказ = истина;
         конецесли;

система говорит: *Переменная не определена (Сотр)*.
Вот полный код:

Функция ПолучитьСписокИменинников() Экспорт
   
   ТД_День =   День(ТекущаяДата());
   ТД_Месяц = Месяц(ТекущаяДата());
   
   //Создаю пустой массив
   Массив = Новый Массив();
   
   Выборка = Справочники.Сотрудники.Выбрать();
   Пока Выборка.Следующий() Цикл
      
      Если Выборка.ЭтоГруппа Тогда
         Продолжить;
      КонецЕсли;
      если Сотр.Родитель.Наименование <> "Уволеные" Тогда
         продолжить
      иначе отказ = истина;
         конецесли;
         
      ДР_День =   День(Выборка.ДатаРождения);
      ДР_Месяц = Месяц(Выборка.ДатаРождения);
      
      Если ДР_Месяц = ТД_Месяц И ДР_День = ТД_День Тогда
         //Добавляю новый элемент в массив
         Массив.Добавить(Выборка.Наименование);
      КонецЕсли;
   КонецЦикла;
   
   Возврат Массив;
КонецФункции
 Вы либо напишите так, чтобы работало и понятно было, либо не пишите вообще. А то на чем был на том и остался. Извините, если грубо получилось.

Оффлайн Клуб 01С

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-22
  • Сайт: 
  • Профессия: Консультант 1С
    Здравствуйте. Недавно посмотрел урок Чистова по созданию списка именинников при запуске системы, но там было для всего справочника *Работники*.
А вот если есть в справочнике *Работники* еще и папка *Уволенные*, то как добавить содержимое этой папки в исключения, чтобы при запуске программы именинники из этой группы не находились.
Помогите пожалуйста.

x-01c@lenta.ru сюда базу и посмотрю.


Теги:
 

выбор параметра "Склад" в отчёте.

Автор The KAINРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 819
Последний ответ 22 Июн 2016, 08:11
от The KAIN
Как записать в поле ввода "Единица Измерения", которое заполняется через выбор из формы.

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 287
Последний ответ 12 Окт 2017, 14:30
от Ivan94
Выбор элементов из ТЧ одного документа для переноса в ТЧ другого документа

Автор Никита ВикторовичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 100
Последний ответ 01 Дек 2017, 19:29
от Никита Викторович
Значение параметра "ВыбраннаяСтрока" в событии Выбор Табличного поля.

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7655
Последний ответ 09 Дек 2013, 15:03
от Katish
фильтр в табличной части документа на выбор значений пользователем из справочника по условию

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 297
Последний ответ 20 Июл 2017, 16:33
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
53 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal