Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет проведения "Реализация товаров и услуг" при условии  (Прочитано 1885 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dmkovpak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-16
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток. Подскажите, пожалуйста, в УТ10.3 заведено две организации, например: "Фирма1" и "Фирма2".
В справочнике "Номенклатура" добавлен реквизит "ТолькоФирма2", тип "Булево".
Как сделать так, чтобы при проведении документа "Реализация товаров и услуг" от организации "Фирма1", если в нем есть номенклатура с реквизитом "ТолькоФирма2", документ не проводился и выдавал соответствующее сообщение?


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
В обработке проведения:
Для каждого ст из Товары цикл
Если ст.Номенклатура.ТолькоФирма2 Тогда
Отказ = истина;
КонецЕслИ;
КонецЦикла;
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн dmkovpak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-16
  • Сайт: 
  • Профессия: Ученик 1С
Огромное спасибо. Получилось.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В обработке проведения:
Для каждого ст из Товары цикл
Если ст.Номенклатура.ТолькоФирма2 Тогда
Отказ = истина;
КонецЕслИ;
КонецЦикла;


а где условие на Фирма1?
у вас все документы по Фирма2 проводится перестанут.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн dmkovpak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-16
  • Сайт: 
  • Профессия: Ученик 1С
В обработке проведения:
Для каждого ст из Товары цикл
Если ст.Номенклатура.ТолькоФирма2 Тогда
Отказ = истина;
КонецЕслИ;
КонецЦикла;


а где условие на Фирма1?
у вас все документы по Фирма2 проводится перестанут.
Условие я конечно же добавил. Спасибо.


Теги:
 

Продавец товаров, утилизация которых предусмотрена в законе, имеет право списать траты на их выкуп после окончания срока годности в налоговые расходы

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1318
Последний ответ 03 Июн 2014, 11:58
от news
Как синхронизировать остатки по складу розничный и остатки товаров в рознице??

Автор rappaparradiРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4588
Последний ответ 31 Окт 2013, 11:00
от vic1804
Возврат товаров поставщику отменяет закрытие заказа поставщику

Автор kiksiРаздел Пользователям "1С - Предприятие 8"

Ответов: 8
Просмотров: 3584
Последний ответ 17 Сен 2014, 21:04
от Eugeneer
Аванс в счет будущих поставок товаров, даже если этот товар был позже возвращен, должен включаться в базу по НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1094
Последний ответ 22 Сен 2014, 11:53
от news
Как перенести возврат товаров из Розницы в Бухгалтерию? При обмене данных из Отчета о розничных продажах не отражается на 50 и 41 счетах

Автор Natalya77-09Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2943
Последний ответ 19 Фев 2014, 00:27
от Natalya77-09

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal