Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Упорядочить итоги запроса по дням.  (Прочитано 4837 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Здравствуйте!Подскажите,пожалуйста,как в следующем запросе упорядочить итоги по дням.Просто при выводе результатов в таблицу,они идут вразнобой.Спасибо.
// подготовка и выполнение запроса
Запрос = Новый Запрос("ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ХозрасчетныйОстаткиИОбороты.Субконто1 КАК БанковскийСчет,
| ХозрасчетныйОстаткиИОбороты.Регистратор КАК Регистратор,
| ХозрасчетныйОстаткиИОбороты.СуммаОборотДт,
| ХозрасчетныйОстаткиИОбороты.СуммаОборотКт,
| ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
| ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт,
| ХозрасчетныйОстаткиИОбороты.Регистратор.Номер КАК НомерПЛ,
| ХозрасчетныйОстаткиИОбороты.ВалютнаяСуммаНачальныйОстатокДт,
| ХозрасчетныйОстаткиИОбороты.ВалютнаяСуммаКонечныйОстатокДт,
| ХозрасчетныйОстаткиИОбороты.ВалютнаяСуммаОборотДт,
| ХозрасчетныйОстаткиИОбороты.ВалютнаяСуммаОборотКт,
| НАЧАЛОПЕРИОДА(ХозрасчетныйОстаткиИОбороты.Период, ДЕНЬ) КАК День,
| ХозрасчетныйОстаткиИОбороты.Субконто1.ВалютаДенежныхСредств КАК Валюта
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(
| &ДатаНачала,
| &ДатаОкончания,
| Запись,
| ,
| Счет В ИЕРАРХИИ (ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.РасчетныеСчета))
| ИЛИ Счет В ИЕРАРХИИ (ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ВалютныеСчета)),
| ,
| Субконто1 = &БанковскийСчет
| ИЛИ (НЕ &ОтборПоБанковскимСчетам)) КАК ХозрасчетныйОстаткиИОбороты
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
| День

|ИТОГИ ПО
| День,
| БанковскийСчет");
Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДатаОкончания));
Запрос.УстановитьПараметр("БанковскийСчет", БанковскийСчет);
Запрос.УстановитьПараметр("ОтборПоБанковскимСчетам", ЗначениеЗаполнено(БанковскийСчет));

Результат = Запрос.Выполнить();

// подготовка табличного документа
ЭлементыФормы.ПолеТабличногоДокумента1.Очистить();

Макет = ПолучитьМакет("Макет");

ВыборкаПоДням = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "День");
Пока ВыборкаПоДням.Следующий() Цикл
ВыборкаПоБС = ВыборкапоДням.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "БанковскийСчет");
Пока ВыборкаПоБС.Следующий() Цикл
Область = Макет.ПолучитьОбласть("Шапка");
Область.Параметры.Заполнить(ВыборкаПоБС);
Если ВыборкаПоБС.Валюта <> Рубли Тогда
Область.Параметры.ОстатокНач = ВыборкаПоБС.ВалютнаяСуммаНачальныйОстатокДт;
Иначе
Область.Параметры.ОстатокНач = ВыборкаПоБС.СуммаНачальныйОстатокДт;
КонецЕсли;
ЭлементыФормы.ПолеТабличногоДокумента1.Вывести(Область);
Выборка = ВыборкаПоБС.Выбрать();
Пока Выборка.Следующий() Цикл
Область = Макет.ПолучитьОбласть("Строка");
Для Каждого Параметр Из Область.Параметры Цикл
Параметр = "";
КонецЦикла;
Область.Параметры.Заполнить(Выборка);
Если ВыборкаПоБС.Валюта <> Рубли Тогда
Если Выборка.ВалютнаяСуммаОборотДт > 0 Тогда
Область.Параметры.СуммаОборотДт = Выборка.ВалютнаяСуммаОборотДт;
КонецЕсли;
Если Выборка.ВалютнаяСуммаОборотКт > 0 Тогда
Область.Параметры.СуммаОборотКт = Выборка.ВалютнаяСуммаОборотКт;
КонецЕсли;
КонецЕсли;

Если ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер") Тогда
Область.Параметры.КонтрагентКт = Выборка.Регистратор.ПринятоОт;
Область.Параметры.НазначениеПлатежаКт = Выборка.Регистратор.Основание;
ИначеЕсли ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.РасходныйКассовыйОрдер") Тогда
Область.Параметры.КонтрагентДт = Выборка.Регистратор.Выдать;
Область.Параметры.НазначениеПлатежаДт = Выборка.Регистратор.Основание;
ИначеЕсли ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПлатежноеПоручениеВходящее")
ИЛИ ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПлатежноеТребованиеВыставленное")
ИЛИ ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПлатежныйОрдерПоступлениеДенежныхСредств") Тогда
Область.Параметры.КонтрагентДт = Выборка.Регистратор.Контрагент;
Область.Параметры.НазначениеПлатежаДт = Выборка.Регистратор.НазначениеПлатежа;
ИначеЕсли ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПлатежноеПоручениеИсходящее")
ИЛИ ТипЗнч(Выборка.Регистратор) = Тип("ДокументСсылка.ПлатежныйОрдерСписаниеДенежныхСредств") Тогда
Область.Параметры.КонтрагентКт = Выборка.Регистратор.Контрагент;
Область.Параметры.НазначениеПлатежаКт = Выборка.Регистратор.НазначениеПлатежа;
Иначе // что-либо другое

КонецЕсли;

ЭлементыФормы.ПолеТабличногоДокумента1.Вывести(Область);
КонецЦикла;
Область = Макет.ПолучитьОбласть("Подвал");
Область.Параметры.Заполнить(ВыборкаПоБС);
Если ВыборкаПоБС.Валюта <> Рубли Тогда
Область.Параметры.СуммаОборотДт = ВыборкаПоБС.ВалютнаяСуммаоборотДт;
Область.Параметры.СуммаОборотКт = ВыборкаПоБС.ВалютнаяСуммаоборотКт;
Область.Параметры.ОстатокКон = ВыборкаПоБС.ВалютнаяСуммаНачальныйОстатокДт;
Иначе
Область.Параметры.ОстатокКон = ВыборкаПоБС.СуммаНачальныйОстатокДт;
КонецЕсли;
ЭлементыФормы.ПолеТабличногоДокумента1.Вывести(Область);
КонецЦикла;
КонецЦикла;



Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Для начала в секции упорядочить по попробуй поменять местами День и Регистратор

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Спасибо большое.А ещё у меня такой вопрос.Когда выводится результат в виде таблицы,то почему-то заполняются не все графы.В чём может быть причина?

Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Проверяй правильность заполнения параметром у областей макета

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Или в макете есть поле с параметром, а в свойствах ячейки забыли указать что параметр
Преподаватель, программист...и просто хороший человек

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
У меня почему-то до июня заполняются только графы таблицы СуммаОборотДт и СуммаОборотКт,а начиная с июня всё как надо заполняется.Почему так может быть?


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12189
Последний ответ 14 Июн 2012, 17:44
от Alex1111
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 3231
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 723
Последний ответ 15 Июн 2017, 07:53
от mvk843
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 438
Последний ответ 29 Май 2017, 15:29
от alex0402
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11914
Последний ответ 21 Апр 2011, 16:00
от Marta_Li

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 194
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal