Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает обработка помогите. Не могу понять по чему. УТ11  (Прочитано 1340 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vladimir19901

  • Все просто!!!)
  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-10
  • Сайт: 
  • Профессия: Программист 1С
вод код:
&НаКлиенте
Перем ТаблНом;


&НаКлиенте

Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();
       //    Размещение    =    Справочники.Склады.ПустаяСсылка();

    //Объект[ИмяТабличнойЧасти].Очистить();

    //Если не ТипЗнч(Объект.СкладГруппа)= Тип("СправочникСсылка.Склады") Тогда

    //    Сообщить("Не выбран склад. Размещение не будет заполнео");

    //ИначеЕсли Объект.СкладГруппа=Справочники.Склады.ПустаяСсылка() Тогда

    //    Сообщить("Не выбран склад. Размещение не будет заполнео");

    //Иначе

    //    Размещение=Объект.СкладГруппа.ссылка;

    //КонецЕсли;   


    //ПолучитьВсюНоменклатуру();

    Попытка
        Эксель = Новый COMОбъект("Excel.Application");
    Исключение
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;
   
   
    //Теперь используя переменную Эксель можно управлять приложением Excel.

   
    //    Внимание! Microsoft Excel должен быть установлен на компьютере!

   
   
    //Следующая команда откроет книгу:

   
    // Выбор файла с просмотром

    ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    //ДиалогФыбораФайла.Фильтр = "Картинка (*.bmp)|*.bmp|Картинка формата jpg (*.jpg)|*.jpg";

    ДиалогФыбораФайла.Заголовок = "Выберите файл";
    ДиалогФыбораФайла.ПредварительныйПросмотр = ложь;
    ДиалогФыбораФайла.ИндексФильтра = 0;
    Если ДиалогФыбораФайла.Выбрать() Тогда
        ПутьКФайлу=ДиалогФыбораФайла.ПолноеИмяФайла;
        Сообщить(ПутьКФайлу);
    КонецЕсли;
    ЗаполнитьТабл();
    НомерПервойСтроки=10;
    НомерЛиста=1;
    //НомерКолонки0=1;  //номер строки

    НомерКолонки1=2;  // штрихкод

    //НомерКолонки2=5;  //кол

    НомерКолонки3=2;  //наименование

    НомерКолонки4=3; //Количество

    //***

   
   
   
    Книга = Эксель.WorkBooks.Open(ПутьКФайлу);
   
   
    //Перед тем, как начать считывание данных, укажем лист книги, с которого будем считывать данные:

   
    Лист = Книга.WorkSheets(НомерЛиста);
   
   
    //Нумерация листов книги начинается с 1. Общее количество листов можно получить, используя следующую команду:

   
    КоличествоЛистов = Книга.Sheets.Count;
   
   
    //Лист можно выбрать по имени листа в книге:

   
    //Лист = Книга.WorkSheets(ИмяЛиста);

   
   
    //Имя листа в книге можно получить по номеру:

   
    //ИмяЛиста = Книга.Sheets(НомерЛиста).Name;

   
   
    //Итак, мы открыли книгу и выбрали лист, теперь посмотрим, сколько строк и колонок на выбранном листе:

   
    //ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;

    ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;
    Для НомерСтроки=НомерПервойСтроки по ВсегоСтрок Цикл
        // Значение1=СокрЛп(Лист.Cells(НомерСтроки, НомерКолонки1).Value);

        // Значение2=СокрЛп(Лист.Cells(НомерСтроки, НомерКолонки2).Value);

        //Значение0=Лист.Cells(НомерСтроки, НомерКолонки0).Value; //номер строки

        Значение0=НомерСтроки;
        Значение1=Сокрлп(Лист.Cells(НомерСтроки, НомерКолонки3).Value);// штрихкод

        Значение2=Лист.Cells(НомерСтроки, НомерКолонки4).Value; //кол

        Значение4=Сокрлп(Лист.Cells(НомерСтроки, НомерКолонки1).Value);
        Значение3=Лист.Cells(НомерСтроки, НомерКолонки3).Value; //наименование

       
        Если Значение1 = "" Тогда
            Значение1= ""
        КонецЕсли;
             
        Попытка
            Значение1=Строка(СокрЛП(Значение1));
            Значение2=Строка(СокрЛП(Значение2));
        Исключение
            Продолжить;
        КонецПопытки;
        Значение1= СтрЗаменить(Значение1," ","");
        Значение1= Строка(Значение1);
        //Если значение1=0 Тогда

        //    Сообщить("Строка "+Значение0+" не обработана в файлене заполнен Штрихкодом "+Значение1+". "+значение3);

        //    Продолжить;

        //КонецЕсли;   

        //Если значение2=0 Тогда

        //    //Сообщить("Строка "+Значение0+" не обработана в файлене заполнен КодУникальности "+Значение1+". "+значение3);

        //    Продолжить;

        //КонецЕсли;       

        ////Сообщить(" "+ Значение0 + " "+ Значение1 + " == " + Значение2);

        //

        ////НайденнаяСсылка = ТаблНом.найти(Значение1,"КодУникальности");

        НайденнаяСсылка    = НайтиВТЧ(Значение1);
        Если НайденнаяСсылка = Неопределено Тогда
            НайденнаяСсылка  = "";
        Иначе
            //Сообщить("найдена");

            НайденнаяСсылка  = НайденнаяСсылка.ССылка;
        КонецЕсли;   
        //Для Каждого Стр Из ИсходныйФайл Цикл

            //СтрокаТабличнойЧасти  = ИсходныйФайл.Добавить();

            //СтрокаТабличнойЧасти.Номенклатура =  НайденнаяСсылка;

            //СтрокаТабличнойЧасти.Количество              = Значение2;

            //СтрокаТабличнойЧасти.НаименованиеИзЕкселя = Значение3;

            //СтрокаТабличнойЧасти.ШтрихКод             = Значение4;

            //СтрокаТабличнойЧасти.Коэффициент              = 1;

            //СтрокаТабличнойЧасти.ЕдиницаИзмерения      = "";   

        //КонецЦикла;

       
       
       
        //СтрокаТабличнойЧасти.СтавкаНДС=Перечисления.СтавкиНДС.НДС20;

        //СтрокаТабличнойЧасти.Размещение=Размещение;

       
        //Если СтрокаТабличнойЧасти.КлючСтроки=0 Тогда

        //    СтрокаТабличнойЧасти.КлючСтроки=УправлениеЗапасами.ПолучитьНовыйКлючСтроки(Объект);

        //КонецЕсли;   

        //Если СтрокаТабличнойЧасти.Номенклатура.Комплект Тогда

        //    //Сообщить(" "+СтрокаТабличнойЧасти.НомерСтроки+" "+СтрокаТабличнойЧасти.Номенклатура);

        //    УправлениеЗапасами.ДобавитьСоставНабора(СтрокаТабличнойЧасти, Объект);

        //КонецЕсли;

       
       
    КонецЦикла;
    //Получим значения ячейки листа в строке НомерСтроки и в колонке НомерКолонки:

   
    //Значение = Лист.Cells(НомерСтроки, НомерКолонки).Value;

   
   
    //Ниже приведен отрывок кода, запустив который мы прочитаем все данные с первой страницы:

   
    //Эксель = СоздатьОбъект("Excel.Application");

    //Книга = Эксель.WorkBooks.Open(ПутьКФайлу);

    //Лист = Книга.WorkSheets(1);

   
    //ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;

    //ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

   
    //для Строка = 1 по ВсегоСтрок цикл

    //   

    //    для Колонка = 1 по ВсегоКолонок цикл

    //        Значение = СокрЛП(Лист.Cells(Строка,Колонка).Value);

    //    КонецЦикла;

    //       

    //КонецЦикла;

   
   
    //Где ПутьКФайлу - полный путь к файлу книги Excel (включая имя).

   
    //После выполнения действий необходимо закрыть книгу:

   
    Эксель.Application.Quit();
    //ПроверкаЗаполненияТоваров();

    //ПолучитьВсюНоменклатуру();

    //SI.ЗаполнитьИсходныйЗаказ(Ссылка);

   
КонецПроцедуры
&НаКлиенте

Функция НайтиВТЧ(КодУникальности)
    Для каждого Стр из ТаблНом    цикл
        Если Строка(Стр.Наименование)=КодУникальности Тогда
            Возврат стр;
        КонецЕсли;
    КонецЦикла;
    Возврат Неопределено;
КонецФункции

Процедура ЗаполнитьТабл()
    Запрос = Новый Запрос;
    Запрос.Текст="ВЫБРАТЬ РАЗРЕШЕННЫЕ
                 |    Номенклатура.Код,
                 |    Номенклатура.КодСоответствия,
                 |    Номенклатура.Наименование,
                 |    Номенклатура.Артикул
                 |ИЗ
                 |    Справочник.Номенклатура КАК Номенклатура";
    ТаблНом =Запрос.Выполнить().Выгрузить();
    Для каждого стр из ТаблНом цикл
        //Стр.КодУникальности=СтрЗаменить(Стр.КодУникальности," ","");

        //Стр.КодУникальности=СокрЛП(Стр.КодУникальности);

        Попытка
            Стр.КодУникальности=Строка(Стр.Наименование);
        Исключение
            Сообщить(""+ стр.Наименование+ "  содержит штрихкод со значением ["+Стр.Наименование+"] "+ ОписаниеОшибки());
        КонецПопытки;   
    КонецЦикла;
    //ТаблНом.ВыбратьСтроку();

КонецПроцедуры


Ошибка в том что ТаблНом не заполнен. И не могу реализовать проверку. Куда нужно кидать данную процедуру на серв или на клиента. Но с клиента не фурычит


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ЗаполнитьТабл()  на сервере
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Vladimir19901

  • Все просто!!!)
  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-10
  • Сайт: 
  • Профессия: Программист 1С
ЗаполнитьТабл()  на сервере
Пробывал он не отрабатывает. :(

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Отладчег в помощь...
Добавлено: 23 Фев 2015, 15:28

хыхы/ а как вы проверяете отработало оно или нет? у вас сообщение выпадет только если ошибка будет. а если нет ошибки?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Vladimir19901

  • Все просто!!!)
  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-10
  • Сайт: 
  • Профессия: Программист 1С
Отладчег в помощь...
Добавлено: 23 Фев 2015, 15:28

хыхы/ а как вы проверяете отработало оно или нет? у вас сообщение выпадет только если ошибка будет. а если нет ошибки?
Так я и пытаюсь отладчигом а он игнорит)

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ну если у вас сикульная версия \нужно перевести сервер в режим дэбаг
Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4373
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 279
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal