Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Фильтр\Отбор программно при выборе из справочника  (Прочитано 4373 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн opossum777

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-22
  • Сайт: 
  • Профессия: Ученик 1С
Суть следующая:
Есть справочник "СтруктурныеПодразделения" и документ "ПолучениеТовара" с реквизитом "Откуда", который имеет тип СправочникСсылка.СтруктурныеПодразделения. Нужно чтобы при заполнении реквизита "Откуда" выводился отфильтрованный список, где отражались бы только значения, содержащие слово "Восток". Сделать это нужно программным способом


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Хорошая задача, вы ищите программиста?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн opossum777

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-22
  • Сайт: 
  • Профессия: Ученик 1С
Хорошая задача, вы ищите программиста?

Нет, мне нужно самому решить такую задачу, но что-то плохо получается:(

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Создайте свою форму выбора, если управляемые формы, то в динамическом списке в запросе отсеивайте не нужные элементы.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у поля "Откуда" в НачалоВыбора() получаем форму выбора справочника СтруктурныеПодразделения и добавляем у нее отбор "Ссылка В", получаем нужный список подразделений и подсовываем в значение отбора.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Если прям действительно нужно, чтобы отсеивало по конкретному слову, то вот такой код, не забудьте вставить процедуру в соответствующий обработчик
&НаКлиенте
Процедура ОткудаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   ДанныеВыбора = ВыборкаДанных();
КонецПроцедуры

&НаСервере
Функция ВыборкаДанных ()
   НужныеДанные = Новый СписокЗначений;
   Выборка = Справочники.СтруктурныеПодразделения.Выбрать();
   Пока Выборка.Следующий() Цикл
       Если Найти(НРег(Выборка.Наименование),"восток")<> 0 Тогда
        НужныеДанные.Добавить(Выборка.Ссылка);
        КонецЕсли;
     КонецЦикла;
     Возврат НужныеДанные;
КонецФункции

Оффлайн opossum777

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-22
  • Сайт: 
  • Профессия: Ученик 1С
Огромное Спасибо! Помогло!


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6498
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4200
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 631
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2037
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
46 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 790
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal