Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подсчет даты  (Прочитано 2960 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Есть 2 полеВвода с типом дата, надо подсчитать количество дней от датыНачала до ДатыОкончания, вот этот алгоритм считает только за текущий год, а мне надо сделать за любой, подскажите пожалуйста?

Если ЗначениеЗаполнено(ДатаНачалаОсновногоОтпуска) И ЗначениеЗаполнено(ДатаОкончанияОсновногоОтпуска) Тогда
      Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("ДатаНачалаОтпуска",      ДатаНачалаОсновногоОтпуска);
      Запрос.УстановитьПараметр("ДатаОкончанияОтпуска",   ДатаОкончанияОсновногоОтпуска);
      Запрос.Текст =
      "ВЫБРАТЬ
      |   СУММА(РегламентированныйПроизводственныйКалендарь.КалендарныеДни) КАК КоличествоДнейОтпуска
      |ИЗ
      |   РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
      |ГДЕ
      |   РегламентированныйПроизводственныйКалендарь.ДатаКалендаря МЕЖДУ &ДатаНачалаОтпуска И &ДатаОкончанияОтпуска";   
      Выборка = Запрос.Выполнить().Выбрать();
      Если Выборка.Следующий() Тогда
         Если Выборка.КоличествоДнейОтпуска <> КоличествоДнейОсновногоОтпуска Тогда
            Если КоличествоДнейОсновногоОтпуска <> 0 Тогда
               //зададим вопрос, хочется ли пересчитать количество дней отпуска 
               ТекстВопроса = "Указанный в документе период отпуска
               |не соответствует количеству дней отпуска!
               |Изменить количество дней отпуска?";
               Ответ  = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);
               Если Ответ = КодВозвратаДиалога.Да Тогда
                  КоличествоДнейОсновногоОтпуска = Выборка.КоличествоДнейОтпуска;
               КонецЕсли;
            Иначе
               КоличествоДнейОсновногоОтпуска = Выборка.КоличествоДнейОтпуска;
            КонецЕсли;
         Иначе
            // даты совпали, ничего менять не нужно
         КонецЕсли;
      Иначе
         // не удалось получить количество дней отпуска запросом
         Сообщить("Проверьте заполнение производственного календаря!");
      КонецЕсли;
   КонецЕсли;


Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Re: Подсчет даты
« Ответ #1: 18 Авг 2010, 11:59 »
отнимаешь от даты конца  даты начала и прибавляешь 1

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Re: Подсчет даты
« Ответ #2: 19 Авг 2010, 06:06 »
мне надо решение в числовом виде
Пр. ДатаНачала(18.06.2010), ДатаОкончания(23.08.2010), Результат = 66 дней

Оффлайн ***Vjacheslav***

  • ***
  • Сообщений: 156
  • РЕПУТАЦИЯ: 35
  • КПД: 22%
  • Регистрация: 2010-08-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Подсчет даты
« Ответ #3: 20 Авг 2010, 10:40 »
(ДатаКонца-ДатаНачала)/86400 

86400- количество секунд в одном дне

Оффлайн ***Vjacheslav***

  • ***
  • Сообщений: 156
  • РЕПУТАЦИЯ: 35
  • КПД: 22%
  • Регистрация: 2010-08-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Подсчет даты
« Ответ #4: 20 Авг 2010, 10:50 »
результат вычитания одной даты из другой есть количество секунд между датами, поэтому /86400 получается количество дней в числовом виде.

Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Re: Подсчет даты
« Ответ #5: 20 Авг 2010, 13:21 »
результат вычитания одной даты из другой есть количество секунд между датами, поэтому /86400 получается количество дней в числовом виде.

Эт у меня пережитки семерки, там результат это количество дней между датами))


Теги:
 

Проблема при проведении реализации УТ 11 - сообщение дата оплаты меньше даты документа

Автор AndreyBlacksmithРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2690
Последний ответ 05 Фев 2015, 11:53
от AndreyBlacksmith
ЗУП Даты получения дохода в регистре налогового учета НДФЛ не ставятся(((?

Автор may_sergРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2872
Последний ответ 14 Июл 2011, 08:17
от may_serg
Установка даты запрета редактирования, как расширить выбором конкретных документов

Автор Саша ЛибертиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3052
Последний ответ 13 Июн 2014, 11:24
от Саша Либерти
Нет значка изменения даты в документе поступления товара, в 1с 8.3 , Розница 2.1 базовая

Автор genyfildРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2676
Последний ответ 24 Фев 2015, 12:16
от genyfild
Определение даты получения дохода от реализации услуг при методе начисления

Автор newsРаздел Новости

Ответов: 0
Просмотров: 448
Последний ответ 19 Июн 2015, 15:19
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 373
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal