Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 14:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: выдавать ошибку при выборе сотрудника  (Прочитано 1310 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Есть справочник *Список сотрудников*. В нем 2 группы: *Продавцы* и *Кладовщики*.
В документе *Прием товара* нужно указывать фамилии сотрудников из группы *Кладовщики*, а при выборе сотрудников из группы *Продавцы*, выдавать ошибку.
В документе *Продажа* наоборот.
Как это реализовать, подскажите.


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
В процедуре при изменении что то типа:
Если Выб.Родитель - ненужныйнам тогда
сообщить("не надовыбирать это");
КонецЕсли;
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Не выходит. Система ругается на параметр *Выб.Родитель*

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
гыгыгы. Логично блин.
Вам сюда:
http://v8.1c.ru/metod/books/book.jsp?id=441
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Не выходит. Система ругается на параметр *Выб.Родитель*

Напишите весь код, который Вы прописали....
Народная мудрость: Программу встречают по интерфейсу

Оффлайн Константин163

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-31
  • Сайт: 
  • Профессия: Ученик 1С
Не выходит. Система ругается на параметр *Выб.Родитель*

Напишите весь код, который Вы прописали....

   &НаКлиенте
      Процедура СотрудникПриИзменении(Элемент)
            
   Результат = Проверить(Объект.Сотрудник);
   Если Не Результат Тогда
   Сообщить("не может быть выбран");
   КонецЕсли;
   КонецПроцедуры

   &НаСервереБезКонтекста
   Функция Проверить(Сотрудник)
   //а = 0;
   если Сотрудник.Родитель = Справочники.НайтиПоКоду("000000002") тогда Результат = истина;
   иначе Результат = ложь;
   возврат Результат
   КонецЕсли;
   КонецФункции



теперь ругается на *метод объекта не обнаружен(найти по коду)*

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
да вы прикалываетесь чтоли? :)
Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 275
Последний ответ 12 Окт 2017, 14:02
от wise
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1057
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 489
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
"Триггеры" на прием и увольнение сотрудника

Автор taurusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1610
Последний ответ 11 Окт 2016, 16:59
от ilyay
Как поймать ошибку "Не удалось заблокировать документ"?

Автор Николай 2йРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2574
Последний ответ 05 Дек 2011, 17:05
от Николай 2й

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal