Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 13:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод в номенклатуру количества ТМЦ в резеревах  (Прочитано 1641 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн llpass

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Программист 7.7
Подскажите пож как из регистра РезервыТМЦ вытащить количества товра
есть аналог
//******************************************************* Это касается Физического склада
Функция Остаток3()
   Если ЭтоГруппа() = 0 Тогда
          Рег = Создатьобъект("Регистр.ОстаткиТМЦ");
Рег.УстановитьЗначениеФильтра("Номенклатура",ТекущийЭлемент(),1);
Рег.УстановитьЗначениеФильтра("Склад",Склад3,1);
          Таб=СоздатьОбъект("ТаблицаЗначений");
          Рег.ВыгрузитьИтоги(Таб,1,1);
          Возврат глФРМ(Таб.Итог("Количество"));
Конецесли;
КонецФункции // Остаток3()

//********************************  ВЫВОДИМ СКЛАД С ОСТАТКАМИ В СПИСОК НОМЕНКЛАТУРЫ
Спр = СоздатьОбъект("Справочник.Склады");
     Если Спр.НайтиПоНаименованию("Логистика",0,1) = 1 Тогда
     Если Спр.ТекущийЭлемент().Складзакрыт = 0 Тогда
       Склад3 = Спр.ТекущийЭлемент();
    Иначе
    Форма.Склад3.Видимость(0);
     КонецЕсли;
КонецЕсли;
//********************************  Это касается виртуального склада  где числяться  резервы
Функция Резерв()
Если ЭтоГруппа() = 0 Тогда
          Рег = Создатьобъект("Регистр.РезервыТМЦ");
Рег.УстановитьЗначениеФильтра("Номенклатура",ТекущийЭлемент(),1);
Рег.УстановитьЗначениеФильтра("Склад",Склад4,1);
          Таб=СоздатьОбъект("ТаблицаЗначений");
          Рег.ВыгрузитьИтоги(Таб,1,1);
          Возврат глФРМ(Таб.Итог("Количество"));
        Конецесли;
КонецФункции // Резерв()

//*************************************** ВЫВОДИМ Резервы С ОСТАТКАМИ В СПИСОК НОМЕНКЛАТУРЫ
Спр = СоздатьОбъект("Справочник.Склады");  //********* Как создать  обьект с  РезервамиТМЦ  ???????
     Если Спр.НайтиПоНаименованию("???????????",0,1) = 1 Тогда
     Если Спр.ТекущийЭлемент().Складзакрыт = 0 Тогда
       Склад4 = Спр.ТекущийЭлемент();
    Иначе
    Форма.Склад4.Видимость(0);
     КонецЕсли;
КонецЕсли;


СПС  должно получиться как на фото


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Функция Резерв()
Если ЭтоГруппа() = 0 Тогда
          Рег = Создатьобъект("Регистр.РезервыТМЦ");
Рег.УстановитьЗначениеФильтра("Номенклатура",ТекущийЭлемент(),1);
Рег.УстановитьЗначениеФильтра("Склад",Склад4,1);
          Таб=СоздатьОбъект("ТаблицаЗначений");
          Рег.ВыгрузитьИтоги(Таб,1,1);
          Возврат глФРМ(Таб.Итог("Количество"));
        Конецесли;
КонецФункции // Резерв()

Вот же вы получаете резерв,
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн llpass

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Программист 7.7
он получается... не понятно во второй части вывод этих цифр в с список номенклатуры см фото     

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
если открыть совйства столбца резерв, или любого другого где цифры, то там во второй вкладке будет прописано название функции которая возвращает эту цифру
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн llpass

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Программист 7.7
Да така и есть...  для вывода на на  экран  сосздается справочниик 
как для физического склада

Спр = СоздатьОбъект("Справочник.Склады");
     Если Спр.НайтиПоНаименованию("Логистика",0,1) = 1 Тогда
     Если Спр.ТекущийЭлемент().Складзакрыт = 0 Тогда
       Склад3 = Спр.ТекущийЭлемент();
    Иначе
    Форма.Склад3.Видимость(0);
     КонецЕсли;
КонецЕсли;


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Ну так я не понимаю, что вы хотите получить?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн llpass

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Программист 7.7
Посмотрите миниатюры...  видите  в колонке склад стоят колличества  ( это количесвтва на реальном складе) и есть колонка резерв  в ней должна  быть цифра котрая  зарезервирована

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Ну???? а я вам о чом говорю? У вас прописано там функция резерв(), следовательно оно туда заходит и вычисляет резерв. если цифры нулевые, а он есть, изучайте в отладчике отчего они нулевые.
Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 881
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal