Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обращение к реквизиту справочника из модуля формы документа  (Прочитано 3384 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Golickoff

  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 35
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.

Есть справочник, в котором перечисляются рабочие инструменты на складе. У каждого инструмента есть реквизит "количество использований", предназначенный для контроля износа инструмента. Помимо этого, есть документ "выдача инструмента", в котором указывается кому из рабочих какой с утра выдали инструмент. Согласно техническому регламенту, у каждого инструмента есть свой срок службы. То есть, нож мы можем использовать только 10 раз, после чего его использование запрещено. Можно ли при проведении этого документа в том случае, если этот нож попал в него, то есть был выдан рабочему, увеличить в справочнике значение реквизита "количество использований" у ножа на единицу? Нож -- это, само собой, абстракция. В документе имеется несколько разных инструментов и для каждого из них при проведении документа необходимо увеличить значение реквизита "количество использований" на единицу. Мечта, или реальность?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Данный механизм считаю неоптимальным. А так можно всё. Проблема только в ресурсах.
СпрНож = Нож.Ссылка.ПолучитьОбъект();
СпрНож.КоличествоИспользований = СпрНож.КоличествоИспользований + 1;
СпрНож.Записать();
Как-то так.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Golickoff

  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 35
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
СпрНож = Нож.Ссылка.ПолучитьОбъект();
СпрНож.КоличествоИспользований = СпрНож.КоличествоИспользований + 1;
СпрНож.Записать();
Ага, со второй частью всё ясно. А как мне получить список всех ресурсов, использованных в документе?
Документ выглядит так:
NИнструментПолучил
1НожИванов
2ДолотоПетров
3Диск циркулярной пилыСидоров
4НожПупкин
.........
xyz
И нужно сделать то же самое для каждого использованного инструмента от 1 до x. То есть, сначала составить список выданных инструментов, затем найти каждый инструмент из списка в справочнике и только потом добавить каждому найденному инструменту единицу в реквизит "КоличествоИспользований" справочника "Инструменты".
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
С помощью "Для каждого..."
Для каждого РеквизитТЧ Из [Имя табличной части] Цикл
НожСпр = РеквизитТЧ.Ссылка.ПолучитьОбъект();
<<ну и так далее>>
КонецЦикла

Проще пареной репы.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Golickoff

  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 35
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Написал в модуле формы документа следующий код:
СтрокаТабличнойЧасти = Элементы.Инструмент.ТекущиеДанные;
Для каждого СтрокаТЧ из Справочники.Инструменты цикл
Если СтрокаТЧ = СтрокаТабличнойЧасти
Тогда СтрокаТЧ.КоличествоИспользований = СтрокаТЧ.КоличествоИспользований + 1
КонецЕсли;
КонецЦикла;
Но конфигурация не запускается, выдавая
{Документ.ВыдачаИнструмента.Форма.ФормаДокумента.Форма(23,26)}: Переменная не определена (Справочники)
Для каждого СтрокаТЧ из <<?>>Справочники.Инструменты цикл (Проверка: Тонкий клиент)
Что не так с этим кодом?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
СтрокаТабличнойЧасти = Элементы.Инструмент.ТекущиеДанные;
Эту строку убрать
Справочники.Инструменты - Здесь должно быть имя табличной части документа.
Товары, Инструменты, Материалы... Как то так.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Golickoff

  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 35
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
СтрокаТабличнойЧасти = Элементы.Инструмент.ТекущиеДанные;
Эту строку убрать
Справочники.Инструменты - Здесь должно быть имя табличной части документа.
Товары, Инструменты, Материалы... Как то так.
Спасибо, сейчас поковыряюсь.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для каждого СтрокаТЧ Из Инструменты Цикл
НожСпр = СтрокаТЧ.Инструмент.ПолучитьОбъект();
НожСпр.КоличествоИспользований = НожСпр.КоличествоИспользований + 1;
НожСпр.Записать();
КонецЦикла
Научись пользоваться отладчиком. Понимать будешь больше.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15921
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4779
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1581
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal