Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Просьба о помощи от новичка в 1с  (Прочитано 2555 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EvGenOM

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С
    Доброго дня, уважаемые посетители форума. Я новичок в 1с. Большую часть времени трачу на изучение учебной литературы. В книге "Введение в конфигурирование в системе "1с Предприятие 8.2". Основные объекты" Столкнулся с задачкой, которую уже 2 дня не могу решить. Гуглил, смотрел синтаксис-помощник, 1с ИТС, но так и не смог самостоятельно разобраться. Подскажите пожалуйста, что я делаю не так. Создается документ "ПродажаТовара" в нем реквизиты(Контрагент, КонтактноеЛицо Сотрудник, Склад, СуммаДокумента) и табличная часть(Номенклатура, Цена, Количество, Сумма). Пишется код для элемента Количество и Сумма для события ПриИзменении. Код :
&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)

Стр = Элементы.Товары.ТекущиеДанные;
Стр.Сумма = Стр.Количество * Стр.Цена;


КонецПроцедуры

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)

Стр = Элементы.Товары.ТекущиеДанные;
Стр.Сумма = Стр.Количество * Стр.Цена;


КонецПроцедуры

В модуле Объекта(документ "ПродажаТовара") пишу :

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
СуммаДокумента = Товары.Итог("Сумма");
КонецПроцедуры

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
Если СуммаДокумента >= 1000 Тогда Сообщить("Доступна бесплатная доставка");
КонецЕсли;
КонецПроцедуры


Отладчик не ругается, сумма в таблице для строки исправно считается. Только в реквизите СуммаДокумента, как стояло значение = 0, так и остается и следовательно сообщение не выводится. Все делаю по книжке, понять не могу/не в силах. Помогите пожалуйста. 


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. С суммой документа единственный вариант пока - не так называется сам реквизит, мож очепятались где-то...
2. а почему сообщение о бесплатной доставке в ОбработкаЗаполнения()? Почему не в ПриОткрытии() формы документа?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн herosmart

  • **
  • Сообщений: 54
  • РЕПУТАЦИЯ: 4
  • КПД: 7%
  • Регистрация: 2013-06-19
  • Сайт: 
  • Профессия: Ученик 1С

Отладчик не ругается, сумма в таблице для строки исправно считается. Только в реквизите СуммаДокумента, как стояло значение = 0, так и остается и следовательно сообщение не выводится. Все делаю по книжке, понять не могу/не в силах. Помогите пожалуйста.
[/quote]

Доброго времени суток. Скажите, реквизит СуммаДокумента - это реквизит документа у Вас? Или же реквизит, созданный непосредственно на форме?

Оффлайн EvGenOM

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С
1. С суммой документа единственный вариант пока - не так называется сам реквизит, мож очепятались где-то...
2. а почему сообщение о бесплатной доставке в ОбработкаЗаполнения()? Почему не в ПриОткрытии() формы документа?

Просмотрел много раз на предмет опечаток, такой случай был при написании кода под "Номенклатура", а в реквизите была указана "Номанклатура":D. Тут сколько не проверял все тщетно.

Сообщение, честно сказать не знал куда запихнуть. По идее, от кода формы требуется, при вводе цены и количества для товара должна выводится сумма, далее, должна вывестись общая сумма(Итоговая), а далее, если этот итог превысит 1000, должно выдаваться сообщение.


Доброго времени суток. Скажите, реквизит СуммаДокумента - это реквизит документа у Вас? Или же реквизит, созданный непосредственно на форме?

Здравствуйте. Данный реквизит является реквизитом документа. На форме реквизитов не создавал.

Пытался эту задачу решить следующим путем. На форме, в свойствах СуммаДокумента выбирал ПутьКДанным - Объект.Товары.ИтогСумма. На форме реквизит "СуммаДокумента" меняется на "Сумма (итог)", общая итоговая сумма стала выводиться. Но, сообщение так и не смог вывести при выполнении условия.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
У вас сообщение в "ОбработкаЗаполнения"?

Оффлайн EvGenOM

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С
Вернул все, как было изначально. Заметил тот факт, что после ввода товаров, изменения в СуммаДокумента происходит, лишь, после того, как нажимаю "провести и закрыть", открываю снова этот документ и все посчитано правильно. Подскажите, а возможно ли чтобы все происходило непосредственно во время/в момент создания и заполнения документа? 
Добавлено: 16 Фев 2015, 14:24

У вас сообщение в "ОбработкаЗаполнения"?

Осознал свою ошибку. Но не могу понять в какую обработку записать вывод сообщения... Может такой вариант?
&НаКлиенте
Процедура СуммаДокументаОткрытие(Элемент, СтандартнаяОбработка)
  Ск = Элементы.ТекущиеДанные;
Если Ск.СуммаДокумента >= 1000 Тогда Сообщить("Доступна бесплатная доставка");
КонецЕсли;

КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Как вы себе представляете: когда/ в какой момент должно возникнуть это сообщение?

Оффлайн Sergey 1c

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: -3
  • Регистрация: 2015-02-04
  • Сайт: 
  • Профессия: Ученик 1С
Кто знает как загрузить документ счет на оплату в 1с демо-???? Помогите пожалуйста???????

Оффлайн EvGenOM

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С
Как вы себе представляете: когда/ в какой момент должно возникнуть это сообщение?

Думаю сообщение выдается в тот момент когда СуммаДокумента имеет значение больше или равно 1000, таким образом это значение проявляется после нажатия кнопки "провести и закрыть", также заметил, что при нажатии кнопки "сохранить" значение в элементе СуммаДокумента меняется, а следовательно....
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
СуммаДокумента = Товары.Итог("Сумма");
Если СуммаДокумента >= 1000 Тогда Сообщить("Доступна бесплатная доставка");
КонецЕсли;
КонецПроцедуры

Все заработало!)) При нажатии кнопки "сохранить" появляется нужное сообщение. Спасибо огромное vitasw, вы заставили мои мозги работать в правильном направлении))

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Пожалуйста. Это, как говорится, была проверка на вшивость - насколько вы готовы самостоятельно находить решения. - вроде голова есть. Тогда усовершенствуем ваш метод. В текущем варианте пользователь узнает о том что "Доступна бесплатная доставка" только после записи документа, что не является совсем уж комильфо. Как вариант. Повесить это сообщение при изменении суммы: т.е. при любом изменении суммы вызывать заполнение "СуммаДокумента" и соответственно выдавать сообщение. НО! в таком случае пользователю будет выдаваться это сообщение много раз при любом изменении суммы, соответственно, желательно при первом переползании через 1000 пользователю выдавать сообщение, а при последующих - нет. Если хотите, то можете попробовать реализовать это.


Теги:
 

Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 970
Последний ответ 01 Мар 2016, 14:33
от sveta C
Вопрос новичка по главе из одной книги "Программирование формы документа"

Автор ZcehРаздел Пользователям "1С - Предприятие 8"

Ответов: 8
Просмотров: 4381
Последний ответ 03 Дек 2011, 12:51
от Zceh
перечисление разовых премий и материальной помощи физическим лицам не состоящим в штате организации

Автор Лана ЮрьевнаРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 416
Последний ответ 09 Дек 2016, 19:04
от Лана Юрьевна
Нужно очень много помощи, в выпускной работе по 1с предприятию 8.1.

Автор Artem_KovalevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1480
Последний ответ 21 Апр 2014, 23:54
от MuI_I_Ika
Прошу помощи, чтобы исправить ошибку в конфигурации

Автор garmin-osaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1662
Последний ответ 10 Апр 2011, 17:43
от chuevsf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal