Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 09:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать ценников 3х3  (Прочитано 1580 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн neyotauhura

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С
Помогите пожалуйста чайнику:D
Как в конфигураторе сделать ценники что бы располагались 3х3, т. е. 3 по горизонтали и три во вертикали всего получается 9 шт. на одном листе.
Все перепробовало но не получается.
Я так поняла что менять нужно что то здесь:

Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
       
   Столбик   = ?(Столбик = 0, 1      , 0  );
   Ряд      = ?(Столбик = 0, Ряд +1, Ряд);

   Если Ряд > 3 Тогда
       Таб.НоваяСтраница();
       Ряд = 1;
    КонецЕсли;
    
    Если Столбик = 0 Тогда
       Таб.ВывестиСекцию("Товар|Ценник");
    Иначе
       Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли;

КонецПроцедуры // ДобавитьЦенник()


Если можно по подробнее что и где менять

Заранее Спасибо!



Оффлайн llpass

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Программист 7.7
Помогите пожалуйста чайнику:D
Как в конфигураторе сделать ценники что бы располагались 3х3, т. е. 3 по горизонтали и три во вертикали всего получается 9 шт. на одном листе.
Все перепробовало но не получается.
Я так поняла что менять нужно что то здесь:

Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
       
   Столбик   = ?(Столбик = 0, 1      , 0  );
   Ряд      = ?(Столбик = 0, Ряд +1, Ряд);

   Если Ряд > 3 Тогда
       Таб.НоваяСтраница();
       Ряд = 1;
    КонецЕсли;
    
    Если Столбик = 0 Тогда
       Таб.ВывестиСекцию("Товар|Ценник");
    Иначе
       Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли;

КонецПроцедуры // ДобавитьЦенник()


Если можно по подробнее что и где менять

Заранее Спасибо!




если увас склад ТиС 9.2 могу скинуть обработу ценников в налисте а4

Оффлайн neyotauhura

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-13
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн dimi3o

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-05
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд) 
    Если Столбик = 0 Тогда
        Столбик = 1;
    ИначеЕсли Столбик = 1 Тогда
        Столбик = 2;
    ИначеЕсли Столбик = 2 Тогда
        Столбик = 0;
    КонецЕсли;
    Ряд = ?(Столбик = 0, Ряд + 1, Ряд);

    Если Ряд > 3 Тогда
       Таб.НоваяСтраница();
       Ряд = 1;
    КонецЕсли; 
    Если Столбик = 0 Тогда
        Таб.ВывестиСекцию("Товар|Ценник");
    Иначе 
   Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли; 
КонецПроцедуры

Перед первым вызовом процедуры задаёшь столбик и ряд:
Столбик = 2;
Ряд     = 0;

Оффлайн alenuchka

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Наверное у меня не было таких проблем. Пользовалась программой Печать ценников. Загрузила для 1с http://cennik-etiketka.ru/. Удобно, что для каждого товара я задавала свой размер ценника))


Теги: ценники 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
147 Сообщений
oleg-x
66 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
26 Сообщений
BuhRust
21 Сообщений
trialex3
20 Сообщений

* Кто онлайн

  • Точка Гостей: 650
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal