Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 02:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Закрепление макета договора за кодом организации  (Прочитано 1109 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн FromRome

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-12
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте есть такой код: нужно закрепить макет договора, если код организации 000000010, в общем мне нужно вписать в программный код третий макет (договор 3) и обозначить его кодом организации 000000010, не судите строго, только учусь.
Процедура ОсновныеДействияФормыПечать(Кнопка)
   Если ЭтоНовый() или модифицированность тогда
      Предупреждение("Перед печатью документ необходимо записать.");
      возврат;
   КонецЕсли;
   ТабДок=Новый ТабличныйДокумент;
   Если Организация.Код = "000000001" Тогда
      Макет=ПолучитьМакет("Договор1");
      Шапка=Макет.ПолучитьОбласть("Шапка");
      Строка=Макет.ПолучитьОбласть("Строка");
      СекцияИтого=Макет.ПолучитьОбласть("Итого");
      СекцияСкидка=Макет.ПолучитьОбласть("Скидка");
      СекцияИтогоСоСкидкой=Макет.ПолучитьОбласть("ИтогоСоСкидкой");
      СекцияКомментарий=Макет.ПолучитьОбласть("Комментарий");
      ТелоДоговора=Макет.ПолучитьОбласть("ТелоДоговора");
      СекцияМРТ=Макет.ПолучитьОбласть("СекцияМРТ");
      Подписи=Макет.ПолучитьОбласть("Подписи");
      
      Шапка.Параметры.НомерДоговора=Номер;
      Шапка.Параметры.фио=Пациент.НаименованиеПолное;
      Шапка.Параметры.ДатаДоговора=формат(Дата,"ДЛФ=ДД");
      ТабДок.Вывести(Шапка);
      
      ЕстьМРТ = Ложь; СуммаКонтраста = 0;
      Для каждого стр из Услуги цикл
         Строка.Параметры.Заполнить(стр);
         Строка.Параметры.Услуга = стр.Услуга.НаименованиеДляДоговора;
         ТабДок.Вывести(Строка);
                                        
         Если стр.Услуга.Родитель.Код = "000000003" Тогда
            ЕстьМРТ = Истина;
         КонецЕсли;   
         
         Если стр.Услуга.Код = "000000454" Тогда
            СуммаКонтраста = стр.Сумма
         КонецЕсли;   
      КонецЦикла;
      
      СекцияИтого.Параметры.ИтогоСумма=СуммаБезСкидки + ?(Скидка=100,0,СуммаКонтраста);
      ТабДок.Вывести(СекцияИтого);
      
      Если СуммаСкидки <> 0 Тогда
         СекцияСкидка.Параметры.Скидка=СуммаСкидки;
         ТабДок.Вывести(СекцияСкидка);
         
         СекцияИтогоСоСкидкой.Параметры.ИтогоСоСкидкой=?(СуммаДокумента=0,"0",СуммаДокумента);
         ТабДок.Вывести(СекцияИтогоСоСкидкой);
         
         Если СокрЛП(Комментарий)<>"" Тогда
            СекцияКомментарий.Параметры.Комментарий=Комментарий;
            ТабДок.Вывести(СекцияКомментарий);
         КонецЕсли;   
      КонецЕсли;
      
      ТелоДоговора.Параметры.ДатаДоговора=формат(Дата,"ДЛФ=ДД");
      ТелоДоговора.Параметры.ДатаВыполнения = "_____ _________________ 2014 г.";
      ТелоДоговора.Параметры.СуммаДокумента = СуммаДокумента;
      
      ТелоДоговора.Параметры.ФИО=Пациент.НаименованиеПолное;   
      Заказчик=Пациент.НаименованиеПолное;
      Если ЗначениеЗаполнено(Пациент.ДокументУдостоверяющийЛичность) Тогда
         Заказчик=Заказчик+"
         |"+Пациент.ДокументУдостоверяющийЛичность;
      КонецЕсли;
      ТабДок.Вывести(ТелоДоговора);
      
      Если ЕстьМРТ Тогда
         ТабДок.Вывести(СекцияМРТ);
      КонецЕсли;   
      
      Запрос = Новый Запрос;
      Запрос.Текст="ВЫБРАТЬ
      |   КонтактнаяИнформация.Представление как адрес
      |ИЗ
      |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
      |ГДЕ
      |   КонтактнаяИнформация.Объект = &Объект
      |   И КонтактнаяИнформация.Вид = &Вид";
      //Параметры запроса
      Запрос.УстановитьПараметр("Вид",справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);//Справочник ссылка: Виды контактной информации
      Запрос.УстановитьПараметр("Объект",Пациент);//Справочник ссылка: Контрагенты
      
      Результат=Запрос.Выполнить().Выбрать();
      Если Результат.Следующий() Тогда
         Заказчик=Заказчик+"
         |Адрес: "+результат.адрес;
      КонецЕсли;

      Запрос = Новый Запрос;
      Запрос.Текст="ВЫБРАТЬ
      |   КонтактнаяИнформация.Представление как телефон
      |ИЗ
      |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
      |ГДЕ
      |   КонтактнаяИнформация.Объект = &Объект
      |   И КонтактнаяИнформация.Вид = &Вид";
      //Параметры запроса
      Запрос.УстановитьПараметр("Вид",справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);//Справочник ссылка: Виды контактной информации
      Запрос.УстановитьПараметр("Объект",Пациент);//Справочник ссылка: Контрагенты
      
      Результат=Запрос.Выполнить().Выбрать();
      Если Результат.Следующий() Тогда
         Заказчик=Заказчик+"
         |Тел.:"+результат.телефон;
      КонецЕсли;

      Подписи.Параметры.Заказчик=Заказчик;
      Подписи.Параметры.ФамилияИО=Пациент.Наименование;
      ТабДок.Вывести(Подписи);
      ТабДок.ПолеСверху = 5;
      ТабДок.ПолеСнизу  = 5;
   ИначеЕсли Организация.Код = "000000003" Тогда
      Макет=ПолучитьМакет("Договор2");
      Шапка=Макет.ПолучитьОбласть("Договор");
      Шапка.Параметры.НомерДоговора = Число(Прав(Номер,5));
      Шапка.Параметры.ФИОПолностью = Пациент.НаименованиеПолное;
      Шапка.Параметры.ФИОКратко = Пациент.Наименование;
      Шапка.Параметры.ДатаДоговора = Формат(Дата,"ДЛФ=ДД");
      Шапка.Параметры.СуммаДоговора = СуммаДокумента;
      ТабДок.Вывести(Шапка);
      
      Согласие=Макет.ПолучитьОбласть("Согласие");
      Согласие.Параметры.ФИОПолностью = Пациент.НаименованиеПолное;
      ТабДок.Вывести(Согласие);
      
      ТабДок.ПолеСверху = 5;
      ТабДок.ПолеСнизу  = 5;
      ТабДок.ПолеСлева  = 5;
      ТабДок.ПолеСправа = 5;
      ТабДок.АвтоМасштаб = Истина;
      ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   КонецЕсли;      
      
   ТабДок.Показать();
   
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
И? предлагаете за вас написать код? - так это денег стоит...

Оффлайн FromRome

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-12
  • Сайт: 
  • Профессия: Ученик 1С
И? предлагаете за вас написать код? - так это денег стоит...
там нужно скопипастить программный код по договору 1 и все, просто я не пойму, выдает постоянно ошибку синтаксиса

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
А, я понял! это тест: угадай текст ошибки  и получи пирожок. К сожалению экстрасенсов среди программистов 1С - ну очень мало.

Оффлайн FromRome

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-12
  • Сайт: 
  • Профессия: Ученик 1С
А, я понял! это тест: угадай текст ошибки  и получи пирожок. К сожалению экстрасенсов среди программистов 1С - ну очень мало.
Процедура ОсновныеДействияФормыПечать(Кнопка)
   Если ЭтоНовый() или модифицированность тогда
      Предупреждение("Перед печатью документ необходимо записать.");
      возврат;
   КонецЕсли;
   ТабДок=Новый ТабличныйДокумент;
   Если Организация.Код = "000000001" Тогда
      Макет=ПолучитьМакет("ДоговорТомограф");
      Шапка=Макет.ПолучитьОбласть("Шапка");
      Строка=Макет.ПолучитьОбласть("Строка");
      СекцияИтого=Макет.ПолучитьОбласть("Итого");
      СекцияСкидка=Макет.ПолучитьОбласть("Скидка");
      СекцияИтогоСоСкидкой=Макет.ПолучитьОбласть("ИтогоСоСкидкой");
      СекцияКомментарий=Макет.ПолучитьОбласть("Комментарий");
      ТелоДоговора=Макет.ПолучитьОбласть("ТелоДоговора");
      СекцияМРТ=Макет.ПолучитьОбласть("СекцияМРТ");
      Подписи=Макет.ПолучитьОбласть("Подписи");
      
      Шапка.Параметры.НомерДоговора=Номер;
      Шапка.Параметры.фио=Пациент.НаименованиеПолное;
      Шапка.Параметры.ДатаДоговора=формат(Дата,"ДЛФ=ДД");
      ТабДок.Вывести(Шапка);
      
      ЕстьМРТ = Ложь; СуммаКонтраста = 0;
      Для каждого стр из Услуги цикл
         Строка.Параметры.Заполнить(стр);
         Строка.Параметры.Услуга = стр.Услуга.НаименованиеДляДоговора;
         ТабДок.Вывести(Строка);
                                        
         Если стр.Услуга.Родитель.Код = "000000003" Тогда
            ЕстьМРТ = Истина;
         КонецЕсли;   
         
         Если стр.Услуга.Код = "000000454" Тогда
            СуммаКонтраста = стр.Сумма
         КонецЕсли;   
      КонецЦикла;
      
      ТабДок=Новый ТабличныйДокумент;
   Если Организация.Код = "000000010" Тогда
      Макет=ПолучитьМакет("Договор3");
      Шапка=Макет.ПолучитьОбласть("Шапка");
      Строка=Макет.ПолучитьОбласть("Строка");
      СекцияИтого=Макет.ПолучитьОбласть("Итого");
      СекцияСкидка=Макет.ПолучитьОбласть("Скидка");
      СекцияИтогоСоСкидкой=Макет.ПолучитьОбласть("ИтогоСоСкидкой");
      СекцияКомментарий=Макет.ПолучитьОбласть("Комментарий");
      ТелоДоговора=Макет.ПолучитьОбласть("ТелоДоговора");
      СекцияМРТ=Макет.ПолучитьОбласть("СекцияМРТ");
      Подписи=Макет.ПолучитьОбласть("Подписи");
      
      Шапка.Параметры.НомерДоговора=Номер;
      Шапка.Параметры.фио=Пациент.НаименованиеПолное;
      Шапка.Параметры.ДатаДоговора=формат(Дата,"ДЛФ=ДД");
      ТабДок.Вывести(Шапка);
      
      ЕстьМРТ = Ложь; СуммаКонтраста = 0;
      Для каждого стр из Услуги цикл
         Строка.Параметры.Заполнить(стр);
         Строка.Параметры.Услуга = стр.Услуга.НаименованиеДляДоговора;
         ТабДок.Вывести(Строка);
                                        
         Если стр.Услуга.Родитель.Код = "000000003" Тогда
            ЕстьМРТ = Истина;
         КонецЕсли;   
         
         Если стр.Услуга.Код = "000000454" Тогда
            СуммаКонтраста = стр.Сумма
         КонецЕсли;   
      КонецЦикла;
      
      СекцияИтого.Параметры.ИтогоСумма=СуммаБезСкидки + ?(Скидка=100,0,СуммаКонтраста);
      ТабДок.Вывести(СекцияИтого);
      
      Если СуммаСкидки <> 0 Тогда
         СекцияСкидка.Параметры.Скидка=СуммаСкидки;
         ТабДок.Вывести(СекцияСкидка);
         
         СекцияИтогоСоСкидкой.Параметры.ИтогоСоСкидкой=?(СуммаДокумента=0,"0",СуммаДокумента);
         ТабДок.Вывести(СекцияИтогоСоСкидкой);
         
         Если СокрЛП(Комментарий)<>"" Тогда
            СекцияКомментарий.Параметры.Комментарий=Комментарий;
            ТабДок.Вывести(СекцияКомментарий);
         КонецЕсли;   
      КонецЕсли;
      
      ТелоДоговора.Параметры.ДатаДоговора=формат(Дата,"ДЛФ=ДД");
      ТелоДоговора.Параметры.ДатаВыполнения = "_____ _________________ 2014 г.";
      ТелоДоговора.Параметры.СуммаДокумента = СуммаДокумента;
      
      ТелоДоговора.Параметры.ФИО=Пациент.НаименованиеПолное;   
      Заказчик=Пациент.НаименованиеПолное;
      Если ЗначениеЗаполнено(Пациент.ДокументУдостоверяющийЛичность) Тогда
         Заказчик=Заказчик+"
         |"+Пациент.ДокументУдостоверяющийЛичность;
      КонецЕсли;
      ТабДок.Вывести(ТелоДоговора);
      
      Если ЕстьМРТ Тогда
         ТабДок.Вывести(СекцияМРТ);
      КонецЕсли;   
      
      Запрос = Новый Запрос;
      Запрос.Текст="ВЫБРАТЬ
      |   КонтактнаяИнформация.Представление как адрес
      |ИЗ
      |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
      |ГДЕ
      |   КонтактнаяИнформация.Объект = &Объект
      |   И КонтактнаяИнформация.Вид = &Вид";
      //Параметры запроса
      Запрос.УстановитьПараметр("Вид",справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);//Справочник ссылка: Виды контактной информации
      Запрос.УстановитьПараметр("Объект",Пациент);//Справочник ссылка: Контрагенты
      
      Результат=Запрос.Выполнить().Выбрать();
      Если Результат.Следующий() Тогда
         Заказчик=Заказчик+"
         |Адрес: "+результат.адрес;
      КонецЕсли;

      Запрос = Новый Запрос;
      Запрос.Текст="ВЫБРАТЬ
      |   КонтактнаяИнформация.Представление как телефон
      |ИЗ
      |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
      |ГДЕ
      |   КонтактнаяИнформация.Объект = &Объект
      |   И КонтактнаяИнформация.Вид = &Вид";
      //Параметры запроса
      Запрос.УстановитьПараметр("Вид",справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);//Справочник ссылка: Виды контактной информации
      Запрос.УстановитьПараметр("Объект",Пациент);//Справочник ссылка: Контрагенты
      
      Результат=Запрос.Выполнить().Выбрать();
      Если Результат.Следующий() Тогда
         Заказчик=Заказчик+"
         |Тел.:"+результат.телефон;
      КонецЕсли;

      Подписи.Параметры.Заказчик=Заказчик;
      Подписи.Параметры.ФамилияИО=Пациент.Наименование;
      ТабДок.Вывести(Подписи);
      ТабДок.ПолеСверху = 5;
      ТабДок.ПолеСнизу  = 5;
   ИначеЕсли Организация.Код = "000000003" Тогда
      Макет=ПолучитьМакет("ДоговорМДТ");
      Шапка=Макет.ПолучитьОбласть("Договор");
      Шапка.Параметры.НомерДоговора = Число(Прав(Номер,5));
      Шапка.Параметры.ФИОПолностью = Пациент.НаименованиеПолное;
      Шапка.Параметры.ФИОКратко = Пациент.Наименование;
      Шапка.Параметры.ДатаДоговора = Формат(Дата,"ДЛФ=ДД");
      Шапка.Параметры.СуммаДоговора = СуммаДокумента;
      ТабДок.Вывести(Шапка);
      
      Согласие=Макет.ПолучитьОбласть("Согласие");
      Согласие.Параметры.ФИОПолностью = Пациент.НаименованиеПолное;
      ТабДок.Вывести(Согласие);
      
      ТабДок.ПолеСверху = 5;
      ТабДок.ПолеСнизу  = 5;
      ТабДок.ПолеСлева  = 5;
      ТабДок.ПолеСправа = 5;
      ТабДок.АвтоМасштаб = Истина;
      ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   КонецЕсли;      
      
   ТабДок.Показать();
   
КонецПроцедуры

Собственно ошибка {Документ.Т_Договор.Форма.ФормаДокумента.Форма(334,1)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
<<?>>КонецПроцедуры (Проверка: Толстый клиент (обычное приложение))

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Н-да... все хуже. Платформа вам вроде бы на русском пишет, что не хватает "конец если". Думаю, что посчитать "Если" и "КонецЕсли" - вы сможете самостоятельно. Как-то считать в вашем неотформатированном тексте мне не очень хочется.


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 330
Последний ответ 12 Окт 2017, 14:02
от wise
Синхронизация подразделений и подразделений организации

Автор a.nikulnikovaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 868
Последний ответ 27 Июн 2016, 13:16
от Kironten
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 280
Последний ответ 18 Авг 2017, 11:57
от ZSS
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 14082
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Отчет "Списки сотрудников организации" ЗУП

Автор НовенькаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2411
Последний ответ 28 Ноя 2014, 08:36
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 209
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal