Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 17:53

Работа с табличной частью документа в 1С

Автор Hohlova, 12 фев 2015, 08:09

0 Пользователей и 1 гость просматривают эту тему.

Hohlova

Здравствуйте Всем) Есть табличная часть документа с полями: Номенклатура, Единица измерения, Количество. Номенклатура имеет составной тип (СправочникСсылка.Номенклатура; СправочникСсылка.ОсновноеСредство). Как сделать так, чтобы при добавлении новой строчки в табличную часть у поля Номенклатура автоматически ставился тип СправочникСсылка.Номенклатура, и если уже очень надо то переключаться на основные средства

Hohlova

Я понимаю, что тут скорее всего все очень просто, может надо поставить какую - нибудь галочку где - то, но я никак не могу найти эту галочку!!! Помогите пожалуйста...
Добавлено: 12 фев 2015, 09:07


Я уже пробовала прописать так:
Процедура ИнструментыПередНачаломДобавления(Элемент, Отказ, Копирование)
   Если Не Отказ и Не Копирование Тогда
      ЭлементыФормы.Инструменты.ТекущиеДанные.Номенклатура = ПредопределенноеЗначение("Справочник.Номенклатура.ПустаяСсылка");
   КонецЕсли;
КонецПроцедуры
Но здесь он выдает ошибку, что Номенклатура не является значением объектного типа
Добавлено: 12 фев 2015, 09:14


Еще попытка была
Процедура ИнструментыПередНачаломДобавления(Элемент, Отказ, Копирование)
   Если Не Отказ и Не Копирование Тогда
      ЭтотОбъект.Инструменты.Добавить().Номенклатура = ПредопределенноеЗначение("Справочник.Номенклатура.ПустаяСсылка");
   КонецЕсли;
Тут срабатывает, но добавляется строка с выбором справочников и еще одна строка у которой сразу данные из справочника номенклатура

vitasw


Hohlova


vitasw

Процедура ТабличнаяЧасть1ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока Тогда
Элемент.ТекущиеДанные.Номенклатура=Справочники.Номенклатура.ПустаяСсылка();
КонецЕсли;
КонецПроцедуры

Hohlova

:zebzdr:УРААА СПАСИБО ОГРОМНОЕ!!! ЭТО ТО ЧТО НАДО

vitasw


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск