Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Работа с табличной частью документа в 1С  (Прочитано 2157 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Hohlova

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте Всем) Есть табличная часть документа с полями: Номенклатура, Единица измерения, Количество. Номенклатура имеет составной тип (СправочникСсылка.Номенклатура; СправочникСсылка.ОсновноеСредство). Как сделать так, чтобы при добавлении новой строчки в табличную часть у поля Номенклатура автоматически ставился тип СправочникСсылка.Номенклатура, и если уже очень надо то переключаться на основные средства


Оффлайн Hohlova

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Я понимаю, что тут скорее всего все очень просто, может надо поставить какую - нибудь галочку где - то, но я никак не могу найти эту галочку!!! Помогите пожалуйста...
Добавлено: 12 Фев 2015, 09:07

Я уже пробовала прописать так:
Процедура ИнструментыПередНачаломДобавления(Элемент, Отказ, Копирование)
   Если Не Отказ и Не Копирование Тогда
      ЭлементыФормы.Инструменты.ТекущиеДанные.Номенклатура = ПредопределенноеЗначение("Справочник.Номенклатура.ПустаяСсылка");
   КонецЕсли;
КонецПроцедуры
Но здесь он выдает ошибку, что Номенклатура не является значением объектного типа
Добавлено: 12 Фев 2015, 09:14

Еще попытка была
Процедура ИнструментыПередНачаломДобавления(Элемент, Отказ, Копирование)
   Если Не Отказ и Не Копирование Тогда
      ЭтотОбъект.Инструменты.Добавить().Номенклатура = ПредопределенноеЗначение("Справочник.Номенклатура.ПустаяСсылка");
   КонецЕсли;
Тут срабатывает, но добавляется строка с выбором справочников и еще одна строка у которой сразу данные из справочника номенклатура

Последний раз редактировалось: Hohlova; 12 Фев 2015, 09:14. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Какое приложение?

Оффлайн Hohlova

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Обычное приложение

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Процедура ТабличнаяЧасть1ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока Тогда
Элемент.ТекущиеДанные.Номенклатура=Справочники.Номенклатура.ПустаяСсылка();
КонецЕсли;
КонецПроцедуры

Оффлайн Hohlova

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
:zebzdr:УРААА СПАСИБО ОГРОМНОЕ!!! ЭТО ТО ЧТО НАДО

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7743
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4780
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8509
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal