Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: автоматическое заполнение табличной части документа выборкой из справочника по владельцу  (Прочитано 2651 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jediAlex1985

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-11
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему справочник "КритерииОценки", где создал реквизит НаименованиеКритерия -стандартное наименование по длине не устраивало. Для второго справочника изменил представление в менеджере:

Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
 
    СтандартнаяОбработка = Ложь;
    Представление = Данные.НаименованиеКритерия;
 
КонецПроцедуры
Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
 
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("НаименованиеКритерия");
КонецПроцедуры


Справочники заполнил. Далее нужен документ, которым сотрудники и их руководители записывают оценки своей работы. Сделал я такой документ с реквизитами: Сотрудник - СправочникСсылкаСотрудники, Подразделение - СправочникСсылкаПодразделения, Должность -СправочникСсылкаДолжности. Сдела табличную часть документа с реквизитами: Критерий - СправочникСсылкаКритерииОценки,ВесовойКоэффициент - число,ОценкаСотрудника - число; ОценкаРуководителя- число.
Появилась такая задача: заполнить табличную часть критериями оценки автоматически при выборе сотрудника в форме документа. Я сделал такой код:

&НаСервере
Функция ВыгрузкаКритериев()
ВыгрузкаКритериев = Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
Возврат ВыгрузкаКритериев;
КонецФункции 
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
    //Выборка = Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
Результат=ВыгрузкаКритериев();
    Пока Результат.Следующий() Цикл
        Элементы.КритерииОценки.ДобавитьСтроку();     
        НоваяСтрока=Элементы.КритерииОценки.ТекущиеДанные;
        //НоваяСтрока.КритерийОценкиКритерий=Результат.Ссылка;
        НоваяСтрока.КритерийОценкиНольБаллов=Результат.НольБаллов;
        НоваяСтрока.Записать();
    КонецЦикла;
КонецПроцедуры


при изменении реквизита Сотрудник в документе вылетает ошибка:
Ошибка отображения типов: отсутствует отображение для типа Справочниквыборка.КритерииОценки
Что тут не так? помогите пожалуйста


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Типовая ошибка наинающих. Своетую почитать, что такое "Клиент" и "Сервер".
Если в двух словах, то
клиент - это форма, все что на форме отображено, и управление видимостью элементов. Причем все что вы видите на форме, грубо говоря, это картинки со стоками и никаких ссылочных значений на клиенте нет.
сервер - это объекты, ссылки, выборки, запросы, операции над базой данных и прочая-прочая-прочая.
Далее, получая что-то на стороне сервера и возвращая на клиент, платформа пытается отобразить полученный "объект" в соответствии с представлением. Естественно, далеко не у всех объектов может иметься представление, как например в данном случае, справочник-выборка. Вот, как по вашему, форма должна отобразить справочник-выборку? 
 

Оффлайн jediAlex1985

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-11
  • Сайт: 
  • Профессия: Программист 1С
насчет сервера и клиента я понял... но вот и как теперь на клиенте эту выборку отобразить? притом, что выборка идет по параметру, значение которого передается из формы?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
насчет сервера и клиента я понял... но вот и как теперь на клиенте эту выборку отобразить? притом, что выборка идет по параметру, значение которого передается из формы?
Да ну е-мое! "Я все понял, только непонял" - могу предложить только читать умные книжки до наступления просветления.
На Сервере!, работаете на сервере!
Рекомендую почитать хоть одну умную книжку, ваши вопросы - элементарны, охотников отвечать на такие банальные вопросы - ну очень мало.

Оффлайн jediAlex1985

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-11
  • Сайт: 
  • Профессия: Программист 1С
Сделал так:
 &НаСервере
Процедура ВыгрузкаКритериев()
Результат=Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
Пока Результат.Следующий() Цикл
    НоваяСтрока=Объект.КритерииОценки.Добавить();       
        //НоваяСтрока=Объект.КритерииОценки.ТекущиеДанные; 
        //НоваяСтрока.КритерийОценкиКритерий=Результат.Ссылка;
        НоваяСтрока.КритерииОценкиНольБаллов=Результат.НольБаллов;
        НоваяСтрока.Записать();
    КонецЦикла;
 
КонецПроцедуры 
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
    ВыгрузкаКритериев()
КонецПроцедуры
в модуле формы. Добавляет одну строку в табличную часть пустую. При этом ругается :
 
Документ.ОценочнаяВедомость.Форма.ФормаДокумента.Форма(8)}: Поле объекта не обнаружено (КритерииОценкиНольБаллов)
        НоваяСтрока.КритерииОценкиНольБаллов=Результат.НольБаллов;


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Сделал так:
 &НаСервере
Процедура ВыгрузкаКритериев()
Результат=Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
Пока Результат.Следующий() Цикл
    НоваяСтрока=Объект.КритерииОценки.Добавить();       
        //НоваяСтрока=Объект.КритерииОценки.ТекущиеДанные; 
        //НоваяСтрока.КритерийОценкиКритерий=Результат.Ссылка;
        НоваяСтрока.КритерииОценкиНольБаллов=Результат.НольБаллов;
        НоваяСтрока.Записать();
    КонецЦикла;
 
КонецПроцедуры 
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
    ВыгрузкаКритериев()
КонецПроцедуры
в модуле формы. Добавляет одну строку в табличную часть пустую. При этом ругается :
 
Документ.ОценочнаяВедомость.Форма.ФормаДокумента.Форма(8)}: Поле объекта не обнаружено (КритерииОценкиНольБаллов)
        НоваяСтрока.КритерииОценкиНольБаллов=Результат.НольБаллов;


Вы, пожалуйста, чем сразу впадать в отчаяние и строчить сообщения - попробуйте вникнуть в те сообщения, которые вам пишет платформа. В данном случае платформа сообщает, что у вас отсутствует реквизит табличной части КритерииОценкиНольБаллов. Ищите где вы ошиблись, возможно вы спутали идентификатор имени реквизита формы и имени реквизита объекта.

Оффлайн jediAlex1985

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-11
  • Сайт: 
  • Профессия: Программист 1С
спасибо огромное за помощь)) наконец разобрался и все работает))


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4769
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8479
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7330
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 213
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal