Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Неправильное имя внешнего источника в запросе  (Прочитано 874 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Собсно вот сабж:
&НаСервере
Процедура ОбновитьОтбор();
ТЗ = Объект.Ос.Выгрузить();
Запрос = Новый Запрос(
"ВЫБРАТЬ
|   ТЗ.ОсновноеСредство.Ссылка,
|   ТЗ.ОсновноеСредство.Код
|ПОМЕСТИТЬ
|   Объект.Ос ИЗ
|   &ТЗ КАК ТЗ;
|ВЫБРАТЬ
|   ОС.ОсновноеСредство.Ссылка,
|   ОС.ОсновноеСредство.Код
            |   ИЗ
|   Объект.Ос КАК ОС
|   ИТОГИ ПО
|   ОС.ОсновноеСредство.Код" );
Запрос.УстановитьПараметр("ТЗ",ТЗ);
Вот бага:
Цитировать
Ошибка при вызове метода контекста (Выполнить)
          РезультатЗапроса = Запрос.Выполнить();
по причине:
Неправильное имя внешнего источника "Объект.Ос"
<<?>>Объект.Ос ИЗ
в чем трабл? Объект.Ос - табличная часть документа. пробовал обращаться просто Ос - не канает.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
В имени временной таблицы точки быть не должно
 Запрос = Новый Запрос(
            "ВЫБРАТЬ
            |   ТЗ.ОсновноеСредство.Ссылка,
            |   ТЗ.ОсновноеСредство.Код
            |ПОМЕСТИТЬ
            |   ОбъектОс ИЗ
            |   &ТЗ КАК ТЗ;
            |ВЫБРАТЬ
            |   ОС.ОсновноеСредство.Ссылка,
            |   ОС.ОсновноеСредство.Код
            |   ИЗ
            |   ОбъектОс КАК ОС
            |   ИТОГИ ПО
            |   ОС.ОсновноеСредство.Код" );

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Временная это ТЗ. А из объект.ос мы как-раз беремм данные

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
:D:D:D
е-мое, лечить гланды через жопу.
Т.е. данные нужно достать из табличной части и поместить в ТЗ - я правильно понимаю?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Вот эта конструкция
ПОМЕСТИТЬ
|   ОбъектОс
создает временную таблицу. А вообще в чем суть задачи?

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Суть в том чтобы в ТабличнойЧасти(объект.Ос) документа отсортировать ссылочные данные по полю код.
Сделать это методом сортировки не получится (тк данные ссылочные) приходится выгружать во временную таблицу(ТЗ), сортировать и помещать обратно.

  Если Этаформа.ОтборОС = "По имени" тогда
    Объект.Ос.Сортировать("ОсновноеСредство Возр");
ИначеЕсли Этаформа.ОтборОС = "По коду" тогда
ТЗ = Объект.Ос.Выгрузить();
Запрос = Новый Запрос(
"ВЫБРАТЬ
|   ТЗ.ОсновноеСредство.Ссылка,
|   ТЗ.ОсновноеСредство.Код
|ПОМЕСТИТЬ
|   Ос ИЗ
|   &ТЗ КАК ТЗ;
|ВЫБРАТЬ
|   ОС.ОсновноеСредство.Ссылка,
|   ОС.ОсновноеСредство.Код
                  |   ИЗ
|   Объект.Ос КАК ОС
|   ИТОГИ ПО
|   ОС.ОсновноеСредство.Код" );
Запрос.УстановитьПараметр("ТЗ",ТЗ);
Объект.Ос.Очистить();
РезультатЗапроса = Запрос.Выполнить();
Если не РезультатЗапроса.Пустой() Тогда
Этаформа.Выборка.РезультатЗапроса.Выбрать();
Пока Этаформа.Выборка.Следующий() цикл
ЗаполнитьЗначенияСвойств(Объект.Ос.Добавить(), Этаформа.Выборка);
КонецЦикла;
КонецЕсли;

    КонецЕсли;
Пишет - поле не найдено ТЗ.ОсновноеСредство.Ссылка

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Зачем временная таблица тогда? Если уж так сильно хочется, то укажите в качестве параметра ссылку на документ и в запросе вытаскивайте данные какие надо и сортируйте их как надо.


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4121
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1112
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2658
Последний ответ 27 Окт 2015, 10:29
от vitasw
Временная таблица во вложенном запросе+Группировка VS Таблица значений + Свернуть

Автор TsaigerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 581
Последний ответ 14 Июл 2017, 23:10
от Tsaiger

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 324
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal