Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 18:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Мигрирование данных из реквезитов в регистр  (Прочитано 844 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Создаю внешнюю обработку для мигрирования рекезитов в регистр
Не робит нифига. Где я порю чушь?
&НаКлиенте
Процедура ВзятьБуковки(Команда)
Выполнитьзахват();   
КонецПроцедуры

&НаСервере
Функция Выполнитьзахват()

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Организации.НастройкаДаты,
| Организации.ОсновнойВариант,
|ИЗ
| Справочник.Организации КАК Организации";
Выборка = Запрос.Выполнить().Выгрузить();
Этаформа.Список = выборка;
КонецФункции

&НаСервере
Процедура ОтдатьБуковки(Команда)
           
Рег = РегистрыСведений.СведенияОрганизаций.СоздатьМенеджерЗаписи();
Для каждого строка из ЭтаФорма.Список цикл
        Рег.НастройкаДаты = Список.Параметры("НастройкаДаты");
    Рег.ОсновнойВариант = Список.Параметры("ОсновнойВариант"); 
  Рег.Записать();
КонецЦикла;

// Вставить содержимое обработчика.
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. какая структура регистра?
2. &НаСервере
Процедура ОтдатьБуковки(Команда)
если это обработчик команды то он выполняется только на клиенте, в крайнем случае с уходом на сервер внутри.
3. Вот дэ фак из вис?
Список.Параметры("НастройкаДаты");
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
1.Регистр с одним измерением организация и ресурсами по полям
2. Поправил.Теперь итератор не определен:(  (ни на клиенте ни на сервере)
3. Зис из сотая попытка записать данные в регистр хоть ломом по серверу.

&НаКлиенте
Процедура ВзятьБуковки(Команда)
Выполнитьзахват();   
//Элементы.Список.Обновить();
КонецПроцедуры

&НаСервере
Функция Выполнитьзахват()
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

//Макет = ВнешниеОбработки.ПереносДанных.ПолучитьМакет("Макет");
//Запрос = Новый Запрос;
//Запрос.Текст =
// "";

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Организации.НастройкаДаты,
| Организации.ОсновнойВариант,
|ИЗ
| Справочник.Организации КАК Организации";

Выборка = Запрос.Выполнить().Выгрузить();
Этаформа.Список = выборка;
КонецФункции

&НаКлиенте
Процедура ОтдатьБуковки(Команда)

//Выполнитьзахват(выборка);

Для каждого строка из ЭтаФорма.Список цикл
         
ОтдатьСервуБуковки();
КонецЦикла;

// Вставить содержимое обработчика.
КонецПроцедуры

&НаСервере
Процедура ОтдатьСервуБуковки()
          Рег = РегистрыСведений.СведенияОрганизаций.СоздатьМенеджерЗаписи();
  Рег.НастройкаДаты = Список.Параметры("НастройкаДаты");
    Рег.ОсновнойВариант = Список.Параметры("ОсновнойВариант");
     
 
 

 
  Рег.Записать();

КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. раз у вас есть измерение "организация", то в Выполнитьзахват() надо запросом еще и ссылку на организацию получить
2. на клиенте в ОтдатьБуковки() просто вызываете серверный метод ОтдатьБуковкиНаСервере() и уже на сервере крутите цикл по ТЧ Список
НаборЗаписей = РегистрыСведений.СведенияОрганизаций.СоздатьНаборЗаписей();
Для каждого СтрокаТЧ Из Объект.Список Цикл
    Запись = НаборЗаписей.Добавить();
    Запись.Организация = СтрокаТЧ.Организация;
    Запись.НастройкаДаты= СтрокаТЧ.НастройкаДаты;
    Запись.ОсновнойВариант= СтрокаТЧ.ОсновнойВариант;
КонецЦикла;
Попытка
    НаборЗаписей.Записать();
Исключение
КонецПопытки;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Вот такая хрень
&НаКлиенте
Процедура ВзятьБуковки(Команда)
Выполнитьзахват();   
//Элементы.Список.Обновить();
КонецПроцедуры

&НаСервере
Функция Выполнитьзахват()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
    |   Организации.Ссылка,
| Организации.НастройкаДаты,
| Организации.ИспользоватьУполномоченных,
| Организации.ПриказНаПодпись,
|ИЗ
| Справочник.Организации КАК Организации";
Выборка = Запрос.Выполнить().Выгрузить();
Этаформа.Список = выборка;
КонецФункции

&НаКлиенте
Процедура ОтдатьБуковки(Команда)         
ОтдатьСервуБуковки();
КонецПроцедуры

&НаСервере
Процедура ОтдатьСервуБуковки()
Рег = РегистрыСведений.СведенияОрганизаций.СоздатьНаборЗаписей();
Для каждого СтрокаТЧ из Список цикл
      Запись = Рег.Добавить();
      Запись.АвторЗаписи = СтрокаТЧ.АвторЗаписи;
  Запись.НастройкаДаты = СтрокаТЧ.НастройкаДаты;
    Запись.ИспользоватьУполномоченных = СтрокаТЧ.ИспользоватьУполномоченных;
      Запись.ПриказНаПодпись = СтрокаТЧ.ПриказНаПодпись;
КонецЦикла;  
Попытка
Рег.Записать();
Исключение
    КонецПопытки;
КонецПроцедуры

На "взять буковки" пишет ошибку ожидается выражение ВЫБРАТЬ, пофиг прописал этот же запрос прямо в дин. список
На "отдать буковки" пишет итератор не определен.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7465
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3895
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2134
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7389
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6980
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
140 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 489
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal