Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 04:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена  (Прочитано 958 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BEKS

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-09
  • Сайт: 
Здравствуйте!
Изучаю 1с совсем недавно. Вот никак не могу разобраться с задачей, выскакивает ошибка о том, что переменная (Оплата) не определена. Что я не так сделал??
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Если Объект.Работающий И Объект.ДатаРождения='00010101' Тогда
Сообщить("Не заполнена дата рождения");
Отказ=Истина;
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// Вставить содержимое обработчика.
ОбновитьОплатуТруда(Объект.Занятость, Оплата);
КонецПроцедуры

&НаКлиенте
Процедура ЗанятостьПриИзменении(Элемент)
// Вставить содержимое обработчика.
ОбновитьОплатуТруда(Объект.Занятость,  Оплата);
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура ОбновитьОплатуТруда  (Занятость, Оплата)
Если Занятость.Пустая() Тогда
   Оплата=0
   Иначе
Оплата=ОбщиеМеханизмы.ПолучитьЗанятость(Занятость);
КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 09 Фев 2015, 03:08


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А что есть Оплата в вашем контексте?

Оффлайн BEKS

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-09
  • Сайт: 
А что есть Оплата в вашем контексте?
"Оплата"-это как я понял реквизит, и я его неправильно записал, надо было писать "ОплатаТруда"... Только что понял... Просто я думал что это переменная, и ее модно обзывать как угодно.. вот и написал кратко. В общем объяснил как мог... но все равно задача не решена... Теперь мне не показывает значение реквизита "Оплата труда"...
Добавлено: 09 Фев 2015, 03:43

Ну вроде как все заработало... сам допер... доволен, приятно когда получается....:lol:

Последний раз редактировалось: BEKS; 09 Фев 2015, 03:43. Причина: Объединение сообщений


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7877
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3273
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Процедура или функция с указанным именем не определена (Записать)

Автор oo ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3177
Последний ответ 02 Фев 2017, 13:04
от oo oo
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6053
Последний ответ 24 Янв 2012, 16:07
от asd_123
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1039
Последний ответ 29 Июн 2016, 10:15
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 209
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal