Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет двойного запуска.  (Прочитано 2008 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vitalik54

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-29
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Подскажите, в каком модуле в УТ11 необходимо прописать код, для запрета двойного запуска под одним пользователем?


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в Модуле управляемого приложения
обрабатываете такое событие

Процедура ПередНачаломРаботыСистемы(Отказ)

ДопустимоеКолСеансов = 2;
лкИмя = СокрЛП(ИмяПользователя());
Отказ = ОМ.ПроверкаСеанса(лкИмя, ДопустимоеКолСеансов);

Если Отказ Тогда
Предупреждение(
"У пользователя: "
+ лкИмя
+ " уже запущен(о) "
+ ДопустимоеКолСеансов
+ " сеанс(ов) 1С!",30);
КонецЕсли;


КонецПроцедуры

в сервермом модуле размещаете такую функцию
&НаСервере
Функция ПроверкаСеанса(лкИмя, ДопустимоеКоличество)Экспорт

лкВсеСоединения = ПолучитьСоединенияИнформационнойБазы();
лкКоличество = 0;
Для каждого лкСтр Из лкВсеСоединения Цикл
Если Найти(лкСтр.имяПриложения,"1CV8")=1
   И лкСтр.Пользователь <> Неопределено
   И СокрЛП(лкСтр.Пользователь.Имя) = лкИмя Тогда
   лкКоличество = лкКоличество + 1;
   КонецЕсли;
   Если лкКоличество > ДопустимоеКоличество Тогда
   Возврат Истина;
   КонецЕсли;
КонецЦикла;

   Возврат Ложь;

КонецФункции
 

Через переменную (или в константы можно вынести) можно рулить допустимым количеством сеансов, а еще лучше в настройки каждого пользователя вынести, кому-то можно 1 сеанс в базе, а главбуху, например - 5 сеансов! Красота!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Vitalik54

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-29
  • Сайт: 
  • Профессия: Ученик 1С
Отказ = ОМ.ПроверкаСеанса(лкИмя, ДопустимоеКолСеансов);

А можете пояснить, что значит ОМ?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Отказ = ОМ.ПроверкаСеанса(лкИмя, ДопустимоеКолСеансов);

А можете пояснить, что значит ОМ?
Наименование Общего Модуля

Оффлайн Vitalik54

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-29
  • Сайт: 
  • Профессия: Ученик 1С
в сервермом модуле размещаете такую функцию
&НаСервере
Функция ПроверкаСеанса(лкИмя, ДопустимоеКоличество)Экспорт

лкВсеСоединения = ПолучитьСоединенияИнформационнойБазы();
лкКоличество = 0;
Для каждого лкСтр Из лкВсеСоединения Цикл
Если Найти(лкСтр.имяПриложения,"1CV8")=1
   И лкСтр.Пользователь <> Неопределено
   И СокрЛП(лкСтр.Пользователь.Имя) = лкИмя Тогда
   лкКоличество = лкКоличество + 1;
   КонецЕсли;
   Если лкКоличество > ДопустимоеКоличество Тогда
   Возврат Истина;
   КонецЕсли;
КонецЦикла;

   Возврат Ложь;

КонецФункции
 

А как попасть в этот серверный модуль?

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
можете сами создать, или использовать имеющийся, в конфигураторе посмотрите свойство общего модуля Сервер = Истина
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Запрет на изменение "справочники - предприятие"

Автор maskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 947
Последний ответ 25 Июл 2016, 09:09
от SGIRG
Как восстановить в ИБ запрет изменения с поддержкой (восстановить серый замочек)

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 992
Последний ответ 06 Июл 2016, 14:55
от ktu78
Установил запрет на редактирование проведенных документов, но продавцы научились его "обходить"

Автор technopartnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3473
Последний ответ 07 Сен 2014, 22:33
от Besart
Запрет на редактирование документов = Автоматизированный выпуск документов строгой отчётности

Автор ПашёкРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 899
Последний ответ 06 Сен 2014, 10:15
от Пашёк
Запрет проведения "Реализация товаров и услуг" при условии

Автор dmkovpakРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1873
Последний ответ 26 Фев 2015, 09:21
от dmkovpak

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal