Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переписать функцию из 7.7 в 8.1  (Прочитано 3044 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
                                   Здравствуйте!
Я пытаюсь переписать модуль,написанный для 7.7,в 8.1.Не могли бы Вы мне подсказать,как переделать следующую функцию?Спасибо.
Функция ВалютаДокумента(Д,Субконто2)
   
   Если Д.Выбран() = 1 Тогда
      Если (Д.Договор.ВалютаДоговора.Выбран() = 1) Тогда
         Возврат Д.Договор.ВалютаДоговора;
      КонецЕсли;
      
   ИначеЕсли ТипЗначенияСтр(Субконто2) = "Справочник" Тогда
      Если Субконто2.Вид() = "Договоры" Тогда
         Возврат Субконто2.ВалютаДоговора;
      КонецЕсли;
   КонецЕсли;
   
   Возврат "";
   
КонецФункции // ВалютаДокумента()



Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Автор, вы жжете=) Из какой конфигурации в какую хотя бы будете переносить?

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Просто я хочу эту функцию,написанную в семёрке,переписать в виде запроса в восьмёрке.

Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
Абсолютно непонятно...Объясните точней

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
У меня есть внешняя обработка,написанная для 1с Предприятие 7.7,мне надо переделать её для 1с 8.1.Модуль такой:
Функция ВалютаДокумента(Д,Субконто2)
   
   Если Д.Выбран() = 1 Тогда
      Если (Д.Договор.ВалютаДоговора.Выбран() = 1) Тогда
         Возврат Д.Договор.ВалютаДоговора;
      КонецЕсли;
      
   ИначеЕсли ТипЗначенияСтр(Субконто2) = "Справочник" Тогда
      Если Субконто2.Вид() = "Договоры" Тогда
         Возврат Субконто2.ВалютаДоговора;
      КонецЕсли;
   КонецЕсли;
   
   Возврат "";
   
КонецФункции // ВалютаДокумента()

//*******************************************
Процедура Сформировать() 
   Перем Валюта,Стр,Приход;
   
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица"); 
   Сч51    = СчетПоКоду("51");
   Сч52    = СчетПоКоду("52");
   Если Дата2 > КонецРассчитанногоПериодаБИ() Тогда
      Предупреждение("На " + Дата2 + " бухгалтерские итоги не рассчитаны!
      |Расчет итогов выполняется в режиме
      |""Операции - Управление бухгалтерскими итогами""."); 
      Возврат;
   Иначе
      БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
      Если ВыбБС.Выбран()=1 Тогда
          БухИт.ИспользоватьСубконто(ВидыСубконто.БанковскиеСчета,ВыбБС);      
      Иначе
         БухИт.ИспользоватьСубконто(ВидыСубконто.БанковскиеСчета);      
      КонецЕсли;
      
      БухИт.ВыполнитьЗапрос(Дата1,Дата2,"51,52",,,,"Операция","СВ");   
   КонецЕсли;    
   
   КолСтр = 0;
   БухИт.ВыбратьСубконто(ВидыСубконто.БанковскиеСчета);
   Пока БухИт.ПолучитьСубконто(ВидыСубконто.БанковскиеСчета) =1 Цикл 
      БухИт.ВыбратьСчета();
      Пока БухИт.ПолучитьСчет()=1 Цикл
         БухИт.ВыбратьПериоды();
         Пока БухИТ.ПолучитьПериод()=1 Цикл
            Документ   = БухИт.Операция.Документ;
            БС="";
            Если Документ.Вид()="Выписка" Тогда
                БС = Документ.БанковскийСчет;
            ИначеЕсли (Документ.Вид()="ПриходныйОрдер") или (Документ.Вид()="РасходныйОрдер") Тогда
                БС = Документ.Субконто1;
            КонецЕсли;
            ТекстШапки = Документ; 
            Если БухИт.Счет = Сч51 Тогда
               ОстатокНач  = БухИт.СНД("С");
               ОборотПриход= БухИт.КО("С");
               ОборотРасход= БухИт.ДО("С");
               ОстатокКон  = БухИт.СКД("С");
            Иначе   
               БухИт.ВыбратьВалюты();
               Если БухИт.ПолучитьВалюту()=1 Тогда
                  ОстатокНач  = БухИт.СНД("В");             
                  ОборотПриход= БухИт.КО("В");
                  ОборотРасход= БухИт.ДО("В");
                  ОстатокКон  = БухИт.СКД("В");     
               КонецЕсли;
            КонецЕсли;                       
            //Если КолСтр + 6 + Документ.КоличествоСтрок()>49 Тогда
            //   Таб.НоваяСтраница();
            //   КолСтр=0;
            //КонецЕсли; 
            ВсегоПриход = 0;
            ВсегоРасход = 0;
            Таб.ВывестиСекцию("Шапка");
            Если Документ.Вид()="ПриходныйОрдер" Тогда
               Приход  = 1;
               НомерПЛ = Документ.ДокументПоставки.НомерДок;
               Счет    = Формат(ОборотПриход,"Ч015.2. ");
               ВсегоПриход = ВсегоПриход + ОборотПриход; 
               Контрагент  = СокрЛП(Документ.ПринятоОт);
               Содержание  = СокрЛП(Документ.Основание);
               Таб.ВывестиСекцию("Строка");
            ИначеЕсли Документ.Вид()="РасходныйОрдер" Тогда
               Приход  = 0;
               НомерПЛ = Документ.ДокументПоставки.НомерДок;
               Счет    = Формат(ОборотРасход,"Ч015.2. ");
               ВсегоРасход = ВсегоРасход + ОборотРасход;   
               Контрагент  = СокрЛП(Документ.Выдать);
               Содержание  = СокрЛП(Документ.Основание);
               Таб.ВывестиСекцию("Строка");
            ИначеЕсли Документ.Вид()="Выписка" Тогда
               Документ.ВыбратьСтроки();
               Пока Документ.ПолучитьСтроку()=1 Цикл 
                  Приход = 0;
                  Если Документ.Приход>0 Тогда
                     Приход = 1;
                     Счет   = Формат(Документ.Приход,"Ч015.2. ");
                     ВсегоПриход = ВсегоПриход + Документ.Приход;
                  Иначе
                     Счет   = Формат(Документ.Расход,"Ч015.2. ");
                     ВсегоРасход = ВсегоРасход + Документ.Расход;
                  КонецЕсли;
                  Контрагент = Документ.Субконто1;
                  Если ТипЗначенияСтр(Документ.Субконто1) = "Справочник" Тогда
                     Контрагент = СокрЛП(Документ.Субконто1.Наименование);
                     Если Документ.Субконто1.Вид() = "Контрагенты" Тогда   
                        Контрагент =?(ПустоеЗначение(Документ.Субконто1.ПолнНаименование)=1,СокрЛП(Документ.Субконто1.Наименование),СокрЛП(Документ.Субконто1.ПолнНаименование));
                     КонецЕсли;
                  КонецЕсли;
                  Содержание = Документ.НазначениеПлатежа;        
                  Таб.ВывестиСекцию("Строка");   
                  КолСтр = КолСтр + 1;
               КонецЦикла;
            Иначе     
               Документ.Операция.ВыбратьПроводки();
               Пока Документ.Операция.ПолучитьПроводку()=1 Цикл
                  Если (Документ.Операция.Дебет.Счет=Сч51) или (Документ.Операция.Дебет.Счет=Сч52) Тогда
                     Приход = 1;                   
                     ВсегоПриход = ВсегоПриход + Документ.Операция.Сумма;
                      Контрагент  = Документ.Операция.Кредит.Контрагенты;
                  ИначеЕсли (Документ.Операция.Кредит.Счет=Сч51) или (Документ.Операция.Кредит.Счет=Сч52) Тогда
                      Приход = 0;                 
                     ВсегоРасход = ВсегоРасход + Документ.Операция.Сумма;
                     Контрагент  = Документ.Операция.Дебет.Контрагенты;
                  Иначе
                     Продолжить;
                  КонецЕсли;
                  НомерПЛ = Документ.Операция.ПервичныйДокумент;
                  Счет    = Формат(Документ.Операция.Сумма,"Ч015.2. ");                   
                  Содержание  = СокрЛП(Документ.Операция.Содержание);
                  Таб.ВывестиСекцию("Строка");                   
               КонецЦикла;
            КонецЕсли;
            Таб.ВывестиСекцию("Подвал"); 
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;
   
   Таб.Опции(0,0,0,0,"ОпцииВыпискиБанк","ОкноВыпискиБанк");
   Таб.ТолькоПросмотр(1);   
   //Таб.ПовторятьПриПечатиСтроки(3,4);
   Таб.ПараметрыСтраницы(1);
   
   Таб.Показать("Табличка по Выписке банка");
КонецПроцедуры
//*******************************************
Но так как я только-только начала заниматься 1с,то я не очень представляю с чего начать.

Оффлайн YouAreEmpty

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2010-08-12
  • Сайт: 
начинать можно с курсов 1с по основным объектам например


Теги:
 

невозможно выполнить статистическую функцию для выражения, содержащего выражение или вложенный запрос

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2600
Последний ответ 23 Фев 2014, 23:27
от Marta_Li
Как внешней обработкой запустить функцию из модуля формы типовой обработки

Автор zhenia-zaltzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 900
Последний ответ 18 Авг 2015, 22:58
от vitasw
Получение данных табличной части справочника по наименованию через функцию

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 15
Просмотров: 2396
Последний ответ 29 Май 2016, 06:28
от marshalbratsk
как написать функцию которая получит данные и выводит числовое значени

Автор cozac.ericРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 728
Последний ответ 05 Авг 2016, 09:43
от cozac.eric
Любой макрос, функцию,надстройку в EXCEL(WORD) взаимодействие с 1С

Автор TatitutuРаздел Резюме

Ответов: 1
Просмотров: 3138
Последний ответ 19 Мар 2010, 10:39
от Myti

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 127
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal