Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Янв 2018, 03:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие управляемой формы из другой формы внешней обработки  (Прочитано 6698 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yulenka

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте! Столкнулась со следующей проблемой. Пишу обработку заполнения табличной части для документа УТ11. В этой обработке мне необходимо вызвать открытие формы из главной формы обработки.
Прописала следующим образом:
&НаКлиенте
Процедура Загрузить()
мИмяВнешнейОбработки=ПодключитьВнешнююОбработкуСервер();
ОткрытьФорму("ВнешняяОбработка." + мИмяВнешнейОбработки + ".Форма.ФормаЗагрузки",,ЭтаФорма);
КонецПроцедуры

&НаСервере
 Функция ПодключитьВнешнююОбработкуСервер()
АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("ОбработкаПоЗагрузкеИзXLSВЗаявкуНаВозврат").Ссылка.ХранилищеОбработки.Получить());
    Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище, , Истина); 
КонецФункции

Программа просто при нажатии на кнопку ничего не делает. Помогите, пожалуйста, пробовала не только этот вариант, ничего не помогает.




Оффлайн LexaK

  • *****
  • Сообщений: 1280
  • РЕПУТАЦИЯ: 352
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте такой вариант,
Пример, форма внешней обработки, открывает форму внешний обработки, и сама закрывается

только свои данные в нужные места замените

&НаКлиенте
Процедура ОткрытьНовуюФорму()

ЭтаФорма.Закрыть();
ОткрытьФорму("ВнешняяОбработка.ОбработкаАдиминистратора.Форма.Форма",
Новый Структура("Ссылка,СортироватьРеквизиты,История,АдресХранилища",
Объект.Ссылка,
Объект.СортироватьРеквизиты,
Объект.История,
АдресХранилища)
);

КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Tiwin

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-18
  • Сайт: 
  • Профессия: Ученик 1С
попробуйте такой вариант,
Пример, форма внешней обработки, открывает форму внешний обработки, и сама закрывается

только свои данные в нужные места замените

&НаКлиенте
Процедура ОткрытьНовуюФорму()

ЭтаФорма.Закрыть();
ОткрытьФорму("ВнешняяОбработка.ОбработкаАдиминистратора.Форма.Форма",
Новый Структура("Ссылка,СортироватьРеквизиты,История,АдресХранилища",
Объект.Ссылка,
Объект.СортироватьРеквизиты,
Объект.История,
АдресХранилища)
);

КонецПроцедуры

Не согласен, вчера дали задание во внешней обработке из одной формы перейти в другую данные из второй записать в массив и отобразить в 1-ой, метод ОткрытьФорму во внешней обработке работать не будет. (1С Бухгалтерия ред. 3.0)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("ОбработкаПоЗагрузкеИзXLSВЗаявкуНаВозврат").Ссылка.ХранилищеОбработки.Получить());
    Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище, , Истина); 

1. Посмотрите отладчиком находится ли ваша обработка по наименованию
2. Попробуйте не устанавливать безопасный режим в методе Подключить(,,Ложь)


Теги:
 

Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6238
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4394
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3548
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 223
Последний ответ 24 Авг 2017, 10:43
от Golickoff
Пропадают начисления отпусков после обработки "Перерасчета зарплаты организации"

Автор bartolomewРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 689
Последний ответ 19 Июл 2016, 10:43
от bartolomew

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
AIFrame
71 Сообщений
alex0402
32 Сообщений
kiksi
27 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 142
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal