Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Окт 2017, 03:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие управляемой формы из другой формы внешней обработки  (Прочитано 5931 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yulenka

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте! Столкнулась со следующей проблемой. Пишу обработку заполнения табличной части для документа УТ11. В этой обработке мне необходимо вызвать открытие формы из главной формы обработки.
Прописала следующим образом:
&НаКлиенте
Процедура Загрузить()
мИмяВнешнейОбработки=ПодключитьВнешнююОбработкуСервер();
ОткрытьФорму("ВнешняяОбработка." + мИмяВнешнейОбработки + ".Форма.ФормаЗагрузки",,ЭтаФорма);
КонецПроцедуры

&НаСервере
 Функция ПодключитьВнешнююОбработкуСервер()
АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("ОбработкаПоЗагрузкеИзXLSВЗаявкуНаВозврат").Ссылка.ХранилищеОбработки.Получить());
    Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище, , Истина); 
КонецФункции

Программа просто при нажатии на кнопку ничего не делает. Помогите, пожалуйста, пробовала не только этот вариант, ничего не помогает.




Оффлайн LexaK

  • *****
  • Сообщений: 1259
  • РЕПУТАЦИЯ: 345
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте такой вариант,
Пример, форма внешней обработки, открывает форму внешний обработки, и сама закрывается

только свои данные в нужные места замените

&НаКлиенте
Процедура ОткрытьНовуюФорму()

ЭтаФорма.Закрыть();
ОткрытьФорму("ВнешняяОбработка.ОбработкаАдиминистратора.Форма.Форма",
Новый Структура("Ссылка,СортироватьРеквизиты,История,АдресХранилища",
Объект.Ссылка,
Объект.СортироватьРеквизиты,
Объект.История,
АдресХранилища)
);

КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Tiwin

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-18
  • Сайт: 
  • Профессия: Ученик 1С
попробуйте такой вариант,
Пример, форма внешней обработки, открывает форму внешний обработки, и сама закрывается

только свои данные в нужные места замените

&НаКлиенте
Процедура ОткрытьНовуюФорму()

ЭтаФорма.Закрыть();
ОткрытьФорму("ВнешняяОбработка.ОбработкаАдиминистратора.Форма.Форма",
Новый Структура("Ссылка,СортироватьРеквизиты,История,АдресХранилища",
Объект.Ссылка,
Объект.СортироватьРеквизиты,
Объект.История,
АдресХранилища)
);

КонецПроцедуры

Не согласен, вчера дали задание во внешней обработке из одной формы перейти в другую данные из второй записать в массив и отобразить в 1-ой, метод ОткрытьФорму во внешней обработке работать не будет. (1С Бухгалтерия ред. 3.0)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("ОбработкаПоЗагрузкеИзXLSВЗаявкуНаВозврат").Ссылка.ХранилищеОбработки.Получить());
    Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище, , Истина); 

1. Посмотрите отладчиком находится ли ваша обработка по наименованию
2. Попробуйте не устанавливать безопасный режим в методе Подключить(,,Ложь)


Теги:
 

Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5872
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4194
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3375
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 139
Последний ответ 24 Авг 2017, 10:43
от Golickoff
Можете помочь написать обработку которая сможет делать реализацию списывая поступления из другой базы или ссылаясь на них? просто одна компания покупает другая продает этот товар и чтобы вторая компания не смогла продать больше чем есть у первой? 1с 8.2 2

Автор Юлия АндреевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 671
Последний ответ 13 Ноя 2016, 19:25
от BuhRust

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
89 Сообщений
alex0402
43 Сообщений
AIFrame
42 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
29 Сообщений
Golickoff Golickoff
27 Сообщений
Liv98 Liv98
20 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений

* Кто онлайн

  • Точка Гостей: 179
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal