Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение цвета статуса заказа  (Прочитано 2534 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн malcevm

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-28
  • Сайт: 
  • Профессия: Разработчик 1С
Приветствую Вас боги 1С. Вообщем без вашей помощи ни как. Прикрутили мне значит к 1С:Предприятие 8.2 (8.2.19.90) статусы заказов их целых 10 штук. Вот сижу теперь и думаю как бы к этим статусам красок добавить. Скажем Оплачен=>Зеленый ну и, так и далее... Сам то я, в синтаксисе не силен могу только методом тыка понять, что за что отвечает, собственно по этому вам и кланяюсь.


Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Условное оформление в настройках отчета!!!! там можно всё под условия подогнать....

Оффлайн malcevm

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-28
  • Сайт: 
  • Профессия: Разработчик 1С
Условное оформление в настройках отчета!!!! там можно всё под условия подогнать....
Так мне не в отчете нужно это сделать, а в форме списка ЗаказПокупателя

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
ну значит в конфигураторе открываете свойства формы списка находите там "Условное оформление" и делаете в зависимости от условий

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
(обычные формы)
вам необходимо в форме списка,
использовать событие при получении данных, назначить такую процедуру
примерно так (могут быть ошибки, проверьте под отладчиком)
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

    Для каждого Оформление Из ОформленияСтрок Цикл

        лкЦвет  = WebЦвета.Белый;

        //"111","222" - замените на ваши статусы (Перечисление.СтатусЗаказа(?)...)
        Если Оформление.ДанныеСтроки.Статус = "111" Тогда
            лкЦвет = WebЦвета.Зеленый;
        ИначеЕсли Оформление.ДанныеСтроки.Статус = "222" Тогда
            лкЦвет = WebЦвета.Желтый;
        //ИначеЕсли ... и т.д.
        //    ...
        КонецЕсли;

        Оформление.ЦветФона = лкЦвет;

    КонецЦикла;

КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн malcevm

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-28
  • Сайт: 
  • Профессия: Разработчик 1С
(обычные формы)
вам необходимо в форме списка,
использовать событие при получении данных, назначить такую процедуру
примерно так (могут быть ошибки, проверьте под отладчиком)
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

    Для каждого Оформление Из ОформленияСтрок Цикл

        лкЦвет  = WebЦвета.Белый;

        //"111","222" - замените на ваши статусы (Перечисление.СтатусЗаказа(?)...)
        Если Оформление.ДанныеСтроки.Статус = "111" Тогда
            лкЦвет = WebЦвета.Зеленый;
        ИначеЕсли Оформление.ДанныеСтроки.Статус = "222" Тогда
            лкЦвет = WebЦвета.Желтый;
        //ИначеЕсли ... и т.д.
        //    ...
        КонецЕсли;

        Оформление.ЦветФона = лкЦвет;

    КонецЦикла;

КонецПроцедуры


Отладчик проблем не выявил, но что то не так, не красятся
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
   
    //Начало СостояниеЗаказа
    Для каждого Оформление Из ОформленияСтрок Цикл

        лкЦвет  = WebЦвета.Белый;       

        //"111","222" - замените на ваши статусы (Перечисление.СтатусЗаказа(?)...)
        Если Оформление.ДанныеСтроки.СостояниеЗаказа = "Заказать" Тогда
            лкЦвет = WebЦвета.Зеленый;
        ИначеЕсли Оформление.ДанныеСтроки.СостояниеЗаказа = "Подтвержден" Тогда
            лкЦвет = WebЦвета.Желтый;
        КонецЕсли;

        Оформление.ЦветФона = лкЦвет;       
       
    КонецЦикла;
КонецПроцедуры
[/quote]

Что здесь не так?

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
СостояниеЗаказа - это что? какой тип?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн malcevm

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-28
  • Сайт: 
  • Профессия: Разработчик 1С
СостояниеЗаказа - это что? какой тип?
Тип значения ПеречислениеСсылка.СостояниеЗаказа

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
так я же написал в примере! Комментарии надо читать! это не просто зелененькие строчки для красоты
//"111","222" - замените на ваши статусы (Перечисление.СтатусЗаказа(?)...)

в вашем случае, должно быть примерно так.

    ...
  Если Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисление.СостояниеЗаказа.Заказать Тогда
    ...
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
СостояниеЗаказа - это что? какой тип?
Тип значения ПеречислениеСсылка.СостояниеЗаказа
Ну тогда и сравнивайте с перечислением:
Если Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Заказать Тогда


 

Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1057
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
Изменение оформления строки по индексу строки

Автор BladrannerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 172
Последний ответ 13 Ноя 2017, 15:19
от alex0402
Изменение вида "выпадающего списка"

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1226
Последний ответ 20 Май 2016, 13:26
от LexaK
Запрет на изменение "справочники - предприятие"

Автор maskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 968
Последний ответ 25 Июл 2016, 09:09
от SGIRG
Изменение стандартной функции клавиши "Del" в документе

Автор APMEH19Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2684
Последний ответ 24 Янв 2011, 16:13
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 111
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal