Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: получение данных из хранилища значений при печати  (Прочитано 5171 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Столкнулся с такой проблемой. Хочу распечатать элемент из справочника. У меня это резюме с фотографией соискателя. Фото хранится в реквизите типа Хранилищезначения. Так вот, как напечатать фото, скажем, из библиотеки картинок в определенную область я нашел в синтакс помощнике. А вот как получить данные из реквизита и поместить их в картинку не могу разобраться. Помогите кто знает


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
вот за 5 минут маленький тестик набросал
который картинку из ХранилищаЗначений в табличный документ выводит
в область печати вставьте любую картинку, свою я назвал КартинкаТест, и в нее выводите ту которую вам надо.

Процедура Печать()

Данные = Хранилище.Получить();
Если ТипЗнч(Данные) = Тип("Картинка") Тогда
лкКартинка = Данные;
ИначеЕсли ТипЗнч(Данные) = Тип("ДвоичныеДанные") Тогда
лкКартинка = Новый Картинка(Данные, Ложь);
КонецЕсли;

лкМакет = ПолучитьМакет("Макет");
лкОбласть = лкМакет.ПолучитьОбласть("Тест");
лкОбласть.Параметры.Дата = ТекущаяДата();
лкОбласть.Рисунки.КартинкаТест.Картинка = лкКартинка;

лкТаб = Новый ТабличныйДокумент;
лкТаб.Вывести(лкОбласть);
лкТаб.Показать();


КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
вот за 5 минут маленький тестик набросал
который картинку из ХранилищаЗначений в табличный документ выводит
в область печати вставьте любую картинку, свою я назвал КартинкаТест, и в нее выводите ту которую вам надо.

Процедура Печать()

Данные = Хранилище.Получить();
Если ТипЗнч(Данные) = Тип("Картинка") Тогда
лкКартинка = Данные;
ИначеЕсли ТипЗнч(Данные) = Тип("ДвоичныеДанные") Тогда
лкКартинка = Новый Картинка(Данные, Ложь);
КонецЕсли;

лкМакет = ПолучитьМакет("Макет");
лкОбласть = лкМакет.ПолучитьОбласть("Тест");
лкОбласть.Параметры.Дата = ТекущаяДата();
лкОбласть.Рисунки.КартинкаТест.Картинка = лкКартинка;

лкТаб = Новый ТабличныйДокумент;
лкТаб.Вывести(лкОбласть);
лкТаб.Показать();


КонецПроцедуры
Поясните пожалуйста получение переменной Данные. Дело в том, что  создал печать конструктором, так как мне еще другие реквизиты надо выводить, соответственно процедура находится в менеджере объекта, а вызывается в модуле команды на стороне сервера. Как я понял ваше хранилище это и есть хранилище значения. Я записываю так, но мне пишет, что переменная не определена. Нужна ссылка, видимо, на объект из которого вызывается команда. Вот как ее добыть я не знаю

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
как вы говорите картинка у вас в хранилище,
моя переменная Хранилище это переменная с типом ХранилищеЗначений.
у него есть метод Получить(), почитайте СП (синтаксис помощник)

а дальше в примере код как вашу картинку достать из хранилища и поместить в табличный документ, который вы потом можете распечатать/сохранить/отправить.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
как вы говорите картинка у вас в хранилище,
моя переменная Хранилище это переменная с типом ХранилищеЗначений.
у него есть метод Получить(), почитайте СП (синтаксис помощник)

а дальше в примере код как вашу картинку достать из хранилища и поместить в табличный документ, который вы потом можете распечатать/сохранить/отправить.
моя картинка лежит в реквизите справочника, тип реквизита хранилищезначения, а не в каком-либо общем хранилище.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
моя картинка лежит в реквизите справочника, тип реквизита хранилищезначения,
и
Цитировать
моя переменная Хранилище это переменная с типом ХранилищеЗначений.
это одно и тоже (только разные названия переменных), используйте код примера (естественно с небольшими изменениями) и у вас все получится!
Помогло? - Нажми СПАСИБО!!!
                       :)


 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7447
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3888
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2122
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7354
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6962
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 138
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal