Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 13:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в справочник  (Прочитано 669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Доброго времени суток. Конфигурация Розница 8. Магазин одежды и обуви, редакция 2.1
Помогите пожалуйста перезаписать элемент справочника "ИнформационныеКарты". Есть на форме КодКарты и Штрихкод , сейчас заполнен Штрихкод и на основании его нужно заполнить КодКарты. пока не могу победить. Делаю так :
Процедура КнопкаВыполнитьНажатие(Кнопка)	

ШК="";
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИнформационныеКарты.Ссылка,
| ИнформационныеКарты.КодКарты,
| Штрихкоды.Штрихкод
|ИЗ
| Справочник.ИнформационныеКарты КАК ИнформационныеКарты
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Штрихкоды КАК Штрихкоды
| ПО (Штрихкоды.Владелец = ИнформационныеКарты.Ссылка)
| ГДЕ
| ИнформационныеКарты.ЭтоГруппа = ЛОЖЬ";

Выборка  = Запрос.Выполнить().Выбрать();
Пока  Выборка .Следующий()  Цикл
ШК=Выборка.Штрихкод;

ОбработкаПрерыванияПользователя();

Если НЕ ЗначениеЗаполнено(Выборка.КодКарты) Тогда
Объект = Выборка.Ссылка.ПолучитьОбъект();
//Объект.ФлагКодКарты = Истина;
Объект.КодКарты = ШК;
Объект.Записать();

Попытка
Объект.Записать(Истина);
Исключение
Отказ = Истина;
Сообщить(ОписаниеОшибки());
КонецПопытки;

Сообщить("код у этой карты:"+Объект.КодКарты);
КонецЕсли;
КонецЦикла; //КонецЦикла;
//Возврат(ШК);
         
КонецПроцедуры       

И не могу поставить ФлагКодКарты .Заранее благодарен.


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
скорее всего КодКарты уже заполнен, поэтому ничего не записывается, пройдите ваш код под отладчиком,

а вообще код написан ужасно, ну да ладно, каждый пишет как может.

таких явных ошибок, на первый взгляд, нет,

зачем только два раза подряд Объект.Записать() не понятно, (как и многое остальное в вашем коде)
Объект.Записать();

Попытка
Объект.Записать(Истина);
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Этот кусок я просто забыл удалить, пардон.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
69 Сообщений
ilyay ilyay
65 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal