Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Импорт из EXCEL  (Прочитано 1336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Обработка импорт из EXCEL в УТ работала в Рознице 2.1 не работает..,дело все в доп.реквизитах номенклатуры, не могу вывести в список наименования этих доп.реквизитов..

мДопРеквизиты = Новый Структура;
Запрос = Новый Запрос;
Запрос.Текст =  "ВЫБРАТЬ
| ДополнительныеРеквизитыИСведения.ЗаголовокФормыВыбораЗначения КАК Наименование
|ИЗ
| ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
|ГДЕ
| ДополнительныеРеквизитыИСведения.НаборСвойств = &НаборСвойств";
Запрос.УстановитьПараметр("НаборСвойств",Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Номенклатура_Общие);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
мРеквизиты.Добавить(ВыборкаДетальныеЗаписи.Наименование);
мДопРеквизиты.Вставить(СтрЗаменить(ВыборкаДетальныеЗаписи.Наименование, " ", "_"));
КонецЦикла;

Ругается на мДопРеквизиты.Вставить(СтрЗаменить(ВыборкаДетальныеЗаписи.Наименование, " ", "_"));  неправильно задано имя атрибута структуры.


Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Импорт из EXCEL
« Ответ #1: 22 Янв 2015, 11:54 »
Ну может кто то подскажет как быть?
В отладчике показывает "" а должно показывать наименование дополнительного реквизита номенклатуры..

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Импорт из EXCEL
« Ответ #2: 22 Янв 2015, 13:13 »
у вас ВыборкаДетальныеЗаписи.Наименование скорее всего ссылка,

в структуру в методе Вставить(<Ключ>, <Значение>)
Параметры:
<Ключ> (обязательный)
Тип: Строка.
Ключ устанавливаемого элемента.
<Значение> (необязательный)
Тип: Произвольный.
Значение устанавливаемого элемента.

в ключ ссылку передавать нельзя!
вам система честно об это пишет!


попробуйте, ваш код

мДопРеквизиты.Вставить(СтрЗаменить(ВыборкаДетальныеЗаписи.Наименование, " ", "_"));

заменить на следдующий
лкПоз = лкПоз + 1;
мДопРеквизиты.Вставить("Код"+лкПоз,ВыборкаДетальныеЗаписи.Наименование);

вообще моя подсказка бессмысленна, так как я не знаю что вы делаете и зачем!
просто "лечение" вашей ошибки! возможно все надо делать совсем по другому. :dfbsdfbsdf:
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Импорт из EXCEL
« Ответ #3: 22 Янв 2015, 16:43 »
Получилось немного изменил..

мДопРеквизиты = Новый Структура;
    Запрос = Новый Запрос;
    Запрос.Текст =  "ВЫБРАТЬ
    |    ДополнительныеРеквизитыИСведения.Наименование КАК Наименование
    |ИЗ
    |    ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
    |ГДЕ
    |    ДополнительныеРеквизитыИСведения.НаборСвойств = &НаборСвойств";
    Запрос.УстановитьПараметр("НаборСвойств",Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Номенклатура_Общие);
    РезультатЗапроса = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        мРеквизиты.Добавить(ВыборкаДетальныеЗаписи.Наименование);
        лкПоз = лкПоз;
        мДопРеквизиты.Вставить("Код"+лкПоз,ВыборкаДетальныеЗаписи.Наименование);
    КонецЦикла;

Так заработало :bleh:
В общем то дело было в ДополнительныеРеквизитыИСведения.Наименование

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Импорт из EXCEL
« Ответ #4: 22 Янв 2015, 16:59 »
зачем это?
лкПоз = лкПоз;

подразумевалось что лкПоз + 1 это счетчик, в вашем варианте если лкПоз не меняется
то после цикла структура у вас будет всего с одним элементом!

может вам ваша переменная мДопРеквизиты не в виде структуры нужна а в виде списокзначений?

тогда нужен следующий код
мДопРеквизиты = Новый СписокЗначений;
//...запрос
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        мРеквизиты.Добавить(ВыборкаДетальныеЗаписи.Наименование);
        мДопРеквизиты.Добавить(ВыборкаДетальныеЗаписи.Наименование);
    КонецЦикла;


(ложка меда)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Импорт из EXCEL
« Ответ #5: 23 Янв 2015, 10:22 »
Да работает,Спасибо еще раз, я учусь еще только поэтому оптимизация кода для меня чужда пока,но я конечно видел что счетчик не нужен,но работает же ;)
Вообще по сути это выпадающий список реквизитов для заполнения документа из excel файла,а эта секция отвечает за доп.реквизиты номенклатуры.


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1687
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2789
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2099
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7134
Последний ответ 23 Июл 2015, 14:25
от vitasw
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 990
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal