Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ВФ_Счёт на оплату_БП3.0_Метод объекта не обнаружен  (Прочитано 1879 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MineAllMine

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток!
Обновил конфигурацию бп 8.3 и стала ошибка вылезать внешней печатной формы, подмогните, пожалуйста
Печать->Счет на оплату
->Ошибка->Метод объекта не обнаружен (ПолучитьДанныеФайлаИДвоичныеДанные)


Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Всем доброго времени суток!
Обновил конфигурацию бп 8.3 и стала ошибка вылезать внешней печатной формы, подмогните, пожалуйста
Печать->Счет на оплату
->Ошибка->Метод объекта не обнаружен (ПолучитьДанныеФайлаИДвоичныеДанные)

В обновленной версии значит по-другому называется функция ПолучитьДанныеФайлаИДвоичныеДанные, или удалена, либо перемещена. Нужно смотреть код. Возможно спасет простое комментирование этой строки во внешней печатной форме
Народная мудрость: Программу встречают по интерфейсу

Оффлайн MineAllMine

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ВывестиЗаголовокПредупреждение(Организация, ТабличныйДокумент, Макет)

Если Не ЗначениеЗаполнено(Макет.Области.Найти("ЗаголовокПредупреждениеСЛоготипом")) Тогда
Возврат;
КонецЕсли;

ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Организация.ФайлЛоготип);
Если ЗначениеЗаполнено(ДанныеКартинки.ДвоичныеДанные) Тогда
ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждениеСЛоготипом");
Попытка
ОбластьМакета.Рисунки.Логотип.Картинка = Новый Картинка(ДанныеКартинки.ДвоичныеДанные);
Исключение
КонецПопытки;
ТабличныйДокумент.Вывести(ОбластьМакета);
Иначе
ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждение");
ТабличныйДокумент.Вывести(ОбластьМакета);
КонецЕсли;

КонецПроцедуры
Если СПечатью Тогда 
ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.Получатель.ФайлФаксимильнаяПечать);
Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
ДанныеКартинки = ДанныеКартинки.ДвоичныеДанные;
КонецЕсли;
Иначе
ДанныеКартинки = Неопределено;
КонецЕсли;
Как я понял - проблема с картинкой, подскажите как подправить, пожалуйста

Оффлайн Vittany

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 1
  • КПД: 33%
  • Регистрация: 2014-12-26
  • Сайт: 
  • Профессия: Программист 1С
Проблема не с картинкой, а с тем, что в модуле РаботаСФайламиСлужебныйВызовСервера процедура ПолучитьДанныеФайлаИДвоичныеДанные больше не существует и называется "ДанныеФайлаИДвоичныеДанные". Уберёте "Получить" и всё заработает

Оффлайн MineAllMine

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, помогло!)
:zebzdr:

Проблема не с картинкой, а с тем, что в модуле РаботаСФайламиСлужебныйВызовСервера процедура ПолучитьДанныеФайлаИДвоичныеДанные больше не существует и называется "ДанныеФайлаИДвоичныеДанные". Уберёте "Получить" и всё заработает


Теги:
 

{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2280
Последний ответ 09 Дек 2015, 19:33
от Oks
Ошибка "Поле объекта не обнаружено"

Автор KSV67Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4436
Последний ответ 29 Май 2014, 22:11
от KSV67
Общий реквизит или одинаковый реквизит для каждого объекта

Автор Соловьева Ольга_ИнтерсРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 917
Последний ответ 15 Июн 2015, 14:23
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6342
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
"Поле объекта не обнаружено" при переходе на редакцию 2.0

Автор gdlkgdfgnfdgРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 16
Просмотров: 22915
Последний ответ 12 Апр 2017, 11:53
от Diman.K

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 352
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal