Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: поиск по наименованию в справочнике  (Прочитано 1972 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anna.tepl

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-19
  • Сайт: 
Здравствуйте!

 У меня не происходит поиск контрагента из соответствующего справочника. Обработку делаю как внешную, считываю из файла excel наименование, в отладчике вижу его, а потом почему-то это наименование теряется, и получается пустое значение. ниже приведен код.

&НаСервере
Процедура ЗагрузитьДанныеНаСервере()

Excel = Новый COMОбъект("Excel.Application");

Книга = Excel.WorkBooks.Open(Объект.ИмяФайла);
Лист = Книга.WorkSheets(1);
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

Для НомерСтроки = 2  по ВсегоСтрок Цикл   

РасходнаяНакладная = Документы.РеализацияТоваровУслуг.СоздатьДокумент();

//ищем контрагента
        Контрагент = Справочники.Контрагенты.НайтиПоНаименованию((СокрЛП(Лист.Cells(НомерСтроки,3).Value)),истина);

Если Контрагент.Пустая() Тогда
Сообщить("Контрагент" + Контрагент + "не найден. Будет создан новый контрагент");

Контрагент = Справочники.Контрагенты.СоздатьЭлемент();
    Контрагент.Наименование = Контрагент;
    Контрагент.Записать();
// далее идет поиск договора и
КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 19 Янв 2015, 03:10


Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Здравствуйте!

 У меня не происходит поиск контрагента из соответствующего справочника. Обработку делаю как внешную, считываю из файла excel наименование, в отладчике вижу его, а потом почему-то это наименование теряется, и получается пустое значение. ниже приведен код.

&НаСервере
Процедура ЗагрузитьДанныеНаСервере()

Excel = Новый COMОбъект("Excel.Application");

Книга = Excel.WorkBooks.Open(Объект.ИмяФайла);
Лист = Книга.WorkSheets(1);
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

Для НомерСтроки = 2  по ВсегоСтрок Цикл   

РасходнаяНакладная = Документы.РеализацияТоваровУслуг.СоздатьДокумент();

//ищем контрагента
        Контрагент = Справочники.Контрагенты.НайтиПоНаименованию((СокрЛП(Лист.Cells(НомерСтроки,3).Value)),истина);

Если Контрагент.Пустая() Тогда
Сообщить("Контрагент" + Контрагент + "не найден. Будет создан новый контрагент");

Контрагент = Справочники.Контрагенты.СоздатьЭлемент();
    Контрагент.Наименование = Контрагент;
    Контрагент.Записать();
// далее идет поиск договора и
КонецПроцедуры


все просто! вы используете одну и ту же переменную и для поиска контрагента и для создания нового.
Вам нужно переменную Контрагент, которой вы пользуетесь для поиска по наименованию, переименовать, например в НайденыйКонтрагент, и прописать Контрагент.Наименование = НайденыйКонтрагент
Добавлено: 19 Янв 2015, 19:10

Здравствуйте!

 У меня не происходит поиск контрагента из соответствующего справочника. Обработку делаю как внешную, считываю из файла excel наименование, в отладчике вижу его, а потом почему-то это наименование теряется, и получается пустое значение. ниже приведен код.

&НаСервере
Процедура ЗагрузитьДанныеНаСервере()

Excel = Новый COMОбъект("Excel.Application");

Книга = Excel.WorkBooks.Open(Объект.ИмяФайла);
Лист = Книга.WorkSheets(1);
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

Для НомерСтроки = 2  по ВсегоСтрок Цикл   

РасходнаяНакладная = Документы.РеализацияТоваровУслуг.СоздатьДокумент();

//ищем контрагента
        Контрагент = Справочники.Контрагенты.НайтиПоНаименованию((СокрЛП(Лист.Cells(НомерСтроки,3).Value)),истина);

Если Контрагент.Пустая() Тогда
Сообщить("Контрагент" + Контрагент + "не найден. Будет создан новый контрагент");

Контрагент = Справочники.Контрагенты.СоздатьЭлемент();
    Контрагент.Наименование = Контрагент;
    Контрагент.Записать();
// далее идет поиск договора и
КонецПроцедуры


все просто! вы используете одну и ту же переменную и для поиска контрагента и для создания нового.
Вам нужно переменную Контрагент, которой вы пользуетесь для поиска по наименованию, переименовать, например в НайденыйКонтрагент, и НаименованиеКонтрагента = СокрЛП(Лист.Cells(НомерСтроки,3).Value). Затем прописать Контрагент.Наименование = НаименованиеКонтрагента
Народная мудрость: Программу встречают по интерфейсу

Последний раз редактировалось: SitnovaMarina; 19 Янв 2015, 19:10. Причина: Объединение сообщений


Теги:
 

Реквизит "ГоловнойКонтрагент" в справочнике "Контрагенты"

Автор SergWolf07Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7146
Последний ответ 28 Авг 2011, 19:12
от SergWolf07
Поле "Вес" в справочнике Номенклатура

Автор c_andreyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1692
Последний ответ 09 Сен 2015, 04:51
от Конст_007
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 743
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika
Как установить "Поиск по точному совпадению" по умолчанию?

Автор BulatsergРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1667
Последний ответ 16 Сен 2016, 14:58
от Bulatserg
Автонумерация в справочнике "Номенклатура" по группам

Автор Sergey-ChelnyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2356
Последний ответ 12 Дек 2010, 08:45
от Gendelf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 804
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal