Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 20:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Глюк с формированием массива. Платформа 8.3  (Прочитано 835 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tourist56

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.3.5.1383. Делаю обработку загрузки данных из файла dbf.
Примерно такая процедура:
&НаКлиенте
Процедура СоздатьСФ(Команда)
Данные= Новый XBase;
Данные.ОткрытьФайл(Объект.ФайлДанных,,Истина);
Структура=Новый Структура();
НаборДанных = Новый Массив;
Запись = Новый Структура;
НаборДанных.Очистить();
Если Не Данные.Открыта() Тогда
Предупреждение("Не удалось открыть указанный файл!");
Иначе
КолЗаписей=Данные.КоличествоЗаписей();
Для НомЗап=1 по КолЗаписей Цикл
Данные.Перейти(НомЗап);
Запись.Вставить("ДатаДок",Данные.DataDok);
Запись.Вставить("НомерДок",Данные.NomDok);
Запись.Вставить("СФНомер",Данные.SchF);
Запись.Вставить("ДСФ",Данные.DataSchF);
Запись.Вставить("Основание",Неопределено);
НаборДанных.Вставить(НомЗап-1,Запись);
Сообщить("Номер док."+Запись.НомерДок+" Номер записи "+НаборДанных.Количество());
КонецЦикла;
Для каждого Запись из НаборДанных Цикл
Сообщить("Номер док."+Запись.НомерДок+" НомерСФ "+Запись.СФНомер);
КонецЦикла;   

ДостатьОсн(НаборДанных);
СФ(НаборДанных);
Сообщить("Счета-Фактуры заполнены");
КонецЕсли;

КонецПроцедуры

Проблема в следующем. Когда по циклу выбираются данные из dbf, все нормально. Запись содержит нужную информацию.
По окончании цикла просматриваю массив. Все записи массива содержат последнюю Запись выборки. В чем может быть проблема?
Аналогичный код в другой процедуре работает нормально.


Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 473
  • РЕПУТАЦИЯ: 85
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Перенесите "Запись = Новый Структура;" внутрь цикла. Необходимо создавать новый объект в памяти под каждую запись dbf. Вы в каждый элемент массива кладете сейчас ссылку на один и тот же участок памяти и на каждом проходе обновляете данные в этой области памяти.


Теги:
 

При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 475
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
Мобильная платформа и кнопка "меню"

Автор nickroblogger_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1745
Последний ответ 09 Мар 2015, 16:49
от temrmal
платформа 8.3 Окно выдает "Неверный формат хранилища данных" Помогите

Автор Виктор АлександровичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 849
Последний ответ 17 Мар 2016, 08:47
от Виктор Александрович
Как изменить макет печатной формы документа "Прием в ремонт" УНФ 1.6 Платформа 8.3

Автор AlexK39Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 781
Последний ответ 11 Дек 2016, 15:32
от cast
Настройка смс-порталов (sms4b) для "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2

Автор Оксана НовочРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 936
Последний ответ 17 Янв 2017, 09:29
от Oldman06

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 252
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal