Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 05:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите прописать простую задачу  (Прочитано 2574 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
На форме 2 поля числовых. Первое меньше второго должно быть (проверять ввод пользователя) если введено неправильно, сообщить и обнулить поле. По кнопке выполнить необходимо рассчитать сумму квадратов всех нечетных чисел между числом из первого поля и числом из второго.


Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
На форме 2 поля числовых. Первое меньше второго должно быть (проверять ввод пользователя) если введено неправильно, сообщить и обнулить поле. По кнопке выполнить необходимо рассчитать сумму квадратов всех нечетных чисел между числом из первого поля и числом из второго.
помогите прописать

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
А что вы хотите чтобы мы вам прописали?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
А что вы хотите чтобы мы вам прописали?
как прописать сумму квадратов всех нечетных чисел?
никак не могу разобраться в циклах

Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
&НаКлиенте
Процедура ВычислитьРезультат(Команда)
Результат = 0;
Для Счетчик  = Объект.поле1 По Объект.поле2 Цикл
Если Счетчик%2 <> 0 Тогда
Результат = Результат + Pow(Счетчик, 2);
КонецЕсли;
КонецЦикла;
Объект.Результат = Результат;
КонецПроцедуры
Народная мудрость: Программу встречают по интерфейсу

Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура ВычислитьРезультат(Команда)
Результат = 0;
Для Счетчик  = Объект.поле1 По Объект.поле2 Цикл
Если Счетчик%2 <> 0 Тогда
Результат = Результат + Pow(Счетчик, 2);
КонецЕсли;
КонецЦикла;
Объект.Результат = Результат;
КонецПроцедуры

а как же нечетные числа?

Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
а как же нечетные числа?

Условие

Если Счетчик%2 <> 0 Тогда

именно это и проверяет
Народная мудрость: Программу встречают по интерфейсу

Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
а как же нечетные числа?

Условие

Если Счетчик%2 <> 0 Тогда

именно это и проверяет

спасибо большое за ответ. Извиняюсь, если вопрос покажется глупым. Где объект.поле1, объект.поле2 и объект.результат выдает ошибку и пишет, что переменная не определена. как это исправить?

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Чую, что у вас не управляемые формы, а обычные. В чем пишите то?
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Эльшад

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-18
  • Сайт: 
  • Профессия: Ученик 1С
Чую, что у вас не управляемые формы, а обычные. В чем пишите то?
1С:Предприятие 8.2 (8.2.12.75), обычная форма. внешняя обработка


Теги: число поле 
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4386
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5648
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5975
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4559
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2030
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal