Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Настройка обмена по одной организации  (Прочитано 1555 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Есть правила обмена, которые корректно работаю с УТ 11 и БП 30 через универсальный обмен данными, необходимо настроить выгрузку только по одной организации, так как загружать необходимо в базовую бухгалтерию, как это реализовать?

Есть код, но он не работает
Функция ВыполнитьВыгрузкуНаСервере()

Если Не ПрямаяВыгрузка Тогда

ИмяВременногоФайлаДанных = ИмяФайлаНаСервереИлиКлиенте(ИмяФайлаДанных, ,,Истина, Ложь);

Если ИмяВременногоФайлаДанных = Неопределено Тогда

Возврат Неопределено;
СообщитьПользователю(НСтр("ru = 'Не определен файл данных'"));

Иначе

Объект.ИмяФайлаОбмена = ИмяВременногоФайлаДанных;

КонецЕсли;

КонецЕсли;

ТаблицаПравилВыгрузки = РеквизитФормыВЗначение("Объект.ТаблицаПравилВыгрузки");

АдресаСКД = Объект.АдресаМакетовСКД;

ОбъектДляСервера = РеквизитФормыВЗначение("Объект");
ЗаполнитьЗначенияСвойств(ОбъектДляСервера, Объект);

ОбъектДляСервера.АдресаМакетовСКД = АдресаСКД;

Если ОбъектДляСервера.ФлагРежимОтладкиОбработчиков Тогда

Отказ = Ложь;

Файл = Новый Файл(ОбъектДляСервера.ИмяФайлаВнешнейОбработкиОбработчиковСобытий);

Если Не Файл.Существует() Тогда

СообщитьПользователю(НСтр("ru = 'Файл внешней обработки отладчиков событий не существует на сервере'"));
Возврат Неопределено;

КонецЕсли;

ОбъектДляСервера.ВыгрузитьОбработчикиСобытий(Отказ);

Если Отказ Тогда

СообщитьПользователю(НСтр("ru = 'Не удалось выгрузить обработчики событий'"));
Возврат "";

КонецЕсли;

Иначе

ОбъектДляСервера.ЗагрузитьПравилаОбмена();
ОбъектДляСервера.ИнициализироватьПервоначальныеЗначенияПараметров();
ОбъектДляСервера.Параметры.Вставить("СворачиватьПоСкладу", Объект.НаОбщийСклад);
ОбъектДляСервера.Параметры.Вставить("ОбобщенныйСклад", Объект.ОбщийСклад);
ОбъектДляСервера.Параметры.Вставить("Организация", Объект.ОтборОрганизация);

КонецЕсли;

ИзменитьДеревоПравилВыгрузки(ОбъектДляСервера.ТаблицаПравилВыгрузки.Строки, ТаблицаПравилВыгрузки.Строки);

ОбъектДляСервера.ВыполнитьВыгрузку();
ОбъектДляСервера.ТаблицаПравилВыгрузки = РеквизитФормыВЗначение("Объект.ТаблицаПравилВыгрузки");

Если ЭтоКлиент И Не ПрямаяВыгрузка Тогда

АдресФайлаДанных = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(Объект.ИмяФайлаОбмена), УникальныйИдентификатор);
УдалитьФайлы(Объект.ИмяФайлаОбмена);

Иначе

АдресФайлаДанных = "";

КонецЕсли;

Если ЭтоКлиент Тогда

УдалитьФайлы(ОбъектДляСервера.ИмяФайлаПравилОбмена);

КонецЕсли;

ОбъектДляСервера.Параметры.Очистить();
ЗначениеВРеквизитФормы(ОбъектДляСервера, "Объект");

Возврат АдресФайлаДанных;

КонецФункции



Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А что в этом коде не работает?

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Иначе
       
        ОбъектДляСервера.ЗагрузитьПравилаОбмена();
        ОбъектДляСервера.ИнициализироватьПервоначальныеЗначенияПараметров();
        ОбъектДляСервера.Параметры.Вставить("СворачиватьПоСкладу", Объект.НаОбщийСклад);
        ОбъектДляСервера.Параметры.Вставить("ОбобщенныйСклад", Объект.ОбщийСклад);
        ОбъектДляСервера.Параметры.Вставить("Организация", Объект.ОтборОрганизация);
       
    КонецЕсли;
это не выполняется и передается пустое значение
тем самым не сворачивается по складу и не идет отбор по организации

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну здесь же нужно смотреть что там в ЗагрузитьПравилаОбмена()


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal