Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 17:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка отображения типов  (Прочитано 1598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите в чем ошибка, выдает ошибку отображения типов
&НаКлиенте
Процедура ПриОткрытии(Отказ)
НужныйСпр = НужныйСправочник();
 
КонецПроцедуры

&НаСервереБезКонтекста
Функция НужныйСправочник()
НС = Справочники.Резюме;
Возврат НС;
КонецФункции


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Справочники.Резюме

- типа СправочникМенеджер. А вы его на клиент передать пытаетесь.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Справочники.Резюме

- типа СправочникМенеджер. А вы его на клиент передать пытаетесь.

А как правильно записать тогда? Это я все пытаюсь сделать в форме списка справочника

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Что записать? Кому записать?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
В общем смысл в том, что я хочу сделать Цикл Для Каждого реквизита справочника Резюме. и уже потом через Если вывести определенные значения сообщением пользователю

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте с сервера получите пустую ссылку этого справочника
тогда в поле выбора, вам будет доступен список из Резюме.
но вообще все надо делать правильно, для этого изучать УФ, там не все так просто как в обычных формах,

&НаСервереБезКонтекста
Функция НужныйСправочник()
    НС = Справочники.Резюме.ПустаяСсылка();
    Возврат НС;
КонецФункции

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн maxipunchik

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Что-то вроде этого
&НаКлиенте
Процедура ПриОткрытии(Отказ)
НужныйСпр = НужныйСправочник();
   Для Каждого ДатаРазмещения ИЗ НужныйСпр Цикл
Если ДатаРазмещения > ТекущаяДата() Тогда
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = НужныйСпр.ФИО+" "+НужныйСпр.ДатаРазмещения;
Сообщение.Сообщить();
КонецЕсли;
КонецЦикла;
 
КонецПроцедуры

&НаСервереБезКонтекста
Функция НужныйСправочник()
НС = Справочники.Резюме;
Возврат НС;
КонецФункции

Добавлено: 29 Дек 2014, 13:01

для этого изучать УФ
Простите, а что такое УФ?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
У объекта заводите Тч с колонками ФИО и ДатаРазмещения.
И в ПриСозданииНаСервере() его заполняете.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4545
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6104
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4214
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8531
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8573
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 259
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal