Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Конфигурация повисает - что не так вкоде?  (Прочитано 1164 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурация повисает из-за вот этого кода

ВсеРаспределены = Ложь; 
   ВремяНачала.Сортировать("Время Возр");
   
   ТекущееВремя = ВремяНачала[0].Время;
   Сообщить (ТекущееВремя);
   Если Час(ТекущееВремя) < 8 Тогда
      ТекущееВремя = ТекущееВремя + 28800;
   КонецЕсли;
   Пока ВсеРаспределены = Ложь Цикл
      Выборка = Справочники.Полуфабрикаты.Выбрать();
      Пока Выборка.Следующий() Цикл  // выбираем полуфабрикат
         МожноРаспределить = Истина;
         ВсеРаспределены = Истина;
         Если Выборка.ФлагРаспределения = Ложь Тогда   //если он еще не распределен пробуем распределить
            Сообщить ("Полуфабрикат "+ Выборка.Наименование + " не распределен");
            ВсеРаспределены = Ложь;
            КодТекущПФ = Выборка.Код;
            Флаг = Истина;
            //ПроверкаНаВыполнимость(КодТекущПФ,ТекущееВремя,Флаг); // проверяем его самого на выполнимость (завершены дочерние пф)
            Если Флаг = Ложь Тогда
               МожноРаспределить = Ложь;
            КонецЕсли;
                        Если МожноРаспределить Тогда
               Сообщить ("    его можно распределить");
            Иначе
               Сообщить ("    его нельзя распределить на " + ТекущееВремя);
            КонецЕсли;
         КонецЕсли;

                  
      КонецЦикла;
      
   ТекущееВремя = ТекущееВремя + 900;   
      
   КонецЦикла;    

если удаляю ту часть что выделена жирным шрифтом - то не виснет. Ошибок никаких не выдает, ни на что не ругается - что за .. ситуация такая?

причем еще так получается - этот код записан в процедуре ЗагрузитьРЦ(ВремяНачала), ее вызывает другая процедура, она тоже не выполняется при наличиии вот этого кода, выделенного жирным


Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Разобрался - дело было в том , что цикл получался бесконечным.
Если не сложно поясните новичку, каким образом отрабатывает 1с такую ситуацию? Дело в том, что выполнения самого цикла как видно не происходит (так как не выводятся сообщения внутри цикла). Однако не выполняется и  строки которые предшествуют циклу, то есть 1с как-то заранее что-то проверяет. Но как система заранее может проверять если еще нет конкретных значений переменных , по которым либо будет выход из цикла либо нет

Просто для понимания интересно

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1С никоим образом предварительно не выполняет цикл!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Игорь_M

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-19
  • Сайт: 
  • Профессия: Ученик 1С
а как тогда? если она выполняла бы цикл, то постоянно бы печатала сообщение  ("Полуфабрикат "+ Выборка.Наименование + " не распределен");
но ведь не печатает. Не печатает даже те сообщения, которые есть в процедуре, вызывающей рассматриваемую. ... не понятно. Вообщем, добавил еще одно условие выхода из цикла и все заработало

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Зацикливание происходило на Пока ПокаВсеРаспределены = Ложь Цикл


Теги:
 

Конфигурация "1С:Оценка персонала"

Автор lyuberРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4660
Последний ответ 05 Авг 2011, 11:09
от chuevsf
конфигурация "Управление торговлей 10.3" для 8.2

Автор bahtovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3224
Последний ответ 18 Окт 2011, 13:22
от bahtovar
Права и конфигурация "кладовщик"

Автор DetsleРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 574
Последний ответ 14 Июн 2017, 13:13
от xdto
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 475
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
Разыскивается Конфигурация "Инпро:Мука 8"

Автор aapospelovРаздел Беседка

Ответов: 0
Просмотров: 2215
Последний ответ 08 Мар 2011, 10:02
от aapospelov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
46 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal