Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 17:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обмен УТ 11 и БП 3.0 через универсальный обмен данными  (Прочитано 7066 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
При обмене УТ 11 и БП 3.0 через универсальный обмен данными в реализации товаров и услуг не заполняются статьи доходов и расходов в бухгалтерии. Как решить данную проблему при обмене не прибегая к дополнительным обработкам?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. добавить заполнение статей в правила (рекомендуется)
2. после переноса заполнять групповой обработкой
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
а приблизительный код для добавления в правила обмена где можно посмотреть. Как сделать чтобы это бралось из регистра сведений счета учета номенклатуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Приблизительный код берется в самом документе и потом с некоторыми исправлениями вставляется в событие ПослеЗагрузки()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
А хотя бы название процедуры может кто подсказать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
например в ТоварыНоменклатураПриИзменении()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
там она обращается к другим процедурам и стандартной заполнения свойств, не могу разобраться какой код мне именно нужен

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вот как у меня делалось в казахском КУФИБе

Для каждого СтрокаТЧ Из Объект.Товары Цикл
      СчетаУчета = ПроцедурыБухгалтерскогоУчета.ПолучитьСчетаУчетаНоменклатуры(Объект.Организация, СтрокаТЧ.Номенклатура);
      
      ЗаполнитьЗначенияСвойств(СтрокаТЧ, СчетаУчета,,"СубконтоДоходовБУ1,СубконтоДоходовБУ3,СубконтоДоходовНУ1,СубконтоДоходовНУ3");
      СтрокаТЧ.СчетДоходовБУ = СчетаУчета.СчетДоходовОтРеализацииБУ;
      СтрокаТЧ.СчетДоходовНУ = СчетаУчета.СчетДоходовОтРеализацииНУ;
      СтрокаТЧ.СчетСписанияСебестоимостиБУ = СчетаУчета.СчетСебестоимостиПриРеализацииБУ;
      СтрокаТЧ.СчетСписанияСебестоимостиНУ = СчетаУчета.СчетСебестоимостиПриРеализацииНУ;
      
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовБУ1) Тогда
         СтрокаТЧ.СубконтоДоходовБУ1 = СчетаУчета.СубконтоДоходовБУ1;
      КонецЕсли;
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовБУ2) Тогда
         СтрокаТЧ.СубконтоДоходовБУ2 = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Основная номенклатурная группа",ИСТИНА);
      КонецЕсли;
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовБУ3) Тогда
         СтрокаТЧ.СубконтоДоходовБУ3 = СчетаУчета.СубконтоДоходовБУ3;
      КонецЕсли;
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовНУ1) Тогда
         СтрокаТЧ.СубконтоДоходовНУ1 = СчетаУчета.СубконтоДоходовНУ1;
      КонецЕсли;
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовНУ2) Тогда
         СтрокаТЧ.СубконтоДоходовНУ2 = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Основная номенклатурная группа",ИСТИНА);
      КонецЕсли;
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоДоходовНУ3) Тогда
         СтрокаТЧ.СубконтоДоходовНУ3 = СчетаУчета.СубконтоДоходовНУ3;
      КонецЕсли;
      
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоСписанияСебестоимостиБУ1) Тогда
         СтрокаТЧ.СубконтоСписанияСебестоимостиБУ1 = СчетаУчета.СубконтоСебестоимостиБУ1;
      КонецЕсли;
      
      Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СубконтоСписанияСебестоимостиНУ1) Тогда
         СтрокаТЧ.СубконтоСписанияСебестоимостиНУ1 = СчетаУчета.СубконтоСебестоимостиНУ1;
      КонецЕсли;
      
      СтрокаТЧ.Коэффициент = пит_ОбщегоНазначения.ПолучитьКоэффициентПересчета(СтрокаТЧ.Номенклатура, СтрокаТЧ.ЕдиницаИзмерения);
   КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн magnifico61

  • ****
  • Сообщений: 344
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Спасибо большое, на примере будет проще разобраться

Добавлено: 25 Дек 2014, 13:29

ПроцедурыБухгалтерскогоУчета.ПолучитьСчетаУчетаНоменклатуры что это в твоей базе?

Последний раз редактировалось: magnifico61; 25 Дек 2014, 13:29. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну соответственно метод общего модуля.
отыскать его (метода) следы в вашей базе поможет анализ ТоварыНоменклатураПриИзменении()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 241
Последний ответ 06 Авг 2017, 21:22
от alex0402
Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1868
Последний ответ 24 Май 2016, 17:17
от Kironten
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8555
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2751
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужен совет в подключении к системе спутникового мониторинга "renault-trucks(Optifleet)", через web-сервис!

Автор snoop82Раздел Беседка

Ответов: 0
Просмотров: 788
Последний ответ 11 Дек 2015, 06:56
от snoop82

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 654
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal