Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 20:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма Бухгалтерия 3.0  (Прочитано 3689 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pcihodelika

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Доброго времени суток!

Подскажите, пожалуйста. При подключении в документу "Начисление зарплаты" (Бухгалтерия 3.0.37.25) внешней печатной формы в документе не появляется кнопка "Печать". Изначально для этого документа печатная форма не предусматривалась.
Процедура печати в модуле используется следующая:
Цитировать
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
   
   УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СчетНаОплатуВРТУ", "Счет на оплату (шаблон)", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));
   
КонецПроцедуры // Печать()
Подскажите, что не так и как это можно поправить.
Заранее спасибо.


Оффлайн Pcihodelika

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Либо подскажите, пожалуйста, как на форму с выбором документа (Начисление зарплаты) добавить печать (то есть команду печати)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если добавлять свою встроенную команду по печати печатной формы, то ключевое - это указание типа параметра у команды.
Как только отмечаем нужный документ - в его формах (и документа и списка) появляется кпнока с командой.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Pcihodelika

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
Если добавлять свою встроенную команду по печати печатной формы, то ключевое - это указание типа параметра у команды.
Как только отмечаем нужный документ - в его формах (и документа и списка) появляется кпнока с командой.
В том-то и проблема, что не появляется. Причем при добавление этой же печатки в любой другой документ, там она появляется.
Кинула впф во вложение.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
сама впф думается что не сильно поможет
бывает что у документа на вкладке команды не стоит флаг "Использовать стандартные команды". например
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Pcihodelika

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
сама впф думается что не сильно поможет
бывает что у документа на вкладке команды не стоит флаг "Использовать стандартные команды". например
конкретно для этого документа стоит :(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
нууу лично у меня больше пока нет вариантов.
только по Тим Вьюверу смотреть...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Pcihodelika

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-22
  • Сайт: 
  • Профессия: Программист 8.1
В итоге сделала форму и печать из нее.
Как-то так:
&НаКлиенте
Процедура Печать(Команда)
   ТабДок = ВызовПечати();
   ТабДок.Показать();

КонецПроцедуры

&НаСервере
Функция ВызовПечати()
    МассивОбъектов = Новый Массив;
   МассивОбъектов.Добавить(Объект.СсылкаНаОбъект);
ОбъектыПечати = Новый СписокЗначений;
   ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
   Возврат ОбработкаОбъект.СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати);
КонецФункции

Вопрос решен.


Теги:
 

Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 698
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 238
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 5106
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
О конфигурации "Бухгалтерия Предприятия 2.0"

Автор СтолярРаздел Закрытые темы

Ответов: 46
Просмотров: 32107
Последний ответ 11 Мар 2012, 18:36
от Котова
Обмен данными Зарплата 8 (бюджет)-Бухгалтерия 8 (бюджет)

Автор VanillaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3533
Последний ответ 14 Дек 2009, 11:16
от Vanilla

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений
Alter
28 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal