Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 16:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Методичка Основные Объекты 8.3  (Прочитано 3268 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LbISS

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-16
  • Сайт: 
  • Профессия: Ученик 1С
Всем добрый день. Прослушал курс по Основным объект, теперь самостоятельно прохожу все заново. Так как курс длился 2 дня("в темпе вальса") и наш преподаватель давал не всегда точное изложение листинга из методички, у меня теперь пару вариантов кода, но при самостоятельном изучении иногда возникают вопросы:)

глава 5.1 Хранилище значений(работа с картинками)
Добавление картинок к номенклатуре.
Код из базы которую писали на курсе..почти тоже самое что и в методичке, собственно в базе которую писали все работает. В новой которую пишу самостоятельно фото добавляется, но при повторном открытии фото нет. Реквизиты теже, код тот же. В чем может быть проблема???

&НаКлиенте
Процедура ЗагрузитьКартинку(Команда)
Перем Адрес,Имя;

Если ПоместитьФайл(Адрес,"",Имя,Истина, ЭтаФорма.УникальныйИдентификатор) Тогда
АдресКартинки = Адрес;
Сообщить(Имя);
    КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда

ДД=ПолучитьИзВременногоХранилища(АдресКартинки);
ТекущийОбъект.Фотография = Новый ХранилищеЗначения(ДД);

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"Фотография");
КонецПроцедуры



Хелп!%)Заранее извиняюсь если чего глупое спросил, я только учусь:) Надеюсь на Вашу помощь.



Оффлайн v8edu.ru

Всем добрый день. Прослушал курс по Основным объект, теперь самостоятельно прохожу все заново. Так как курс длился 2 дня("в темпе вальса") и наш преподаватель давал не всегда точное изложение листинга из методички, у меня теперь пару вариантов кода, но при самостоятельном изучении иногда возникают вопросы:)

глава 5.1 Хранилище значений(работа с картинками)
Добавление картинок к номенклатуре.
Код из базы которую писали на курсе..почти тоже самое что и в методичке, собственно в базе которую писали все работает. В новой которую пишу самостоятельно фото добавляется, но при повторном открытии фото нет. Реквизиты теже, код тот же. В чем может быть проблема???

&НаКлиенте
Процедура ЗагрузитьКартинку(Команда)
Перем Адрес,Имя;

Если ПоместитьФайл(Адрес,"",Имя,Истина, ЭтаФорма.УникальныйИдентификатор) Тогда
АдресКартинки = Адрес;
Сообщить(Имя);
    КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда

ДД=ПолучитьИзВременногоХранилища(АдресКартинки);
ТекущийОбъект.Фотография = Новый ХранилищеЗначения(ДД);

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"Фотография");
КонецПроцедуры



Хелп!%)Заранее извиняюсь если чего глупое спросил, я только учусь:) Надеюсь на Вашу помощь.

Обратите внимание на следующие моменты:
1. АдресКартинки - это реквизит формы, для которого представлен элемент управления ПолеКартинки
2. Процедура-обработчик ПриСозданииНаСервере должен быть связан с событием формы ПриСозданииНаСервере
Разработчики сервиса интерактивного изучения 1С для пользователей и разработчиков

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2640
  • РЕПУТАЦИЯ: 319
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
вау. теперь учитель и ученик ходят вместе?
Ситхи!?!??!?!?!?!?!
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн v8edu.ru

вау. теперь учитель и ученик ходят вместе?
Ситхи!?!??!?!?!?!?!

?
У вас много свободного времени?
Совет: не тратьте время попусту, делитесь знаниями. Это благородно, как минимум.
Разработчики сервиса интерактивного изучения 1С для пользователей и разработчиков

Оффлайн G4My

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Ученик 1С
Народ, подскажите где можно скачать
Основные объекты
Решение оперативных задач
?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
alex0402
69 Сообщений
Dethmontt Dethmontt
67 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
ilyay ilyay
42 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 718
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal