Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 11:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отладка отчета  (Прочитано 798 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
Добрый всем день. В руки попал отчет, который написан сильно начинающим программером. В нем куча алгоритмов, дикий макет по требованию заказчика, и обход объектов конфигурации происходит так:
ПлатВед = Документы.ПлатежнаяВедомость.Выбрать(ДатаНач,КонецДня(ДатаКон));
ЗПЗакрой = 0;
ЗПШвей = 0;
ЗПУпак = 0;
Пока платВед.Следующий() Цикл
Если Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("закройный")))  > 0 Тогда
ЗПЗакрой = ЗПЗакрой + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
ИначеЕсли Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("швейный")))  > 0 Тогда
ЗПШвей = ЗПШвей + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
ИначеЕсли Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("упаковки")))  > 0 Тогда
ЗПУпак = ЗПУпак + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
КонецЕсли;
КонецЦикла;
Естественно нужно такие моменты переписать, но мне стало интересно - насколько увеличится скорость выполнения определенной процедуры. Как это можно (им можно ли вообще) замерять?


Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Отладка отчета
« Ответ #1: 16 Дек 2014, 10:39 »
нашел...
Процедура ЗарплатаПодразделения();// ОПТИМИЗАЦИЯ ЗАПРОСА П+

Начало = ТекущаяУниверсальнаяДатаВМиллисекундах(); //зафиксируем начало процесса...
ПлатВед = Документы.ПлатежнаяВедомость.Выбрать(ДатаНач,КонецДня(ДатаКон));
ЗПЗакрой = 0;
ЗПШвей = 0;
ЗПУпак = 0;
Пока платВед.Следующий() Цикл
Если Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("закройный")))  > 0 Тогда
ЗПЗакрой = ЗПЗакрой + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
ИначеЕсли Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("швейный")))  > 0 Тогда
ЗПШвей = ЗПШвей + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
ИначеЕсли Найти(ПлатВед.ПодразделениеОрганизации.ПолноеНаименование(),НРЕГ(СокрЛП("упаковки")))  > 0 Тогда
ЗПУпак = ЗПУпак + ПлатВед.ТабличнаяЧасть.Итог("КВыплате");
КонецЕсли;
КонецЦикла;
Конец = ТекущаяУниверсальнаяДатаВМиллисекундах(); //зафиксируем окончание процесса...
    ВремяВыполнения = (Конец - Начало)/1000; //вычислим время выполнения цикла в секундах.
    сообщить("Время выполнения цикла ЗарплатаПодразделения составило "+ВремяВыполнения+" сек.");
КонецПроцедуры

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Отладка отчета
« Ответ #2: 16 Дек 2014, 11:53 »
Нет. Не так.
Конфигуратор - Отладка - Замер производительности.

1. Нажать в конфигураторе.
2. В предприятии выполнить задачу.
3. Отжать в конфигураторе.
4. Подождать вывода результата.


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7052
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2997
Последний ответ 27 Май 2015, 10:02
от casper009
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4094
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3874
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1959
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
181 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal