Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 11:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расшифровка в отчете  (Прочитано 1228 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
8.2, не СКД
Как в Процедуре "ОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)" написать условие для двух вариантов расшифровки, т.е. если по одной ячейки1 (ПараметрРасшифровки - расшифровкаПриход) клацнуть выведется одно, а по другой ячейке2 (ПараметрРасшифровки - РасшифровкаРасход) - другое?

Сейчас пишу так:
//Если Тогда
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Список";

Макет = ПолучитьМакет("Список");

Область = Макет.ПолучитьОбласть("Шапка");
Область.Параметры.ВыбНоменклатура = СокрЛП(Расшифровка.Номенклатура);
ТабДокумент.Вывести(Область);

Для Каждого СтрокаТаблицы Из ТаблицаДокументовПоступило Цикл
    Если СтрокаТаблицы.Номенклатура = Расшифровка.Номенклатура Тогда
Область = Макет.ПолучитьОбласть("Строка");
////
ТабДокумент.Вывести(Область);
    КонецЕсли;
КонецЦикла;
//ИначеЕсли
//
//КонецЕсли;


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Прежде, обратите внимание на свойство ячеи в макете: "ПараметрРасшифровки".

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Прежде, обратите внимание на свойство ячеи в макете: "ПараметрРасшифровки".
Параметру Приход прописала- ПараметрРасшифровки - РасшифровкаПриход
и
Параметру Расход - ПараметрРасшифровки - РасшифровкаРасход
Добавлено: 18 Дек 2014, 08:47

Если Расшифровка = "РасшифровкаПриход" Тогда//!!!!! так пишу, ни ошибки , ни результата(((

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Список";

Макет = ПолучитьМакет("Список");

Область = Макет.ПолучитьОбласть("Шапка");
Область.Параметры.ВыбНоменклатура = СокрЛП(Расшифровка.Номенклатура);
ТабДокумент.Вывести(Область);

Для Каждого СтрокаТаблицы Из ТаблицаДокументовПоступило Цикл
    Если СтрокаТаблицы.Номенклатура = Расшифровка.Номенклатура Тогда
Область = Макет.ПолучитьОбласть("Строка");
////
ТабДокумент.Вывести(Область);
    КонецЕсли;
КонецЦикла;
ИначеЕсли Расшифровка = "РасшифровкаРасход" Тогда//!!!!! ((((
///
КонецЕсли;

Последний раз редактировалось: 1cka; 18 Дек 2014, 08:47. Причина: Объединение сообщений


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 545
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1336
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 817
Последний ответ 24 Янв 2018, 02:38
от Геннадий ОбьГЭС
Не активны кнопки "Добавить" и "Удалить" дополнительные строки в отчете по НДС

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 316
Последний ответ 25 Янв 2018, 14:50
от kiksi
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 8550
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 312
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal