Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: программное заполнение документа Установка цен номенклатуры в УТ 11.1  (Прочитано 3659 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zakir_80

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-13
  • Сайт: 
Здравствуйте.
Из внешней обработки пытаюсь загрузить прайс-лист в документ УстановкаЦенНоменклатуры (УТ 11.1.2). Подскажите, пожалуйста, почему при программном  заполнении документа
&НаКлиенте
Процедура ЗагрузитьФайлExcel(Команда)

ФормаДокумента = ПолучитьФорму("Документ.УстановкаЦенНоменклатуры.ФормаОбъекта");
ДанныеФормы = ФормаДокумента.Объект;

СоздатьДокументУстановкиНовойЦены(ДанныеФормы);
КопироватьДанныеФормы(ДанныеФормы, ФормаДокумента.Объект);  //

ФормаДокумента.Открыть();

КонецПроцедуры

 &НаСервере
Процедура СоздатьДокументУстановкиНовойЦены(ДанныеФормы)

        ТаблицаДляУстановкиНовыхЦен = ИнициализироватьТаблицуУстановкиЦен();

Для каждого Стр из Таблица Цикл

НоваяСтр = ТаблицаДляУстановкиНовыхЦен.Добавить();
                НоваяСтр.Номенклатура = Стр.Номенклатура;
НоваяСтр.Цена = Стр.Цена;
НоваяСтр.ВидЦены = Объект.ВидЦены;
НоваяСтр.ЦенаИзмененаВручную = Истина;

КонецЦикла;

//Состояние("Формирование документа установки цен номенклатуры...");
Если ТаблицаДляУстановкиНовыхЦен.Количество() = 0 Тогда
Возврат;
КонецЕсли;

Документ = ДанныеФормыВЗначение(ДанныеФормы, Тип("ДокументОбъект.УстановкаЦенНоменклатуры"));
Документ.Дата = Объект.Дата;
//Документ.УстановитьНовыйНомер();
Документ.Статус = Перечисления.СтатусыУстановокЦенНоменклатуры.Согласован;
Документ.Согласован = Истина;
Документ.Ответственный = Объект.Менеджер;
Документ.Комментарий = "# Создан автоматически на основании прайс-листа #";

Строка = Документ.ВидыЦен.Добавить();
Строка.ВидЦены = Объект.ВидЦены;

Документ.Товары.Загрузить(ТаблицаДляУстановкиНовыхЦен);
Документ.Товары.Свернуть("Номенклатура, ВидЦены, Цена");

ЗначениеВДанныеФормы(Документ,ДанныеФормы);

КонецПроцедуры
после открытия формы в режиме 1С:Предприятие в таб.части документа (в элементе формы ДеревоЦен) почему-то пусто (ни одной строки), но при этом видно, что шапка документа (дата, ответственный, комментарий) и вид цены заполнились. Отладчик показывает, что при открытии формы тч Товары содержит данные. Почему тогда они не показываются на форме? Может кто сталкивался с таким?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
зачем так заумно то?
разве нельзя как раньше: создать объект нового документа, заполнить его, получить его форму и открыть ее?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
зачем так заумно то?
разве нельзя как раньше: создать объект нового документа, заполнить его, получить его форму и открыть ее?
+1
Усложнено.
Есть 2 ТЧ: ВидыЦен и Товары. В ВидыЦен загоняете все свои виды цен, в Товары загоняете номенклатуру, характеристику, вид цены и цену для данного вида цены.  А документ на форме выводит на основании всего этого матрицу, которую мы и видим при открытии. Оно, конечно, способ, может, и не единственный, но Оккамо мужик был умный, однако.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн Zakir_80

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-13
  • Сайт: 
Цитировать
зачем так заумно то?
разве нельзя как раньше: создать объект нового документа, заполнить его, получить его форму и открыть ее?
Если вы имеете ввиду серверную процедуру, то согласен, упростил.

 
&НаСервере
Процедура СоздатьДокументУстановкиНовойЦены(ДанныеФормы)

Документ = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
Документ.Дата = Объект.Дата;
Документ.Статус = Перечисления.СтатусыУстановокЦенНоменклатуры.Согласован;
Документ.Согласован = Истина;
Документ.Ответственный = Объект.Менеджер;
Документ.Комментарий = "# Создан автоматически на основании прайс-листа #";

Строка = Документ.ВидыЦен.Добавить();
Строка.ВидЦены = Объект.ВидЦены;

// Таблица - таблица значений в которую предварительно загружены данные из прайса Excel
Для каждого Стр из Таблица Цикл

НоваяСтр = Документ.Товары.Добавить();
НоваяСтр.Номенклатура = Стр.Номенклатура;
НоваяСтр.Цена = Стр.Цена;
НоваяСтр.ВидЦены = Объект.ВидЦены;
НоваяСтр.ЦенаИзмененаВручную = Истина;

КонецЦикла;

ЗначениеВДанныеФормы(Документ, ДанныеФормы);

КонецПроцедуры
Добавлено: 14 Дек 2014, 18:58

Цитировать
Есть 2 ТЧ: ВидыЦен и Товары. В ВидыЦен загоняете все свои виды цен, в Товары загоняете номенклатуру, характеристику, вид цены и цену для данного вида цены.  А документ на форме выводит на основании всего этого матрицу, которую мы и видим при открытии. Оно, конечно, способ, может, и не единственный, но Оккамо мужик был умный, однако.
Цитировать

Я так и сделал, но на форме все равно ничего не появилось. Получилось только после того, как добавил перед открытием формы на клиенте такую строку:
			ФормаДокумента.ЗаполнитьДокумент(); // экспортируемая процедура модуля формы документа УстановкаЦенНоменклатуры
ФормаДокумента.Открыть();

Почему-то при открытии формы (ФормаДокумента.Открыть()) не отрабатывает заполнение документа уже в самом документе УстановкаЦенНоменклатуры. Возможно, пора обновляться до 11.1.9...
Добавлено: 14 Дек 2014, 18:59

cska-fanat-kz, sertak - спасибо за ответы.

Последний раз редактировалось: Zakir_80; 14 Дек 2014, 18:59. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4474
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7745
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4781
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8512
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal