Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбрать текущий элемент  (Прочитано 815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн d_liliya

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-02
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
По нажатию кнопки я открываю группу в справочнике номенклатура (Лаваш).
Мне нужно, чтобы при нажатии на выбранный элемент заходилось в цикл, т.е. если (нажимаю выбранный элемент) тогда
Если ВвестиЧисло(клв, "Введите количество", 5, 0) Тогда 
строка = товары.Добавить();
строка.Количество=клв;
    Иначе
Возврат;
    КонецЕсли;
конецесли;
Мне нужно запомнить этот выбранный элемент, чтобы обратится к его названию. Как это сделать?
Вот весь код
Процедура ДействияФормыЛаваш(Кнопка) 

       Группа1=Справочники.Номенклатура.НайтиПоНаименованию("Лаваш");
фвыб = Справочники.Номенклатура.ПолучитьФормуВыбора();
фвыб.ЭлементыФормы.СправочникСписок.ТекущийРодитель=Группа1;
фвыб.РежимВыбора = Истина;
фвыб.ЗакрыватьПриВыборе = Ложь;
фвыб.Открыть();

клв=0;

Если (?) тогда
Если ВвестиЧисло(клв, "Введите количество", 5, 0) Тогда
строка = товары.Добавить();
строка.Количество=клв;
   
Иначе
Возврат;
КонецЕсли;
КонецЕсли;


КонецПроцедуры



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. Обрабатываете событие НачалоВыбора() у поля Номенклатура, открываете форму выбора номенклатуры. в ней происходит выбор.
2. Обрабатываете событие ОбработкаВыбора() у (скорее всего) формы, в его параметре ВыбранноеЗначение сидит выбранное значение.
3. В этом же событии и запрашиваете количество
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн d_liliya

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-02
  • Сайт: 
  • Профессия: Ученик 1С
1. Обрабатываете событие НачалоВыбора() у поля Номенклатура, открываете форму выбора номенклатуры. в ней происходит выбор.
2. Обрабатываете событие ОбработкаВыбора() у (скорее всего) формы, в его параметре ВыбранноеЗначение сидит выбранное значение.
3. В этом же событии и запрашиваете количество

Непонятно как это сделать: добавить фвыб.НачалоВыбора()? Но такого события после точки не предлагается, есть только фвыб.НачальноеЗначениеВыбора();
       

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
пункт 1 - не для вашего случая ;)
а вот с ОбработкойВыбора() - в силе.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 231
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Ошибка Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Автор Maks54Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1787
Последний ответ 07 Ноя 2015, 17:27
от pavl_vs
{(1, 1)}: Ожидается выражение "ВЫБРАТЬ"

Автор Sasha133Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1465
Последний ответ 21 Мар 2014, 23:53
от MuI_I_Ika
{(1, 1)}: Ожидается выражение "ВЫБРАТЬ"

Автор Sasha133Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9605
Последний ответ 21 Мар 2014, 10:35
от Sasha133
Ожидается выражение "ВЫБРАТЬ"

Автор АбылайханРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 3010
Последний ответ 30 Мар 2015, 10:04
от Абылайхан

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 280
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal