Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: КД Розница -> УТ Перемещение товара  (Прочитано 998 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ColonelAp4u

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2014-10-24
  • Сайт: 
  • Профессия: Программист 1С
Помогите пожалуйста  ПКД произвольный алгоритм при за грузке в УТ выдает ошибку
Ошибка при записи документа
   ИмяПКО                 =  ПеремещениеТоваровНов
   ТипОбъекта             =  Перемещение товаров
   Объект                 =  Перемещение товаров РТ000000025 от 12.12.2014 8:03:19
   ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ОбработкаПроведения': {ОбщийМодуль.Ценообразование.Модуль(352)}: Поле объекта недоступно для записи (ЕдиницаХраненияОстатков)
   ПозицияМодуля          =  Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(7416)
   КодСообщения           =  25


Оффлайн ColonelAp4u

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2014-10-24
  • Сайт: 
  • Профессия: Программист 1С
это код ПКД
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Дата", ТекущаяДата());
Запрос.Текст =   "ВЫБРАТЬ
 | ПеремещениеТоваровТовары.Ссылка.Номер,
 | ПеремещениеТоваровТовары.Ссылка.Дата,
 | ПеремещениеТоваровТовары.Ссылка.Комментарий,
 | ПеремещениеТоваровТовары.Ссылка.СкладОтправитель,
 | ПеремещениеТоваровТовары.Ссылка.СкладПолучатель,
 | ПеремещениеТоваровТовары.Ссылка.Водитель,
 | ПеремещениеТоваровТовары.Ссылка.ДокументОснование,
 | ПеремещениеТоваровТовары.Номенклатура,
 | ПеремещениеТоваровТовары.Количество,
 | ПеремещениеТоваровТовары.ЕдиницаИзмерения,
 | ПеремещениеТоваровТовары.Цена,
 | ПеремещениеТоваровТовары.Сумма,
 | ПеремещениеТоваровТовары.Коэффициент,
 | ПеремещениеТоваровТовары.Ссылка
 |ИЗ
 | Документ.ПеремещениеТоваров.Товары КАК ПеремещениеТоваровТовары
 |ГДЕ
 | ПеремещениеТоваровТовары.Ссылка.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&Дата, ДЕНЬ) И КОНЕЦПЕРИОДА(&Дата, ДЕНЬ)
 |ИТОГИ ПО
 | ПеремещениеТоваровТовары.Ссылка";


ВыборкаДок = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаДок.Следующий() Цикл

ИсходящиеДанные = Новый Структура();
ИсходящиеДанные.Вставить("Дата" , ВыборкаДок.Ссылка.Дата);
ИсходящиеДанные.Вставить("Номер", ВыборкаДок.Ссылка.Номер);
ИсходящиеДанные.Вставить("Комментарий", ВыборкаДок.Ссылка.Комментарий);
Документ = Новый Структура("Дата,Номер",
ВыборкаДок.Ссылка.ДокументОснование.Дата,
ВыборкаДок.Ссылка.ДокументОснование.Номер);


    ИсходящиеДанные.Вставить("ВнутреннийЗаказ" , Документ);
ИсходящиеДанные.Вставить("Организация"     , "000000001");
    ИсходящиеДанные.Вставить("ОтражатьВУправленческомУчете"    , Истина);
    ИсходящиеДанные.Вставить("Подразделение"   , "УТ0000028");
ИсходящиеДанные.Вставить("СкладОтправитель", Справочники.Склады.НайтиПоКоду("УТ0000009"));
ИсходящиеДанные.Вставить("СкладПолучатель", ВыборкаДок.Ссылка.СкладПолучатель);

Выборка = ВыборкаДок.Выбрать();
ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("ЕдиницаИзмерения");
ТЗ.Колонки.Добавить("Качество");
ТЗ.Колонки.Добавить("Количество");
ТЗ.Колонки.Добавить("Коэффициент");
ТЗ.Колонки.Добавить("Номенклатура");
ТЗ.Колонки.Добавить("Цена");

Пока Выборка.Следующий() Цикл

НоваяСтрока = ТЗ.Добавить();
НоваяСтрока.Качество     = "Новый";
НоваяСтрока.Количество   = Выборка.Количество;
НоваяСтрока.Коэффициент  = Выборка.Коэффициент;
НоваяСтрока.Номенклатура = Выборка.Номенклатура;
НоваяСтрока.Цена         = Выборка.Цена;
НоваяСтрока.ЕдиницаИзмерения         = Выборка.ЕдиницаИзмерения;


КонецЦикла;
ИсходящиеДанные.Вставить("Товары", ТЗ);

ВыгрузитьПоПравилу(,, ИсходящиеДанные, , "ПеремещениеТоваровНов");

КонецЦикла;


Это в ПКО Единицы Измерения
Если Правила.Номенклатура.Выгруженные[Источник.Владелец] = Неопределено Тогда
    ВыгрузитьПоПравилу(Источник.Владелец);
КонецЕсли;                 
Добавлено: 12 Дек 2014, 08:45

и вместе с данной ошибкой в УТ заменились все ед измерения на те которые идут в рознице, и поля ед хран остатков и ед для отчетов стали пустыми


Теги:
 

1c "Розница"

Автор katyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3744
Последний ответ 10 Май 2011, 18:30
от katy
Разыскивается специалист по 1с "Розница" и "Frontol".

Автор ivanilinkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2046
Последний ответ 28 Фев 2016, 15:52
от rossoxa
Обмен данными между 1С УТ (базовая) 8.2 редакция 10.3 и Розница (базовая) редакция 1.0

Автор Андрей ОлимпиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 4996
Последний ответ 17 Мар 2015, 20:16
от дфтын
УТ 10.3 Цена единицы товара в партии и цена списания этой единицы при реализации не совпадают????????????????????????

Автор i_antonРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4863
Последний ответ 31 Янв 2014, 12:22
от i_anton
Не списано 0,0004 кг товара "XXXXX", счет учета 1310, склад Склад материалов

Автор RamirasРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4867
Последний ответ 30 Июл 2015, 09:21
от Макси

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 320
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal