Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнить ТЧ данными справочника  (Прочитано 2559 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн John46

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2010-07-16
  • Сайт: 
Процедура ЗаполнитьСтандартноНажатие(Элемент)
   выборка = Справочники.Материалы.Выбрать();
   пока выборка.Следующий() Цикл
      элемент = выборка.ПолучитьОбъект();
      если не элемент.ЭтоГруппа тогда
         новая = Материалы.Добавить();
         новая.Наименование = элемент.Наименование; // эта строка не работает
         новая.Объект = элемент.Родитель;
         новая.Единицы = элемент.Единицы;
         новая.Цена = элемент.Цена;
         новая.Количество = 1;
         ЭлементыФормы.Материалы.ТекущаяСтрока = новая;
         нов = ЭлементыФормы.Материалы.ТекущаяСтрока;
         нов.Сумма = нов.Количество*нов.Цена;
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры

Варианты этой строки пробовал разные. Остальные поля заполняются. Возможно, не работает потому что Наименование - ссылка на справочник. Тогда как мне заполнить ТЧ? Подскажите пожалуйста!


Оффлайн John46

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2010-07-16
  • Сайт: 
Помогло сделать поле Наименование в тч документа составным типом - строка и ССылка на справочник. Правда при одиночном выборе приходится выбипать тип данных, что не очень удобно. если кто знает другие  решения - подскажите.

Slin
  • Гость
Как вариант, делать не наименование, а ссылку на элемент
потому что, на самом деле, нет разницы для тебя, похоже
наименование будет автоматом подставляться

что-то меня смущает
ЭлементыФормы.Материалы.ТекущаяСтрока = новая;
нов = ЭлементыФормы.Материалы.ТекущаяСтрока;
нов.Сумма = нов.Количество*нов.Цена;
не проще ли сразу
новая.Сумма = новая.Количество * новая.Цена

Оффлайн John46

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2010-07-16
  • Сайт: 
Slin, ты прав - там лишнее, ночью переборщил
Сделал всё намного проще и работает:

Выбор = Новый Запрос( " ВЫБРАТЬ Ссылка как Наименование, Родитель как Объект, Единицы, Цена, 1 как Количество, Цена как сумма
                       |  ИЗ Справочник.Материалы
                       |  ГДЕ Не ЭтоГруппа" );
Материалы.Загрузить(Выбор.Выполнить().Выгрузить());


Выбор = Новый Запрос( " ВЫБРАТЬ Ссылка как Наименование, Родитель как Объект, Единицы, Цена, 1 как Количество, Цена как сумма
                       |  ИЗ Справочник.Работы
                       |  ГДЕ Не ЭтоГруппа" );
Работа.Загрузить(Выбор.Выполнить().Выгрузить());

Slin
  • Гость
Молодец
и, что не маловажно, быстрее работает
:)

Оффлайн John46

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2010-07-16
  • Сайт: 
Спасибо! Для начинающего приятно слышать))


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6492
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 621
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2030
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 268
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 810
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal