Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 16:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка номенклатуры в xml  (Прочитано 1849 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
УТ 11
дописываю типовую выгрузку номенклатуры на сайт по средствам xml
Добавил в номенклатуру реквизит "Длина", подхватил в запросах и уже хотел вывести его, НО!
Формирование xml проходит с использованием XDTO, которое я никогда не ковырял.
        XDTOТоварыТип 	= ПолучениеТипОбъектаXDTO(ПараметрыОбмена,  "Товары", Истина, ВладелецТип);
XDTOТовары = ПараметрыОбмена.МояФабрикаXDTO.Создать(XDTOТоварыТип);
XDTOТоварТип = ПолучениеТипОбъектаXDTO(ПараметрыОбмена,  "Товар");

Для каждого ТекТовар из ТзнТоваров Цикл

XDTOТовар = ПараметрыОбмена.МояФабрикаXDTO.Создать(XDTOТоварТип);
                        .....
                        Если ЗначениеЗаполнено(ТекТовар.Вес) Тогда
XDTOТовар.Вес = ТекТовар.Вес;
КонецЕсли;
                        Если ЗначениеЗаполнено(ТекТовар.Длина) Тогда
//XDTOТовар.Длина = ТекТовар.Длина;  // XDTOТовар.Длина - не существует в этой структуре
КонецЕсли;
////////////////
Функция ПолучениеТипОбъектаXDTO(ПараметрыОбмена, Объект, Сложный = Ложь, ВладелецТип = Неопределено) Экспорт
Если Сложный тогда
Возврат ВладелецТип.Свойства.Получить(Объект).Тип;
иначе
Возврат ПараметрыОбмена.МояФабрикаXDTO.Тип(ПараметрыОбмена.ПространствоИмен,Объект);
КонецЕсли;
КонецФункции



XDTOТовар хранит все характеристики товара, которые будут выводиться. Не могу понять, как добавить в этот список еще реквизит "Длина"
Кто подскажет куда копать?


Оффлайн sertak

  • ****
  • Сообщений: 323
  • РЕПУТАЦИЯ: 92
  • КПД: 28%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: infostart.ru
В конфигураторе Общие - XDTO-пакеты, находите свой объект и добавляете в нужную ветку реквизит. Там не будет веселенького привычного дерева, но программисту разобраться много времени не займет.


Теги:
 

"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 9219
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2917
Последний ответ 29 Июн 2011, 21:11
от joyer
выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4885
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2989
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 9315
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
55 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal