Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как создать новую форму  (Прочитано 2471 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Версия программы - 1С 7.7 Торговля и склад.
Я хочу создать новую форму, создаю справочник, добавляю реквизиты, открываю "Форма_Элемента", перетаскиваю всё как надо мне, сохраняю. Но в итоге отображается таблица с колонками, а не форма с полями.
Как создавать ФормуЭлемента, чтобы она отображалась пользователю?
Подскажите мануал, который стоит изучить.

Спасибо.


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Как создавать ФормуЭлемента, чтобы она отображалась пользователю?

В конфигураторе по справочнику выполните двойной клик левой кнопки мыши.
В появившемся окне, в поле Редактировать выберите режим "В диалоге" и сохраните.




Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Спасибо, то что надо )
Добавлено: 10 Дек 2014, 17:09

Ещё вопрос, как взять из справочника "Сотрудники" их ФИО(3 поля) и записать это значение в другое поле?

Даже больше интересует, где хранятся процедуры типа ПриИзменении, ПриОткрытии и т.д. как это в 1С 8 реализовано?
Добавлено: 10 Дек 2014, 17:13

Написал так:
Процедура СотрудникПриИзменении()
Наименование=Имя+Фамилия+Отчество;
КонецПроцедуры
Но это не работает...

Последний раз редактировалось: keramik; 10 Дек 2014, 17:13. Причина: Объединение сообщений

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Но это не работает...

должно работать. может просто СотрудникПриИзменении() ни откуда не вызывается.

ПриОткрытии() - в любом модуле формы (справочника, документа, отчета).

ПриИзменении() - не предопределенная процедура, может быть где угодно.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за ответ. А где привязывать процедуру?
Вот у меня есть поле на форме "Сотрудник", в "Форма_элемента" открываю закладку "Модуль" и пишу
Процедура СотрудникПриИзменении()
Наиенование=Имя+Фамилия+Отчество;
КонецПроцедуры;
Но я пока не понимаю, как передать программе, что поле "Сотрудник" должно использовать эту процедуру?
Мож есть мануал какой, где подобные вопросы расписаны?

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Но я пока не понимаю, как передать программе, что поле "Сотрудник" должно использовать эту процедуру?
Мож есть мануал какой, где подобные вопросы расписаны?

в свойства поля заходите, и в формуле указываете процедуру, которую нужно вызвать.

Мануал - желто красные книжки по конфигурированию и программированию 1с 77

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Так-так-так, я кое-что нашёл.
Работает, если использовать код
Процедуры ПриИзменении(Сотрудник)
...
КонецПроцедуры
Выводит значение :)


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal