Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вставить данные в таблицу  (Прочитано 2197 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
здраствуйте у меня такой вопрос есть данные типа строка,они считываются сканером в поле штрихкод как втавить данные в поле таблици в столбец обьек и как вобще работать с таблицей в 1с в делфи понятно стрингрид[0,1]:=x;
обьясните кому не жалко, надо срочно.рисунок прилагается


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Источникомданныхтабличнойчастинаформедокументаявляетсятаблицазначенийеёзнченияинужноменять.

Оффлайн KKurgan

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 7
  • КПД: 54%
  • Регистрация: 2014-11-17
  • Сайт: 
Во первых, обратите внимание, что в данном случае вы работаете не с таблицей а с коллекциями. Если нужно обратиться к полю табличной части объекта:
Объект.ЛицевыеСчета[индекс].Объект = ...
Но в вашем случае, если я правильно понял, что требуется, нужно присвоить значение полю в текущей строке табличной части:
Элементы.ЛицевыеСчета.ТекущиеДанные.Объект = ...

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
Вот вроде весь код мне нужно чтобы строка  ИскомаяСтрока    -( это личный счёт, он выделяется из qr кода) вставлялась в строку таблици в столбец обьекта я немогу понять где мне подставить его чтоб он его вставил

// Обработчик события "ПриИзменении" поля "ТекущийШтрихКод".

Процедура ТекущийШтрихКодПриИзменении(Элемент)

 Если Не ПустаяСтрока(ТекущийШтрихКод) Тогда
 если найти(ТекущийШтрихКод,"persAcc=╨╗/╤Б тДЦ") тогда
 с=найти(ТекущийШтрихКод,"persAcc=╨╗/╤Б тДЦ");
 СтрокаПоиска = Сред(ТекущийШтрихКод, с+17);
 с = Найти(СтрокаПоиска, "|");

 ИскомаяСтрока ="л/с №"+Лев(СтрокаПоиска, с-1);

 конецесли;
 ОбработатьШтрихКод(ТекущийШтрихКод);
 ТекущийШтрихКод = "";
 ТекущийЭлемент =Элемент;
 КонецЕсли;

КонецПроцедуры

// Процедура обрабатывает штрих-код, который был прочитан при помощи сканера
// штрих-кодов или который был загружен из терминала сбора данных
//// Параметры
//  Данные        – <Строка>
//                - строка, содержащая штрих-код
//
Процедура ОбработатьШтрихКод(Знач Данные)

Парам = Новый Структура("КодЛС, Сумма, МесяцНачисления");
мНастройкиУчетнойПолитикиТСЖ = ПолучитьНастройкиУчетнойПолитикиЖКХ();
Если Не КВП_ПрочиеПроцедурыИФункции.ОбработатьИРазобратьШтрихКод(Данные, мНастройкиУчетнойПолитикиТСЖ, Парам) Тогда
УПЖКХ_ТиповыеМетодыКлиентСервер.СообщитьОбОшибке("Неизвестный формат штрих-кода.");
возврат;
КонецЕсли;
Парам.Вставить("Объект",Парам.КодЛС);
 Если ЗначениеЗаполнено(Парам.МесяцНачисления)     И мНастройкиУчетнойПолитикиТСЖ.РегистрацияОплатыПоШКНаУказанныйМесяц Тогда
НастройкиПлатежа = Новый ТаблицаЗначений;
НастройкиПлатежа.Колонки.Добавить("Услуга");
НастройкиПлатежа.Колонки.Добавить("МесяцНачисления");
НастройкиПлатежа.Добавить().МесяцНачисления = Парам.МесяцНачисления;
Иначе   НастройкиПлатежа = Неопределено;
КонецЕсли;      
         ДобавитьСтрокуОплатыПоОбъектуНаСервере(Парам, НастройкиПлатежа);
ЗаполнитьДопДанныеВТаблице();
КонецПроцедуры;

// Добавляет строку оплаты по объекту.

Процедура ДобавитьСтрокуОплатыПоОбъектуНаСервере(Парам, НастройкиПлатежа)
ДокументОбъект = РеквизитФормыВЗначение("Объект", Тип("ДокументОбъект.КВП_РегистрацияОплаты"));
ДокументОбъект.ДобавитьСтрокуОплатыПоОбъекту(Парам, НастройкиПлатежа);
ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
КонецПроцедуры;

// Процедура заполнения дополнительных данных
// в строках дерева.

Процедура ЗаполнитьДопДанныеВТаблице()   СписокЛС = Объект.ЛицевыеСчета.Выгрузить().ВыгрузитьКолонку("Объект");
мТаблицаДанныхЛС = ПолучитьПараметрыЛицевыхСчетовДляВыводаВТаблицах(СписокЛС, Объект.Дата);
Для Каждого ТекСтрока Из мТаблицаДанныхЛС Цикл   СтрокиТаблицы = Объект.ЛицевыеСчета.НайтиСтроки(Новый Структура("Объект", ТекСтрока.ЛицевойСчет));
Для Каждого ТекСтрокаТаблицы Из СтрокиТаблицы Цикл   ТекСтрокаТаблицы.Помещение = ТекСтрока.Помещение;
ТекСтрокаТаблицы.Владелец  = ТекСтрока.Владелец;
КонецЦикла;
КонецЦикла;
Для Каждого ТекСтрокаДанных Из Объект.ЛицевыеСчета Цикл   ТекСтрокаДанных.ФлагРедактированияНастроек = ?(ТекСтрокаДанных.ВариантРаспределения = "", 1, 0);
ТекСтрокаДанных.ПробитыйЧек = ?(ТекСтрокаДанных.НомерЧекаККМ = 0, 1, 0);
КонецЦикла;
КонецПроцедуры;

// Формирует таблицу параметров лицевых счетов для облегчения вывода в
// табличных полях.
//
// Параметры:
//  СписокЛицевыхСчетов - Массив или Список значений - список лицевых
//                 счетов, по которым необходимы данные
//  Период       - Дата - дата получения данных
//  ЗапросПараметровЛС - Запрос - переменная для хранения запроса - для
//                 избежания множественной инициализации
/// Возвращаемое значение:
//  Таблица значений с колонками: "ЛицевойСчет", "Помещение" и "Владелец",
//  проиндексированная по колонке "ЛицевойСчет".
//
Функция ПолучитьПараметрыЛицевыхСчетовДляВыводаВТаблицах(СписокЛицевыхСчетов,   Период,    ЗапросПараметровЛС = Неопределено) Экспорт
Если ЗапросПараметровЛС = Неопределено Тогда   ЗапросПараметровЛС = Новый Запрос();   ЗапросПараметровЛС.Текст =
"ВЫБРАТЬ   |   ДанныеЛС.ЛицевойСчет,   |   ДанныеЛС.Здание КАК Здание,   |   ДанныеЛС.Помещение КАК Помещение,   |   УПЖКХ_ОтветственныйСобственникНанимательЛицевогоСчетаСрезПоследних.ОтветственныйВладелец КАК Владелец,   |   ДанныеЛС.Помещение.Представление КАК ПомещениеПредставление,   |   УПЖКХ_ОтветственныйСобственникНанимательЛицевогоСчетаСрезПоследних.ОтветственныйВладелец.Представление    |   КАК ВладелецПредставление   |ИЗ   |   (ВЫБРАТЬ   |   КВП_ЛицевыеСчета.Ссылка КАК ЛицевойСчет,   |   КВП_ЛицевыеСчета.Адрес КАК Помещение,   |   КВП_ЛицевыеСчета.Адрес.Владелец КАК Здание   |   ИЗ   |   Справочник.КВП_ЛицевыеСчета КАК КВП_ЛицевыеСчета   |   ГДЕ   |   КВП_ЛицевыеСчета.Ссылка В(&СписокЛС)) КАК ДанныеЛС   |   ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.УПЖКХ_ОтветственныйСобственникНанимательЛицевогоСчета.СрезПоследних(&Дата,    |   ЛицевойСчет В (&СписокЛС))    |   КАК УПЖКХ_ОтветственныйСобственникНанимательЛицевогоСчетаСрезПоследних   |   ПО ДанныеЛС.ЛицевойСчет = УПЖКХ_ОтветственныйСобственникНанимательЛицевогоСчетаСрезПоследних.ЛицевойСчет";
КонецЕсли;

ЗапросПараметровЛС.УстановитьПараметр("СписокЛС", СписокЛицевыхСчетов);   ЗапросПараметровЛС.УстановитьПараметр("Дата",     Период);   ТаблицаДанныхЛС = ЗапросПараметровЛС.Выполнить().Выгрузить(); ТаблицаДанныхЛС.Индексы.Добавить("ЛицевойСчет");
Возврат ТаблицаДанныхЛС;
КонецФункции

// ПолучитьПараметрыЛицевыхСчетовДляВыводаВТаблицах()


Теги:
 

Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4845
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3798
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 8145
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6975
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 970
Последний ответ 01 Мар 2016, 14:33
от sveta C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 240
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal