Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не верный банковский счет в документе  (Прочитано 1643 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! В базе Две организации.Одна выбрана как основаная. Почему то при создание документа счет на оплату покупателю подставляется банковский счет старой организации, хотя на форме выбрана новая.если перевыбрать организацию банковский счет встает верный. Удалось выяснить что в документе реквизит получатель оплаты(который скрыт на форме) хранит старую организацию, поэтому и счет подставляется старый. как он туда попадает не могу понять?и при создании на сервере и при открытии уже подставлена она, но в каком месте может в общем модуле где?бп 30 типовая, это может в настройках где указывается?помогите пожалуйста!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

   ТипДанныхЗаполнения = ТипЗнч(ДанныеЗаполнения);
   Если ДанныеЗаполнения <> Неопределено И ТипДанныхЗаполнения <> Тип("Структура")
      И Метаданные().ВводитсяНаОсновании.Содержит(ДанныеЗаполнения.Метаданные()) Тогда
      ЗаполнитьПоДокументуОснованию(ДанныеЗаполнения);
   Иначе
      СуммаВключаетНДС = Истина;
   КонецЕсли;
   ЗаполнениеДокументов.Заполнить(ЭтотОбъект, ДанныеЗаполнения);

   Если ЗначениеЗаполнено(СтруктурнаяЕдиница) Тогда
      ОрганизацияПолучатель = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СтруктурнаяЕдиница, "Владелец");
   Иначе
      ОрганизацияПолучатель = Организация;
   КонецЕсли;


КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

   ТипДанныхЗаполнения = ТипЗнч(ДанныеЗаполнения);
   Если ДанныеЗаполнения <> Неопределено И ТипДанныхЗаполнения <> Тип("Структура")
      И Метаданные().ВводитсяНаОсновании.Содержит(ДанныеЗаполнения.Метаданные()) Тогда
      ЗаполнитьПоДокументуОснованию(ДанныеЗаполнения);
   Иначе
      СуммаВключаетНДС = Истина;
   КонецЕсли;
   ЗаполнениеДокументов.Заполнить(ЭтотОбъект, ДанныеЗаполнения);

   Если ЗначениеЗаполнено(СтруктурнаяЕдиница) Тогда
      ОрганизацияПолучатель = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СтруктурнаяЕдиница, "Владелец");
   Иначе
      ОрганизацияПолучатель = Организация;
   КонецЕсли;


КонецПроцедуры

а где заполняются данные заполнения?там же уже хранится старая организация.нужно выяснить, но программно не хотелось бы конфу трогать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
если в форме списка отбор выполнен то ДанныеЗаполнения - структура с полями отбора.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
если в форме списка отбор выполнен то ДанныеЗаполнения - структура с полями отбора.

Проблема решена! Был указан основной банковский счет у старой организации, перевыбрал на новую а со старой убрал. всё заработало как надо!Всем спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 135
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal