Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: qr код  (Прочитано 1271 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий1991

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 8.1
qr код
« Первое сообщение: 04 Дек 2014, 16:02 »
здравствуйте прошу извинить если задаю глупый вопрос я просто только начинаю программировать в 1с,а зделать надо срочно
как этот код поменять, чтобы дата вывадилась не в формате 12.02.2004, а в 12022004 и номер лицевого счета не в л/с №433 а просто 433

Функция СформироватьШтрихкодИзШаблона(Параметры, ПарамУчетнойПолитики) Экспорт
   
   // Дополним структуру параметров.
   Параметры.Вставить("Константа", СокрЛП(ПарамУчетнойПолитики.КонстантаОрганизацииДляШтрихКода));
   Если Параметры.Свойство("Дата") Тогда
      Параметры.Вставить("МесяцОплаты", Формат(Параметры.Дата, "ДФ=MM"));
      Параметры.Вставить("ГодОплаты",   Формат(Параметры.Дата, "ДФ=yy"));
   КонецЕсли;
   Если Параметры.Свойство("ЛицевойСчет") Тогда
      Если ПарамУчетнойПолитики.ИдентификаторЛСШтрихкода Тогда
         Параметры.Вставить( "КодЛС",
                        УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(СокрЛП(Параметры.ЛицевойСчет.Идентификатор),
                                                          ПарамУчетнойПолитики.ДлинаИдентификатораШтрихкода,
                                                          "0"));
      Иначе
         Параметры.Вставить("КодЛС", УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(СокрЛП(Параметры.ЛицевойСчет.Код), 9, "0"));
      КонецЕсли;
   КонецЕсли;
   Если Параметры.Свойство("Сумма") Тогда
      Если ПарамУчетнойПолитики.РазделительДробнойЧастиСуммы = "не выводить" Тогда
         Параметры.Вставить("СуммаКОплате", УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(Формат(Параметры.Сумма * 100, "ЧГ=0"),
                                                                  ПарамУчетнойПолитики.ДлинаСуммыШтрихкода,
                                                                  "0"));
      ИначеЕсли ПарамУчетнойПолитики.РазделительДробнойЧастиСуммы = " . (точка)" Тогда
            Параметры.Вставить("СуммаКОплате", УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(Формат(Параметры.Сумма, "ЧДЦ=2; ЧРД=.; ЧН=; ЧГ=0"),
                                                                  ПарамУчетнойПолитики.ДлинаСуммыШтрихкода + 1,
                                                                  "0"));
      ИначеЕсли ПарамУчетнойПолитики.РазделительДробнойЧастиСуммы = " , (запятая)" Тогда
            Параметры.Вставить("СуммаКОплате", УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(Формат(Параметры.Сумма, "ЧДЦ=2; ЧРД=,; ЧН=; ЧГ=0"),
                                                                  ПарамУчетнойПолитики.ДлинаСуммыШтрихкода + 1,
                                                                  "0"));
      КонецЕсли;
   КонецЕсли;
   
   ТекстКода = СокрЛП(ПарамУчетнойПолитики.КодОрганизацииДляШтрихКода);
   
   // сформируем текст штрихкода.
   ТекстКода = ТекстКода + Параметры.КодЛС + Параметры.МесяцОплаты
   + Параметры.ГодОплаты + Параметры.СуммаКОплате;
   УПЖКХ_РаботаСоШтрихкодомВызовСервера.ВставитьКонтрольнуюСтрокуШК(ТекстКода, ПарамУчетнойПолитики);
   
   Возврат ТекстКода;
   
КонецФункции // СформироватьШтрихкодИзШаблона()

заранее спасибо   


Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Re: qr код
« Ответ #1: 04 Дек 2014, 16:16 »
Надо бы знать какой параметр отвечает за Дату которая вам нужна и за Лицевой счёт...

Я вижу у вас Месяц и Год, но не вижу дату...
И не вижу где у вас НомерЛицевогоСчёта передаётся...

Для лицевого счёта можно написать Параметры.КодЛС = СтрЗаменить(Параметры.КодЛС, "л/c №", "");
А для даты  Параметры.Дата = Формат(Параметры.Дата,"ДФ=ddMMyyyy");

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: qr код
« Ответ #2: 05 Дек 2014, 06:17 »
чтобы дата вывадилась не в формате 12.02.2004, а в 12022004

у вас дата не в виде "12.02.2004" а в виде "0204"...

номер лицевого счета не в л/с №433 а просто 433

вот тут ковыряйте
Если Параметры.Свойство("ЛицевойСчет") Тогда
      Если ПарамУчетнойПолитики.ИдентификаторЛСШтрихкода Тогда
         Параметры.Вставить( "КодЛС",
                        УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(СокрЛП(Параметры.ЛицевойСчет.Идентификатор),
                                                          ПарамУчетнойПолитики.ДлинаИдентификатораШтрихкода,
                                                          "0"));
      Иначе
         Параметры.Вставить("КодЛС", УПЖКХ_ТиповыеМетодыКлиентСервер.ДополнитьСтроку(СокрЛП(Параметры.ЛицевойСчет.Код), 9, "0"));
      КонецЕсли;
   КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 205
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal