Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Условие на запись документа  (Прочитано 1623 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dob

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-02
  • Сайт: 
  • Профессия: Ученик 1С
Приветствую всех!
Помогите плиз решить задачку.
В документе заказ пок-ля есть поле статус. Надо написать условие, если в заказ ставят статус "Утвержден" и дата документа меньше текущей, то отказ в записи.

Если  ЭтотОбъект.Статус.Утвержден = Истина  и ЭтотОбъект.Дата <> ТекущаяДата() Тогда
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "Измените дату документа на текущую";
Отказ = Истина;

КонецЕсли;

Как то так, но фигня и не работает.
И куда код вставлять? При записи? Перед записью?




Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
В модуле объекта:
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
    Если ЭтотОбъект.Статус = Перечисления.<имя_перечисления>.Утвержден И НачалоДня(ЭтотОбъект.Дата) <> НачалоДня(ТекущаяДата()) Тогда
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Измените дату документа на текущую";
        Сообщение.Сообщить();
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры
Добавлено: 02 Дек 2014, 16:15

Если же надо запретить даже запись, тогда перенесите тот же код в обработчик ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения) модуля объекта.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн dob

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-12-02
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое за столь быстрый ответ)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15947
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal